The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проброс портов через NAT модель ASA 5510"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Проброс портов через NAT модель ASA 5510"  
Сообщение от Леонид email(??) on 22-Авг-08, 11:25 
Доброго времени суток.
может этот вопрос и звучал неоднократно, но на счет асы мало я нашел здесь :(
есть 3 интерфейса:

interface Ethernet0/0
nameif outside
security-level 0
ip address х.х.х.х 255.255.255.252
!
interface Ethernet0/1
nameif DMZ
security-level 1

!
interface Ethernet0/2
nameif inside
security-level 100
ip address 10.0.6.1 255.255.255.0

для проброски порта 8080 для внутренного айпи пишу следующее
static (inside,outside) udp 10.0.6.113 8080 x.x.x.x 8080

x.x.x.x внешний айпишник

я полагаю эта строка правильная, н омне кажется что нужно еще прописать что-то в аксес листы. проблема только в том что именно :(

собственно поэтому прошу помощи.


Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проброс портов через NAT модель ASA 5510"  
Сообщение от sh_ email(??) on 22-Авг-08, 12:11 
Перепутали
static (inside,outside) udp x.x.x.x 8080 10.0.6.113 8080
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Проброс портов через NAT модель ASA 5510"  
Сообщение от ural_sm (ok) on 22-Авг-08, 12:14 
Так надо делать.. когда на ИП привязываешь то не работает.

static (inside,outside) udp interface 8080 10.0.6.113  8080 netmask 255.255.255.255
и почему UDP?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Леонид email(??) on 22-Авг-08, 12:48 
>Так надо делать.. когда на ИП привязываешь то не работает.
>
>static (inside,outside) udp interface 8080 10.0.6.113  8080 netmask 255.255.255.255
>и почему UDP?

спасибо за ответ. знаешь просто опыта мало и тренируюсь на том, что реально могу проверить.
вв данном случае UDP позволяет использовать большую пропускную способность, правда не сильно надежен. мне он интересен для систем peer-to-peer.
а аксес лист нужен для этого правила?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Леонид email(??) on 22-Авг-08, 12:59 
тю, странно чего то не пашет....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Ash (??) on 22-Авг-08, 13:01 
>>Так надо делать.. когда на ИП привязываешь то не работает.
>>
>>static (inside,outside) udp interface 8080 10.0.6.113  8080 netmask 255.255.255.255
>>и почему UDP?
>
>спасибо за ответ. знаешь просто опыта мало и тренируюсь на том, что
>реально могу проверить.
>вв данном случае UDP позволяет использовать большую пропускную способность, правда не сильно
>надежен. мне он интересен для систем peer-to-peer.
>а аксес лист нужен для этого правила?

Да на обеих интерфейсах

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Проброс портов через NAT модель ASA 5510"  
Сообщение от dxer on 22-Авг-08, 13:17 
>[оверквотинг удален]
>>>static (inside,outside) udp interface 8080 10.0.6.113  8080 netmask 255.255.255.255
>>>и почему UDP?
>>
>>спасибо за ответ. знаешь просто опыта мало и тренируюсь на том, что
>>реально могу проверить.
>>вв данном случае UDP позволяет использовать большую пропускную способность, правда не сильно
>>надежен. мне он интересен для систем peer-to-peer.
>>а аксес лист нужен для этого правила?
>
>Да на обеих интерфейсах

nat-control включите.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Леонид email(??) on 22-Авг-08, 13:32 
>[оверквотинг удален]
>>>
>>>спасибо за ответ. знаешь просто опыта мало и тренируюсь на том, что
>>>реально могу проверить.
>>>вв данном случае UDP позволяет использовать большую пропускную способность, правда не сильно
>>>надежен. мне он интересен для систем peer-to-peer.
>>>а аксес лист нужен для этого правила?
>>
>>Да на обеих интерфейсах
>
>nat-control включите.

то бишь?  сори, просто действительно не сильно разбираюсь.

такой аксес лист подойдет, он конечно как бы для всех
access-list 110 permit udp any any eq 8080
или нужен более конкретный?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Ash (??) on 22-Авг-08, 14:05 
кажеться так надо, если ошибаюсь поправьте
во всяком случае у меня так работало
я RDP прокидывал на время отпуска

на outside
access-list outside_access_in extended permit udp any host IPвнешний  eq 8080
на inside
access-list inside_access_in extended permit udp any host IPвнутренний

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Леонид email(??) on 22-Авг-08, 14:42 
static (inside,outside) udp x.x.x.x 8080 10.0.6.113 8080

access-list inside_access_in extended permit udp any host 10.0.6.113
access-list outside_access_in extended permit udp any host 213.133.167.30 eq 8080

таков конфиг, но если проверять порт извне, то он закрыт.

а что там на счет nat-control, может в этом дело?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Проброс портов через NAT модель ASA 5510"  
Сообщение от sh_ email(??) on 22-Авг-08, 14:49 
А как вы проверяете порт извне? Может вам действительно нужно tcp порт использовать?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Леонид email(??) on 22-Авг-08, 15:12 
http://www.utorrent.com/testport.php?port=8080 с помощью этой ссылки на www.portforward.com
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Леонид email(??) on 22-Авг-08, 15:26 
http://whatsmyip.org/ports/ можно еще по этой ссылке здесь даже лучше
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Cwer74 email(ok) on 26-Авг-08, 15:21 
>static (inside,outside) udp x.x.x.x 8080 10.0.6.113 8080
>
>access-list inside_access_in extended permit udp any host 10.0.6.113
>access-list outside_access_in extended permit udp any host 213.133.167.30 eq 8080
>
>таков конфиг, но если проверять порт извне, то он закрыт.
>
>а что там на счет nat-control, может в этом дело?

аксесс листы надо привязывать к интерфейсу
access-group outside_access_in in interface outide
и достаточно прописать отлько для внешнего интерфейса

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Cwer74 email(ok) on 26-Авг-08, 15:27 
мне кажется все таки эти ссылки проверяют tcp порты
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Леонид email(??) on 27-Авг-08, 15:05 
спасибо за совет. да действительно нужно было tcp. релаьно в этом затык был
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Проброс портов через NAT модель ASA 5510"  
Сообщение от ural_sm (ok) on 28-Авг-08, 07:26 
То есть у тебя все заработало?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Проброс портов через NAT модель ASA 5510"  
Сообщение от Леонид email(??) on 28-Авг-08, 09:31 
static (inside,outside) udp x.x.x.x 8080 10.0.6.113 8080
>
>access-list inside_access_in extended permit udp any host 10.0.6.113
>access-list outside_access_in extended permit udp any host 213.133.167.30 eq 8080

да, вот здесь просто нужно было поменять udp на tcp, и все прекрассно работает! просто я думал, исходя из прочитанного ранее что нужно открывать именно udp порты, а оказывается tcp :) короче кто-то лажанулся, а я на єто повелся....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру