The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"SI2000 -> КВАНТ-Е -> AS5350 = VoIP"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VoIP)
Изначальное сообщение [ Отслеживать ]

"SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от iles email(ok) on 15-Янв-09, 10:38 
Всем доброго дня. Вообщем имеется cisco 5350 голосовая. Через PRI-30 подрублена к городской станции КВАНТ-Е. Через данный линк имеем подключение к "горожанам". Далее КВАНТ-Е подключен к SI2000 (как точно не знаю, но думаю по ОКС-7)
На циску заведена городская нумерация с выделенным префиксом. (нумерация используется далее для проброса городских звонков на VoIP-телефоны)
Так же на циске поднята карточная платформа.

конфиги:

boot-start-marker
boot system flash flash:c5350-ik8s-mz.123-19.bin
boot system flash flash:c5350-is-mz.122-2.XB10.bin
no boot startup-test
boot-end-marker
!
no logging monitor

!

!
resource-pool disable
clock timezone msk3 3
clock summer-time msk3 recurring last Sun Mar 2:00 last Sun Oct 3:00
clock calendar-valid
syscon shelf-id 1
spe country russia
!
spe recovery port-action recover
spe default-firmware spe-firmware-1
aaa new-model
aaa session-mib disconnect
!
!
aaa authentication password-prompt password:
aaa authentication username-prompt login:
aaa authentication login default local
aaa authentication login h323 group radius
aaa authentication login LINE-VTY local
aaa authentication ppp default group radius
aaa authorization exec default local group radius
aaa authorization exec h323 group radius
aaa authorization network default local group radius
aaa accounting update periodic 3
aaa accounting network default start-stop group radius
aaa accounting connection h323 start-stop group radius
aaa session-id common
ip subnet-zero
!
!
ip cef
ip name-server 213.xxx.xx.20
!
async-bootp dns-server 213.xxx.xxx.20 79.xxx.xxx.2
isdn switch-type primary-net5
!
voice call send-alert
!
voice class codec 701
codec preference 1 g729r8
codec preference 2 g729br8
codec preference 3 g723r63
codec preference 4 g723r53
codec preference 5 g723ar63
codec preference 6 g723ar53
!

!
fax interface-type fax-mail
!

!
controller E1 3/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 3/1
shutdown
pri-group timeslots 1-31

!
policy-map OUT
!
gw-accounting h323
gw-accounting h323 vsa
gw-accounting voip

!!!!!!!!!!!!!!!!!

interface Serial3/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice modem 64
isdn guard-timer 20000
isdn calling-number 630000
isdn send-alerting
isdn negotiate-bchan
isdn bchan-number-order ascending
isdn sending-complete
no cdp enable


interface Group-Async1
ip unnumbered Loopback0
ip nat inside
encapsulation ppp
ip policy route-map PPPoE
async mode dedicated
peer default ip address pool setup_pool
ppp authentication pap
group-range 1/00 1/59

radius-server attribute 44 include-in-access-req
radius-server configure-nas
radius-server host 213.xxx.xxx.2 auth-port 1945 acct-port 1946
radius-server key 7 xxxxxxxxxxxxxxx
radius-server vsa send accounting
radius-server vsa send authentication

call application voice debit1 tftp://213.xxx.xxx.2/debitcard.1.1.4.tcl
call application voice debit1 uid-len 6
call application voice debit1 pin-len 6
call application voice debit1 language 0 ru
call application voice debit1 set-location ru 0 tftp://213.xxx.xxx.2/prompts/ru/


voice-port 3/0:D
cptone RU
bearer-cap Speech
!
voice-port 3/1:D
playout-delay mode fixed
cptone RU
bearer-cap Speech


dial-peer voice 8766 pots
application debit1
incoming called-number 6[7,3]0000
answer-address 630000
destination-pattern 7876.......
translate-outgoing called 7876
direct-inward-dial
port 3/0:D


dial-peer voice 631111 pots
application data_dialpeer
incoming called-number 6[7,3]1111


dial-peer voice 6300002 pots
description TELEKOM-PSTN-IN
incoming called-number 63[01,02,03,04,05,06,07,08,09]..
direct-inward-dial
forward-digits all
!
dial-peer voice 63600022 voip
description TELEKOM-PSTN-OUT
destination-pattern 63[01,02,03,04,05,06,07,08,09]..
translate-outgoing called 27
voice-class codec 701
session target ipv4:79.xxx.xxx.4
dtmf-relay h245-alphanumeric
ip qos dscp cs5 media

dial-peer voice 8104 voip
description MVTS-216
destination-pattern .T
progress_ind setup enable 3
progress_ind progress enable 8
translate-outgoing called 7095
voice-class codec 701
session target ipv4:79.XXX.XXX.4
ip qos dscp cs5 media


а вот теперь момент - номер карточной платформы - 630000, номер офиса - 630009
и, если "горожанин" (тот что подкрублен напрямую к кванту) звонит на 630000 - слышит приглашение, на 630009 - слышит оператора. НО..... если звонить с мобил (которые попадают на квант через SI2000) - то 630000 - идет сброс, а вот на 630009 - дозванивается без проблем!!.

Лог звонка "горожанина":

00:22:02: ISDN Se3/0:15 Q931: RX <- SETUP pd = 8  callref = 0x2100
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech  
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA9839A
                Exclusive, Channel 26
        Progress Ind i = 0x8281 - Call not end-to-end ISDN, may have in-band info  
        Calling Party Number i = 0x0183, '4551430'
                Plan:ISDN, Type:Unknown
        Called Party Number i = 0x81, '630000'
                Plan:ISDN, Type:Unknown
00:22:02: ISDN Se3/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0xA100
        Channel ID i = 0xA9839A
                Exclusive, Channel 26
00:22:02: ISDN Se3/0:15 Q931: TX -> CONNECT pd = 8  callref = 0xA100
00:22:02: ISDN Se3/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x2100
00:22:27: ISDN Se3/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x2100
        Cause i = 0x8490 - Normal call clearing
        Progress Ind i = 0x8488 - In-band info or appropriate now available
00:22:27: ISDN Se3/0:15 Q931: call_disc: PI received in disconnect; Postpone sending RELEASE for callid 0x16
00:22:27: ISDN Se3/0:15 Q931: TX -> RELEASE pd = 8  callref = 0xA100
00:22:27: ISDN Se3/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x2100

лог звонка с "мобильника" (через SI2000):
00:23:07: ISDN Se3/0:15 Q931: RX <- SETUP pd = 8  callref = 0x2100
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech  
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA9839B
                Exclusive, Channel 27
        Progress Ind i = 0x8281 - Call not end-to-end ISDN, may have in-band info  
        Calling Party Number i = 0x0183, '6445827'
                Plan:ISDN, Type:Unknown
        Called Party Number i = 0x81, '630000'
                Plan:ISDN, Type:Unknown
00:23:07: ISDN Se3/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0xA100
        Channel ID i = 0xA9839B
                Exclusive, Channel 27
00:23:07: ISDN Se3/0:15 Q931: TX -> CONNECT pd = 8  callref = 0xA100
00:23:07: ISDN Se3/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x2100
00:23:08: ISDN Se3/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x2100
        Cause i = 0x8490 - Normal call clearing
        Progress Ind i = 0x8488 - In-band info or appropriate now available
00:23:08: ISDN Se3/0:15 Q931: call_disc: PI received in disconnect; Postpone sending RELEASE for callid 0x17
00:23:08: ISDN Se3/0:15 Q931: TX -> RELEASE pd = 8  callref = 0xA100
00:23:08: ISDN Se3/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x2100


Самое что интересное, если "горожанин" будет звонить на 630000 не прямым набором, а через "восьмерку" (то есть как бы на межгород, в этом случае он попадает на SI2000, с нее снова заворачивается на КВАНТ и идет на циску) - то его звонок тоже сбрасывается, но на 630009 - проходит на ура.

Есть у кого мысли ????

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от Alex email(??) on 15-Янв-09, 11:47 
Посмотрите более внимательно на
destination-pattern 63[01,02,03,04,05,06,07,08,09]..
Обычно воспринимется как все 63, а не 630. .
Для проверки набора используйте
sh dialplan number 630000
sh dialplan number 630009

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от iles email(ok) on 15-Янв-09, 12:29 
>Посмотрите более внимательно на
>destination-pattern 63[01,02,03,04,05,06,07,08,09]..
>Обычно воспринимется как все 63, а не 630. .
>Для проверки набора используйте
>sh dialplan number 630000
>sh dialplan number 630009

Удалил все пиры кроме:

ial-peer voice 8766 pots
application debit1
incoming called-number 630000
answer-address 630000
destination-pattern 7876.......
translate-outgoing called 7876
direct-inward-dial
port 3/0:D


dial-peer voice 631111 pots
application data_dialpeer
incoming called-number 6[7,3]1111


циска стала говорить:
CISCO-5350#sh dialplan number 630000
Macro Exp.: 630000
No match, result=1


Лог (по прежнему сбрасывает)

2:51:40: ISDN Se3/0:15 Q931: RX <- SETUP pd = 8  callref = 0x2000
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech  
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98395
                Exclusive, Channel 21
        Progress Ind i = 0x8281 - Call not end-to-end ISDN, may have in-band info  
        Calling Party Number i = 0x0183, '6442115'
                Plan:ISDN, Type:Unknown
        Called Party Number i = 0x81, '630000'
                Plan:ISDN, Type:Unknown
02:51:40: ISDN Se3/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0xA000
        Channel ID i = 0xA98395
                Exclusive, Channel 21
02:51:40: ISDN Se3/0:15 Q931: TX -> CONNECT pd = 8  callref = 0xA000
02:51:40: ISDN Se3/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x2000
02:51:41: ISDN Se3/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x2000
        Cause i = 0x8490 - Normal call clearing
        Progress Ind i = 0x8488 - In-band info or appropriate now available
02:51:41: ISDN Se3/0:15 Q931: call_disc: PI received in disconnect; Postpone sending RELEASE for callid 0xA7
02:51:41: ISDN Se3/0:15 Q931: TX -> RELEASE pd = 8  callref = 0xA000
02:51:41: ISDN Se3/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x2000

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от iles email(ok) on 16-Янв-09, 14:32 
Ау..... HELP!!!!
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от Alex email(??) on 19-Янв-09, 11:51 
Звонок приходит на !voice 8766 pots!

application debit1
incoming called-number 630000


Смотрите, что происходит в debit1
- deb voip ivr tcl
   deb voip ivr scr
или
- deb voip app tcl
   deb voip app scr

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от iles email(ok) on 19-Янв-09, 12:02 
>[оверквотинг удален]
>application debit1
>incoming called-number 630000
>
>
>Смотрите, что происходит в debit1
> - deb voip ivr tcl
>   deb voip ivr scr
>или
> - deb voip app tcl
>   deb voip app scr

запустил дебаг - в логах только:
3d23h: ************ cid(1349) app running state do_ani_authorize
3d23h: ************ cid(1349) app running state do_get_card_number

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от iles email(ok) on 19-Янв-09, 12:52 
не дает покоя строка:

4d00h: ISDN Se3/0:15 Q931: RX <- SETUP pd = 8  callref = 0x2100

разве не со стороны Е1 должен приходить SETUP ? то есть:

4d00h: ISDN Se3/0:15 Q931: RX -> SETUP pd = 8  callref = 0x2100

а уже в ответ на него:

4d00h: ISDN Se3/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0xA100
        Channel ID i = 0xA98392
                Exclusive, Channel 18
4d00h: ISDN Se3/0:15 Q931: TX -> CONNECT pd = 8  callref = 0xA100
4d00h: ISDN Se3/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x2100

ведь звонок инициируется на стороне ГАТС, а не на стороне циски, или я не прав?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от Alex email(??) on 21-Янв-09, 10:59 
:51:40: ISDN Se3/0:15 Q931: RX <- SETUP pd = 8  callref = 0x2000
02:51:40: ISDN Se3/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0xA000
        Channel ID i = 0xA98395
                Exclusive, Channel 21
02:51:40: ISDN Se3/0:15 Q931: TX -> CONNECT pd = 8  callref = 0xA000
02:51:40: ISDN Se3/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x2000
02:51:41: ISDN Se3/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x2000

Извениете, невнимательно смотрел код dtbug isdn.
DISCONNECT приходит со стороны PSTN. Попробуйте
в коде приложения, если на TCL, а не vxml,
поставьте передачу ALERT или PROGRESS:
     leg progress leg_incoming -p 8
     leg alert leg_incoming -p 8
или
     leg progress leg_incoming
     leg alert leg_incoming

Так как DISCONNECT со стороны станции, попросите снять
трассировку со стороны станции.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от iles (ok) on 21-Янв-09, 20:02 
>[оверквотинг удален]
>в коде приложения, если на TCL, а не vxml,
>поставьте передачу ALERT или PROGRESS:
>     leg progress leg_incoming -p 8
>     leg alert leg_incoming -p 8
>или
>     leg progress leg_incoming
>     leg alert leg_incoming
>
>Так как DISCONNECT со стороны станции, попросите снять
>трассировку со стороны станции.

Э.. такой вопрос - а в каой части скрипта ставить ?? скрипты на TCL, но я вних не бум-бум.
в скрипте процедуры:

proc do_tens {} {
    global prompt
    global prefix
    global numbers
    global len
    global gender

proc do_hundreds {} {
    global prompt
    global prefix
    global numbers

    

proc do_thousands {} {
    global prompt
    global prefix
    global numbers
    global len

    

proc do_hthousands {} {
    global prompt
    global prefix
    global numbers

    
proc do_whole_part {} {
    global amt
    global prefix
    global prompt
    global numbers
    global len
    global newlist

    
proc do_decimal_part {} {
   global newlist
   global prompt
   global prefix
   global gender

proc do_select_language {} {
    global state
    global retryCnt
    global selectCnt
    global prefix
    global wrongLanguage
    global param5
    global param2
    global param1
    global prefix1
    global totalLang

proc do_get_card_number {} {
    global state
    global account
    global pin
    global promptFlag
    global count
    global accountLen
    global pinLen
    global retryCnt
    global prefix
    global param1
    global param2

    
proc do_first_authorize {} {
    global state
    global pin
    global account
    global count
    global retryCnt
    global promptFlag
    global prefix
    global param2
    global amt
    global returncode


proc do_get_dest {} {
    global state
    global destination
    global fcnt
    global retryCnt
    global promptFlag2
    global prefix
    global pound
    global destBusy
    global param3
    global amt
    global prompt
    global len
    global newlist
    global gender
    global numbers

proc do_creditTime_prompt {} {
    global creditTime
    global prefix
    global param2
    global len
    global prompt
    global newlist
    global numbers
    global gender


proc do_second_authorize {} {
    global state
    global destination
    global account
    global pin
    global creditTime
    global warnTime
    global promptFlag2
    global fcnt
    global retryCnt
    global prefix
    global noPlay
    global param2
    global noTimeLimit
    global len
    global prompt
    global newlist
    global redirectnum
    global operatorNum
    global returncode
    

proc do_place_call {} {
    global state
    global destination
    global account
    global redirectnum
    global operatorNum
    global returncode

  

proc do_active_notimer {} {
    global state

    set ev [waitEvent]
    while { [string compare $ev "digit"] == 0 } {
        set ev [waitEvent]
    }
    set state end
    return 0
}


proc do_active_last_timer {} {
    global state
    global warnTime
    global creditTime
    global fcnt
    global noPlay
    global prefix
    global pound

  
proc do_longpound {} {
    global state
    global fcnt
    global noPlay
    global pound

     set fcnt 0
     set noPlay 0
     set pound 1

     clearOutgoingLeg info
  #set state first_authorize
     set state do_get_dest
     return 0
}

proc do_active_timer {} {
    global state
    global warnTime
    global creditTime
    global prefix
    global fcnt
    global noPlay
    global pound
    global param4

  

proc do_active {} {
    global state
    global creditTime
    global warnTime
    global noTimeLimit

  
proc do_out_of_time {} {
    global state
    global prefix
    global param2

  
proc do_first_authorize_fail {} {
    global state
    global prefix
    global param2

  

proc do_second_authorize_fail {} {
    global state
    global prefix
    global param2

  

proc do_collect_fail {} {
    global state
    global prefix
    global param2

  

proc do_place_fail {} {
    global state
    global prefix
    global destBusy
    global param2

    

proc do_ani_authorize {} {
    global amt
    global state
    global pin
    global account
    global prefix

и какая из них стартует при "появлении" вызова??

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от Alex email(??) on 22-Янв-09, 11:10 
Поставьте
     leg progress leg_incoming
или
     leg alert leg_incoming -p 8
после
     leg proceeding leg_incoming
,но перед
     leg connect leg_incoming
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от iles email(??) on 04-Фев-09, 19:06 
>Поставьте
>     leg progress leg_incoming
>или
>     leg alert leg_incoming -p 8
>после
>     leg proceeding leg_incoming
>,но перед
>     leg connect leg_incoming

походу траблы в конвертации:
https://www.opennet.ru/openforum/vsluhforumID6/15190.html#9

есть мысли???

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "SI2000 -> КВАНТ-Е -> AS5350 = VoIP"  +/
Сообщение от djsergminyar email(ok) on 29-Июн-10, 19:51 
Как вариант может быть что в Билинге количество цифр принимающих стоит, и он просто при авторизации не авторизуется.
Либо просто станция обезает какое то киличество цифр, и в итоге получаем чтото некоректное.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру