The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблема с NAT и NetFlow на 2610"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Проблема с NAT и NetFlow на 2610"  
Сообщение от Krif (??) on 27-Янв-09, 20:34 
Всем привет,

Вроде ошибиться негде а не работает :) Итак задачка простая - есть c2610, с одним Ethernet интерфейсом, который обслуживает сетку из PPPoE пользователей под натом на этой же циске через аплинк (в отдельном вилане) в этом же интерфейсе. НАТ работает а вот  данные по netflow о приватных адресах не экспортируются. Сделан route-map на loopback (как учат вот тут https://www.opennet.ru/base/cisco/netflow_nat.txt.html), пакеты он заворачивает (счетчики route-map'а растут) а данных о входящем трафике в netflow все равно нет, в sh ip cache flow данных о приватных адресах в dst ip тоже нет. Такая же схема работала на cisco 3640 и все было хорошо, собственно и конфиг взят по большей части оттуда. Помогите с этой мистикой.

ip cef

interface Loopback0
ip address 192.168.40.1 255.255.255.255
snmp ifindex persist
!

interface Loopback1
ip address 194.xxx.xxx.xxx 255.255.255.255
ip route-cache same-interface
ip route-cache policy
ip route-cache flow
!

interface Ethernet0/0
description LINK TO HP2524
no ip address
ip route-cache policy
ip route-cache flow
full-duplex
!

interface Ethernet0/0.801
description C2610-LINK
encapsulation dot1Q 801
ip address xxx.xxx.xxx.xxx 255.255.255.248
ip nat outside
ip policy route-map NAT
!

interface Virtual-Template1
mtu 1492
ip unnumbered Loopback0
no ip redirects
no ip proxy-arp
ip nat inside
no peer default ip address
ppp authentication chap
!

ip nat inside source list 10 interface Loopback1 overload

access-list 10 permit 192.168.40.0 0.0.0.255
access-list 10 permit 192.168.41.0 0.0.0.255
access-list 108 permit ip any 192.168.40.0 0.0.0.255
access-list 108 permit ip any 192.168.41.0 0.0.0.255

route-map NAT permit 10
match ip address 108
set interface Loopback1

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема с NAT и NetFlow на 2610"  
Сообщение от kskostja (ok) on 28-Янв-09, 06:55 
а где эти строки у тебя

ip flow-export version 5
ip flow-export destination ХХХ.ХХХ.ХХХ.ХХХ 9996

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Проблема с NAT и NetFlow на 2610"  
Сообщение от kskostja (ok) on 28-Янв-09, 06:57 
interface Loopback0
ip address 192.168.0.1 255.255.255.0
ip route-cache policy
ip route-cache flow


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Проблема с NAT и NetFlow на 2610"  
Сообщение от Krif (??) on 28-Янв-09, 12:47 
>interface Loopback0
> ip address 192.168.0.1 255.255.255.0
> ip route-cache policy
> ip route-cache flow

делал, не помогло

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Проблема с NAT и NetFlow на 2610"  
Сообщение от Krif (??) on 28-Янв-09, 12:46 
>а где эти строки у тебя
>
>ip flow-export version 5
>ip flow-export destination ХХХ.ХХХ.ХХХ.ХХХ 9996

они естественно есть. забыл указать

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Проблема с NAT и NetFlow на 2610"  
Сообщение от sh_ email(??) on 28-Янв-09, 11:49 
interface Virtual-Template1
ip flow ingress
ip flow egress
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Проблема с NAT и NetFlow на 2610"  
Сообщение от Krif (??) on 28-Янв-09, 12:48 
>interface Virtual-Template1
>ip flow ingress
>ip flow egress

ios 12.2(12a) такое еще не умеет.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Проблема с NAT и NetFlow на 2610"  
Сообщение от Krif (??) on 28-Янв-09, 13:20 
Всем спасибо за ответы, вроде разобрался. После 'no ip flow-cache feature-accelerate'  данные стали появляться. ХЗ как это объяснить рационально, но факт остается фактом )
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру