The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Большая загрузка CPU"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Большая загрузка CPU"  +/
Сообщение от alex6999 email(ok) on 09-Май-09, 08:05 
вот так обстоит дело в состоянии покоя. (нулевые процессы не привожу)
CPU utilization for five seconds: 7%/5%; one minute: 15%; five minutes: 36%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
   5    14609076    732635      19940  0.00%  1.75%  2.29%   0 Check heaps
  36      301628      7661      39371  0.00%  0.04%  0.05%   0 Per-minute Jobs
  43    24458392   9755164       2507  1.91%  1.59%  8.80%   0 IP Input
  96        4356       208      20942  0.00%  0.20%  0.14%   2 Virtual Exec
126      365792    922025        396  0.00%  0.00%  0.08%   0 IP NAT Ager

а вот тут я запускаю торрента. качает он со скорость примерно 500 килобайт в сек.
C837-ADSL#sh processes cpu
CPU utilization for five seconds: 99%/61%; one minute: 96%; five minutes: 92%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
   5    14681284    736031      19946  1.18%  1.73%  1.81%   0 Check heaps
  23      329516  10565409         31  0.31%  0.24%  0.22%   0 LED Timers
  43    25703324   9814915       2618 35.96% 33.95% 31.91%   0 IP Input
  96        8140       325      25046  0.00%  0.19%  0.11%   2 Virtual Exec
122      263780  14148479         18  0.15%  0.19%  0.21%   0 PPP manager
123      199436  14150155         14  0.23%  0.14%  0.14%   0 PPP Events
126      378892    926594        408  0.15%  0.32%  0.31%   0 IP NAT Ager
129       35632   3562196         10  0.07%  0.05%  0.04%   0 PPPoE Background


роутер 837, на нём тормозит аплоад, на копеечном ДСЛ модеме на 20% быстрее.
собираюсь перейти на более быстрый интернет и незнаю потянет он или нет.
что делать? менять на 2620 с WIC-1ADSL?
есть ещё 3640 и 3660 - но они(особенно 3660) шумные

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Большая загрузка CPU"  +/
Сообщение от zxc (??) on 09-Май-09, 09:32 
что показывает show ip cef ?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Большая загрузка CPU"  +/
Сообщение от alex6999 email(ok) on 09-Май-09, 10:07 
>что показывает show ip cef ?

в общемто немного

Prefix              Next Hop             Interface
0.0.0.0/0           attached             Dialer1
0.0.0.0/32          receive
64.230.197.213/32   attached             Virtual-Access1
76.66.6.153/32      receive
192.168.0.0/16      attached             Ethernet0
192.168.0.0/32      receive
192.168.0.2/32      192.168.0.2          Ethernet0
192.168.0.11/32     receive
192.168.15.19/32    192.168.15.19        Ethernet0
192.168.15.20/32    192.168.15.20        Ethernet0
192.168.255.255/32  receive
224.0.0.0/4         drop
224.0.0.0/24        receive
255.255.255.255/32  receive

64.230.197.213 следующий хоп в трейсроуте
76.66.6.153 мой ИП
192.168.0.2 - cisco 2950
192.168.15.20 - комп
192.168.15.19 - cisco 7960

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Большая загрузка CPU"  +/
Сообщение от CrAzOiD (ok) on 09-Май-09, 10:18 
а что говорит sh adj sum
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Большая загрузка CPU"  +/
Сообщение от alex6999 email(ok) on 09-Май-09, 11:00 
>а что говорит sh adj sum

да ничего особенного
C837-ADSL#sh adj sum
Adjacency Table has 5 adjacencies
  Table epoch: 0 (5 entries at this epoch)

  Interface                 Adjacency Count
  Ethernet0                 3
  ATM0.1                    1
  Virtual-Access1           1

кстати конфиг у этого роутера ну очень простой

!
version 12.3
no service pad
service timestamps debug uptime
service timestamps log datetime localtime
no service password-encryption
!
hostname C837-ADSL
!
boot-start-marker
boot-end-marker
!
no logging monitor
!
no aaa new-model
clock timezone PCTime -5
no ip subnet-zero
!
!
!
!
ip cef
vpdn enable
!
!
!
!signaling traffic
access-list 101 permit udp any any eq 5060
access-list 101 permit udp any any eq 5061
!


class-map match-all voice-traffic
match access-group 102
!
class-map match-all voice-signaling
match access-group 101

!
policy-map qos-voice
class voice-traffic
priority 240
class voice-signaling
bandwidth 16
class class-defult
fair-queue
!
!
!
!
!
no crypto isakmp enable
!
bridge irb

!--- For DHCP:

ip dhcp pool ADSL_pool
network 192.168.64.0 255.255.192.0
default-router 192.168.0.11
domain STORM
dns-server 4.2.2.1
!


!
!
interface Ethernet0
ip address 192.168.0.11 255.255.0.0
ip nat inside
ip virtual-reassembly
hold-queue 100 out
service-policy output qos-voice
!
interface Ethernet2
no ip address
shutdown
hold-queue 100 out
!
interface ATM0
description ADSL
no shutdown
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in
pvc 0/35
  pppoe-client dial-pool-number 1
!
!
interface ATM0.1 point-to-point
! no snmp trap link-status
pvc 1/1
  pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
duplex auto
speed auto
no shutdown
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!
interface Dialer1
description PPPOE
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username b1wm65 password 0 Onta1
ppp ipcp dns request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
!
!
ip nat translation timeout 120
ip nat translation tcp-timeout 120
ip nat translation udp-timeout 120
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp 192.168.15.20 1723    interface Dialer1 1723
ip nat inside source static tcp 192.168.15.20 500    interface Dialer1 500
ip nat inside source static udp 192.168.15.20 50    interface Dialer1 50
ip nat inside source static udp 192.168.15.20 51    interface Dialer1 51
!
!
access-list 1 permit 192.168.0.0 0.0.255.255
!
!
!
control-plane
!
!
line con 0
exec-timeout 120 0
no modem enable
transport output all
stopbits 1
line aux 0
transport output all
line vty 0 4
access-class 23 in
exec-timeout 120 0
privilege level 15
password qwe
login
transport input telnet
transport output all
!
scheduler max-task-time 5000


end

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Большая загрузка CPU"  +/
Сообщение от zxc (??) on 09-Май-09, 11:59 
sh adj sum у вас не все показывает, что надо :-)

покажите
sh adj detail
sh adj punt
sh adj glean

что-нибудь, да выловим :-)


Ну, и на всякий случай, сбросьте dialer-интерфейс, нагрузите канал и покажите
sh int stats

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Большая загрузка CPU"  +/
Сообщение от alex6999 email(ok) on 17-Май-09, 05:28 
>sh adj detail
>sh adj punt
>sh adj glean

пунта и глена у меня нет

C837-ADSL#sh adj detail
Protocol Interface                 Address
IP       ATM0.1                    point2point(3)
                                   0 packets, 0 bytes
                                   00020000AAAA030000000800
                                   ATM-PVC    never
                                   Epoch: 0
IP       Virtual-Access1           point2point(19)
                                   0 packets, 0 bytes
                                   00010000AAAA030080C2000700000090
                                   1AA0FF00000F8F60F5E8886411000340
                                   00000021
                                   Epoch: 0
IP       Ethernet0                 192.168.0.2(5)
                                   0 packets, 0 bytes
                                   000B5F59C180000F8F60F5E80800
                                   ARP        01:34:12
                                   Epoch: 0
IP       Ethernet0                 192.168.15.20(5)
                                   19248564 packets, 16722219171 bytes
                                   001FD02323A1000F8F60F5E80800
                                   ARP        04:00:56
                                   Epoch: 0
IP       Ethernet0                 192.168.15.19(5)
                                   1384919 packets, 296352673 bytes
                                   000653C62EAE000F8F60F5E80800
                                   ARP        03:58:57
                                   Epoch: 0
C837-ADSL#sh adj punt
                 ^
% Invalid input detected at '^' marker.

C837-ADSL#sh adj glean
                  ^
% Invalid input detected at '^' marker.

>что-нибудь, да выловим :-)
>Ну, и на всякий случай, сбросьте dialer-интерфейс, нагрузите канал и покажите
>sh int stats

провод что-ли выдернуть, у меня есть в диалере только комманда watch-list

C837-ADSL#sh int stat
FastEthernet1
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor          0          0          0          0
             Route cache          0          0          0          0
                   Total          0          0          0          0
Interface FastEthernet2 is disabled

Interface FastEthernet3 is disabled

Interface FastEthernet4 is disabled

Ethernet0
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor   30157929 2546036722   34604218  430238346
             Route cache   81515102 1412005141   87662948  327378775
                   Total  111673031 3958041863  122267166  757617121
ATM0
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor   34455414 1223577302   29465084 2916503872
             Route cache   87709873 2177048830   79554455 2453102452
                   Total  122165287 3400626132  109019539 5369606324
Interface Ethernet2 is disabled

Interface Multilink1 is disabled

Dialer1
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor   34455390   52098513   29940949 3155219736
             Route cache   87709873 3489880806   81456486  389760840
                   Total  122165274 3541982733  111397436 3544980677
Virtual-Access1
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor    6232240 1401361373    5086097  971854704
             Route cache   11599670  930110404   10990883 2029669077
                   Total   17831910 2331471777   16076980 3001523781


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Большая загрузка CPU"  +/
Сообщение от CrAzOiD (ok) on 10-Май-09, 01:15 
>[оверквотинг удален]
>        10  0.07%
> 0.05%  0.04%   0 PPPoE Background
>
>
>роутер 837, на нём тормозит аплоад, на копеечном ДСЛ модеме на 20%
>быстрее.
>собираюсь перейти на более быстрый интернет и незнаю потянет он или нет.
>
>что делать? менять на 2620 с WIC-1ADSL?
>есть ещё 3640 и 3660 - но они(особенно 3660) шумные

Кстати, а вы похоже в предел ее способностей уперлись. IP INPUT основной процесс.
Можно, конечо, помучить животинку, но, имхо, много больше вы из нее вряд ли выжмите. Можете попробовать уменьшить количество одновременных трансляций NAT.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Большая загрузка CPU"  +/
Сообщение от alex6999 (ok) on 11-Май-09, 05:48 
>Кстати, а вы похоже в предел ее способностей уперлись. IP INPUT основной
>процесс.
>Можно, конечо, помучить животинку, но, имхо, много больше вы из нее вряд
>ли выжмите. Можете попробовать уменьшить количество одновременных трансляций NAT.

ну вроде как скорость этой животинки 4.5 мегабита на 64 байтных пакетах. на больших пакетах скорость должна быть ИМХО больше. там вроде ещё и VPN есть, а мощи процессора уже нет

насчёт НАТ, что вы имеет ввиду? уменьшить количество транслируемых портов? или количество одновременных соеденений? я честно говоря незнаю как это сделать и незнаю как это скажется на торренте, торрент клиент будет думать что порты открыты, а на самом деле не для всех.

PS: в этой животинке 12 флеша и 48 рама, я пробовал туда ставить ставить ИОС 12.4(который вообщемто судя по CFN должен работать) но при включенном торренте заканчивалась память, что телнет вообше не работал, а на консоли было лишь сообщение о нехватке памяти. так что пришлось поставить 12.3

если ещё такаяже 837 животинка с 12/64, я туда поставил последнюю 12.4XJ(в буквах точно не уверен) CNF говорит что ей надо 16 флеша, но я образ перепаковал и он влез в 12 флеша. попробую ещё и с ней.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Большая загрузка CPU"  +/
Сообщение от zxc (??) on 11-Май-09, 06:26 
>если ещё такаяже 837 животинка с 12/64, я туда поставил последнюю 12.4XJ(в
>буквах точно не уверен) CNF говорит что ей надо 16 флеша,
>но я образ перепаковал и он влез в 12 флеша. попробую
>ещё и с ней.

А как вы перепаковали образ? Простым архиватором?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Большая загрузка CPU"  +/
Сообщение от alex6999 email(ok) on 17-Май-09, 05:31 
>>если ещё такаяже 837 животинка с 12/64, я туда поставил последнюю 12.4XJ(в
>>буквах точно не уверен) CNF говорит что ей надо 16 флеша,
>>но я образ перепаковал и он влез в 12 флеша. попробую
>>ещё и с ней.
>
>А как вы перепаковали образ? Простым архиватором?

ну не простым, а с помощью 7zip
http://dr-betep.blogspot.com/2009/02/cisco.html


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Большая загрузка CPU"  +/
Сообщение от Andrey (??) on 11-Май-09, 19:47 
show interface

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Большая загрузка CPU"  +/
Сообщение от CrAzOiD (ok) on 11-Май-09, 21:53 
>>Кстати, а вы похоже в предел ее способностей уперлись. IP INPUT основной
>>процесс.
>>Можно, конечо, помучить животинку, но, имхо, много больше вы из нее вряд
>>ли выжмите. Можете попробовать уменьшить количество одновременных трансляций NAT.
>
>ну вроде как скорость этой животинки 4.5 мегабита на 64 байтных пакетах.
>на больших пакетах скорость должна быть ИМХО больше. там вроде ещё
>и VPN есть, а мощи процессора уже нет

Все заявленные Cisco параметры отностятся к стендовой конфигурации, т.е. ничего лишнего, упомянутые Вами 64-байтные пакеты и трафик в _одну_ сторону.
Так что реальные данные так просто апроксимировать не стоит.

>насчёт НАТ, что вы имеет ввиду? уменьшить количество транслируемых портов? или количество
>одновременных соеденений? я честно говоря незнаю как это сделать и незнаю
>как это скажется на торренте, торрент клиент будет думать что порты
>открыты, а на самом деле не для всех.

Именно кодичество одновременных сессий и время хранения трансляции в памяти. Потому как все это память и процессор на проверку пакетов по таблице трансляций.
Кроме этого, я заметил, вы QoS используете...
Так что мое мнение: банально не хватает мощи для железки.
Потюнить можно, но не сильно.
Кстати, посмотрите насчет MTU и фрагментации. Тоже грузит процессор.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Большая загрузка CPU"  +/
Сообщение от alex6999 email(ok) on 17-Май-09, 10:17 
>Именно кодичество одновременных сессий и время хранения трансляции в памяти. Потому как
>все это память и процессор на проверку пакетов по таблице трансляций.

хорошо, отключаю совсем.

итак написал конфиг вот так
ip nat translation timeout 120
ip nat translation tcp-timeout 120
ip nat translation udp-timeout 120
ip nat inside source list 1 interface Dialer1 overload
!ip nat inside source static tcp 192.168.15.20 1723    interface Dialer1 1723
!ip nat inside source static tcp 192.168.15.20 500    interface Dialer1 500
!ip nat inside source static udp 192.168.15.20 50    interface Dialer1 50
!ip nat inside source static udp 192.168.15.20 51    interface Dialer1 51

загрузка проца 75% - всё равно кажется много. хотя для набора полной скорости с закрытыми портам мне пришлось запустить 20 закачек стазу, возможно это тоже влияет на загрузку роутера. тупое качаение больщого файла на большой скорости не влияет на проц

в начале вообще всё закомментировал и роутер отказался роутить

не подскажете как посмотреть количество одновременных сессий и как их ограничить?

>Кроме этого, я заметил, вы QoS используете...

а если QoS стоит только на VoIP траффик и я не говорю в данный момент по телефону(сигнальный траффик мизерный), то разве это грузит проц?

>Так что мое мнение: банально не хватает мощи для железки.

согласен, хотя и странно это слышать, дешёвый китайский роутер справляется лучше.

>Кстати, посмотрите насчет MTU и фрагментации. Тоже грузит процессор.

т.е. сделать MTU больше?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Большая загрузка CPU"  +/
Сообщение от alex6999 email(ok) on 18-Май-09, 14:11 
вообщем взял я другую животинку с большим количеством памяти и IOS 12.4(11)XJ4

загрузка проца выросла так что роутер просто упал, телнет тормозит
пришлось отключить nat вообще
вот что вышло с итоге на скорости торрента в 300 кб/сек.

CPU utilization for five seconds: 90%/85%; one minute: 91%; five minutes: 79%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  51      326860     23899      13676  1.78%  1.04%  1.02%   0 IP Input
146       51972      6885       7548  0.81%  0.66%  0.64%   0 IP NAT Ager
155       31764     92214        344  0.73%  0.41%  0.32%   0 PPP Events
  71       14508      6318       2296  0.40%  0.22%  0.18%   0 DHCPD Receive
  28       54356    161817        335  0.40%  0.53%  0.44%   0 LED Timers

что интересно IP Input теперь берёт мизер, а на 12,3 он брал 33%
интересная арифметика 2+1+0,5+0,5=90

думаю надо вернутся на 12.3 версию, чтото мне не нравится скорость работы 12.4

вопрос про DMZ, можно-ли им заменить NAT? причём так, как сделано в дешёвых роутерах, всё без разбору направляется на один ИП адрес.? хочу сделать это для минимизации CPU. а будет ли эта минимизация?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру