The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Была загрузка CPU 99%, поставил более мощный роутер - опять ..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от alex6999 email(ok) on 26-Авг-09, 07:41 
Вот тут я писал несклько месяцев назад
https://www.opennet.ru/openforum/vsluhforumID6/18822.html
о наблюдаемой высокой загрузке CPU в cisco 837 при работе торрента.
вывод был очевиден - животинка страдала от немощности при включённом НАТ.

итак приобретёр новый роутер. нет, скажем "новый" роутер 2650. по заверениям cisco его производительность в 4 раза больше чем у 837. ну... думаю мне этого хватит.
одновременно приобретена карточка WIC-1ADSL. ADSL2 у меня нет и скорее всего не будет - у нас на это политические причины, народ бондит две ADSL.

не тут-то было, имеет туже саму картину, такая-же загрузка CPU при резком каче торрента на 500 кбайт/с. надо сказать, что 837 качал с такой-же скоростью и с такой-же загрузкой CPU. значит дело не в животинке. я конечно попробую повторить эксперимент на 3660 - этот динозавр не уступает современникам, только шумит и летом както жарко становится.

единственное что я приписал к старому конфигу -  clock rate aal5 7000000
без этого скорость ADSL ограничена 2,5 мегабитами. оригинальное значение  - 2600000(вроде)

итак даю комманды
sh proc cpu sorted
sh adj detail
sh ip cef
sh int
sh ver
sh run

C2650-ADSL#sh proc cpu sorted
CPU utilization for five seconds: 99%/53%; one minute: 99%; five minutes: 93%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  73      794143     31210      25445 43.94% 47.45% 44.69%   0 IP Input
220        6966     35341        197  0.40%  0.43%  0.49%   0 IP NAT Ager
224        3723    551435          6  0.32%  0.18%  0.17%   0 PPP manager
225        2888    551441          5  0.32%  0.19%  0.17%   0 PPP Events
113          36        28       1285  0.08%  0.00%  0.00%   0 TCP Timer
148          92      6726         13  0.08%  0.00%  0.00%   0 FLEX DSPRM MAIN
  61      408484    240589       1697  0.08%  0.09%  0.10%   0 DSL State Machin
107         140     18128          7  0.08%  0.01%  0.00%   0 ATMSIG Timer
136        1374    178564          7  0.08%  0.09%  0.07%   0 RBSCP Background
227         592     18501         31  0.08%  0.02%  0.00%   0 NTP
122         136     18126          7  0.08%  0.02%  0.00%   0 RUDPV1 Main Proc

C2650-ADSL#show ip cef
Prefix              Next Hop             Interface
0.0.0.0/0           64.230.197.213       Dialer1
0.0.0.0/8           drop
0.0.0.0/32          receive
10.1.0.0/16         attached             FastEthernet0/0
10.1.0.0/32         receive
10.1.1.1/32         receive
10.1.1.2/32         10.1.1.2             FastEthernet0/0
10.1.2.3/32         10.1.2.3             FastEthernet0/0
10.1.2.254/32       10.1.2.254           FastEthernet0/0
10.1.3.1/32         10.1.3.1             FastEthernet0/0
10.1.3.2/32         10.1.3.2             FastEthernet0/0
10.1.3.3/32         10.1.3.3             FastEthernet0/0
10.1.3.5/32         10.1.3.5             FastEthernet0/0
10.1.3.6/32         10.1.3.6             FastEthernet0/0
10.1.255.255/32     receive
10.2.0.0/16         attached             BRI0/0
10.2.0.0/32         receive
10.2.1.1/32         receive
10.2.255.255/32     receive
64.230.197.213/32   attached             Dialer1
76.66.165.35/32     receive
127.0.0.0/8         drop
224.0.0.0/4         drop
224.0.0.0/24        receive
240.0.0.0/4         drop
255.255.255.255/32  receive
C2650-ADSL#sh adj sum
Adjacency Table has 12 adjacencies
  Table epoch: 0 (12 entries at this epoch)

  Interface                 Adjacency Count
  FastEthernet0/0           8
  BRI0/0                    1
  ATM0/0.35                 1
  Dialer1                   1
  Virtual-Access1           1
C2650-ADSL#sh adj detail
Protocol Interface                 Address
IP       BRI0/0                    point2point(3)
                                   0 packets, 0 bytes
                                   0F000800
                                   CEF   expires: 00:02:33
                                         refresh: 00:00:33
                                   Epoch: 0
IP       FastEthernet0/0           10.1.1.2(5)
                                   272 packets, 24480 bytes
                                   000B5F59C180000653FE2D200800
                                   ARP        03:47:25
                                   Epoch: 0
IP       FastEthernet0/0           10.1.3.1(5)
                                   0 packets, 0 bytes
                                   000653C62EAE000653FE2D200800
                                   ARP        03:47:40
                                   Epoch: 0
IP       FastEthernet0/0           10.1.3.2(5)
                                   31000 packets, 30397161 bytes
                                   001FD0232371000653FE2D200800
                                   ARP        04:01:52
                                   Epoch: 0
IP       FastEthernet0/0           10.1.2.3(5)
                                   1779 packets, 1047182 bytes
                                   001FD02323A1000653FE2D200800
                                   ARP        04:00:24
                                   Epoch: 0
IP       FastEthernet0/0           10.1.3.3(5)
                                   0 packets, 0 bytes
                                   001FD0232381000653FE2D200800
                                   ARP        03:49:05
                                   Epoch: 0
IP       ATM0/0.35                 point2point(3)
                                   0 packets, 0 bytes
                                   00010900AAAA030000000800
                                   ATM-PVC    never
                                   Epoch: 0
IP       FastEthernet0/0           10.1.3.5(5)
                                   487 packets, 652136 bytes
                                   00087406422B000653FE2D200800
                                   ARP        03:55:30
                                   Epoch: 0
IP       FastEthernet0/0           10.1.3.6(5)
                                   0 packets, 0 bytes
                                   001FD0232391000653FE2D200800
                                   ARP        03:49:05
                                   Epoch: 0
IP       Dialer1                   point2point(7)
                                   35749 packets, 3776545 bytes
Protocol Interface                 Address
                                   00010900AAAA030080C2000700000090
                                   1AA0FF00000653FE2D20886411001F0C
                                   00000021
                                   CEF   expires: 00:02:23
                                         refresh: 00:00:23
                                   Epoch: 0
IP       Virtual-Access1           point2point(3)
                                   0 packets, 0 bytes
                                   00010900AAAA030080C2000700000090
                                   1AA0FF00000653FE2D20886411001F0C
                                   00000021
                                   CEF   expires: never
                                         refresh: 00:00:23
                                   Epoch: 0
IP       FastEthernet0/0           10.1.2.254(5)
                                   0 packets, 0 bytes
                                   0000AA859C03000653FE2D200800
                                   ARP        04:00:14
                                   Epoch: 0
C2650-ADSL#sh adj punt
                   ^
% Invalid input detected at '^' marker.

C2650-ADSL#sh adj ?
  ATM                ATM interface
  Async              Async interface
  BRI                ISDN Basic Rate Interface
  BVI                Bridge-Group Virtual Interface
  CDMA-Ix            CDMA Ix interface
  CTunnel            CTunnel interface
  Dialer             Dialer interface
  FastEthernet       FastEthernet IEEE 802.3
  Group-Async        Async Group interface
  Lex                Lex interface
  Loopback           Loopback interface
  MFR                Multilink Frame Relay bundle interface
  Multilink          Multilink-group interface
  Null               Null interface
  Port-channel       Ethernet Channel of interfaces
  Tunnel             Tunnel interface
  Vif                PGM Multicast Host interface
  Virtual-Access     Virtual Access interface
  Virtual-PPP        Virtual PPP interface
  Virtual-Template   Virtual Template interface
  Virtual-TokenRing  Virtual TokenRing
  detail             Protocol detail and timers
  internal           Internal data structures
  summary            Adjacency table summary
  |                  Output modifiers
  <cr>

C2650-ADSL#sh int stats
ATM0/0
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor     306156  396836246     224106   30844795
             Route cache      37243   36681841      38784    5231310
                   Total     343399  433518087     262890   36076105
FastEthernet0/0
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor     222711   26488564     305170  389614907
             Route cache      38765    4477378      36935   35854563
                   Total     261476   30965942     342105  425469470
BRI0/0
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor          0          0          0          0
             Route cache          0          0          0          0
                   Total          0          0          0          0
BRI0/0:1
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor          0          0          0          0
             Route cache          0          0          0          0
                   Total          0          0          0          0
BRI0/0:2
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor          0          0          0          0
             Route cache          0          0          0          0
                   Total          0          0          0          0
NVI0
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor          0          0          0          0
             Route cache          0          0          0          0
                   Total          0          0          0          0
Virtual-Access1
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor     306165  386442573     224101   30826563
             Route cache      37243   35415579      38784    3912084
                   Total     343408  421858152     262885   34738647
Dialer1
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor     306158  386442470     224094   30826437
             Route cache      37243   35415463      38784    3912084
                   Total     343402  421859427     262878   34738521


C2650-ADSL#show interface
ATM0/0 is up, line protocol is up
  Hardware is DSLSAR (with Alcatel ADSL Module)
  Description: ADSL
  MTU 4470 bytes, sub MTU 4470, BW 800 Kbit, DLY 640 usec,
     reliability 255/255, txload 83/255, rxload 233/255
  Encapsulation ATM, loopback not set
  Encapsulation(s): AAL5  AAL2, PVC mode
  23 maximum active VCs, 256 VCs per VP, 1 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input 00:44:08, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/224/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Per VC Queueing
  5 minute input rate 4225000 bits/sec, 438 packets/sec
  5 minute output rate 263000 bits/sec, 320 packets/sec
     368680 packets input, 465882133 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     280845 packets output, 37851993 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
ATM0/0.35 is up, line protocol is up
  Hardware is DSLSAR (with Alcatel ADSL Module)
  Description: SBC VPI/VCI = 0/35
  MTU 4470 bytes, BW 800 Kbit, DLY 640 usec,
     reliability 255/255, txload 83/255, rxload 233/255
  Encapsulation ATM
     369155 packets input, 465995077 bytes
     280893 packets output, 37857861 bytes
     0 OAM cells input, 0 OAM cells output
  AAL5 CRC errors : 0
  AAL5 SAR Timeouts : 0
  AAL5 Oversized SDUs : 0
  Last clearing of "show interface" counters never
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0006.53fe.2d20 (bia 0006.53fe.2d20)
  Internet address is 10.1.1.1/16
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 10/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 33/32/5564/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Class-based queueing
  Output queue: 0/100/64/0 (size/max total/threshold/drops)
     Conversations  0/2/256 (active/max active/max total)
     Reserved Conversations 1/1 (allocated/max allocated)
     Available Bandwidth 74744 kilobits/sec
  5 minute input rate 213000 bits/sec, 319 packets/sec
  5 minute output rate 4148000 bits/sec, 435 packets/sec
     280007 packets input, 32446910 bytes
     Received 1080 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     368149 packets output, 458254395 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     66 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
BRI0/0 is up, line protocol is up (spoofing)
  Hardware is PQUICC BRI with U interface (Infenion)
  Internet address is 10.2.1.1/16
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
BRI0/0:1 is down, line protocol is down
  Hardware is PQUICC BRI with U interface (Infenion)
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
BRI0/0:2 is down, line protocol is down
  Hardware is PQUICC BRI with U interface (Infenion)
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
NVI0 is up, line protocol is up
  Hardware is NVI
  Interface is unnumbered. Using address of NVI0 (0.0.0.0)
  MTU 1514 bytes, BW 10000000 Kbit, DLY 0 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation UNKNOWN, loopback not set
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
Virtual-Access1 is up, line protocol is up
  Hardware is Virtual Access interface
  MTU 1492 bytes, BW 800 Kbit, DLY 20000 usec,
     reliability 255/255, txload 80/255, rxload 244/255
  Encapsulation PPP, LCP Open
  Listen: CDPCP
  Open: IPCP
  PPPoE vaccess, cloned from Dialer1
  Vaccess status 0x44, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Interface is bound to Di1 (Encapsulation PPP)
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters 00:50:37
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 4116000 bits/sec, 437 packets/sec
  5 minute output rate 251000 bits/sec, 321 packets/sec
     370905 packets input, 456128491 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     282408 packets output, 36552815 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Description: PPPOE
  Internet address is 76.66.165.35/32
  MTU 1492 bytes, BW 56 Kbit, DLY 20000 usec,
     reliability 255/255, txload 43/255, rxload 40/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Vi1
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 05:03:27
  Input queue: 37/75/154/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 42 kilobits/sec
  5 minute input rate 4220000 bits/sec, 402 packets/sec
  5 minute output rate 246000 bits/sec, 292 packets/sec
     371415 packets input, 456753189 bytes
     282772 packets output, 36587446 bytes
Bound to:
Virtual-Access1 is up, line protocol is up
  Hardware is Virtual Access interface
  MTU 1492 bytes, BW 800 Kbit, DLY 20000 usec,
     reliability 255/255, txload 80/255, rxload 244/255
  Encapsulation PPP, LCP Open
  Listen: CDPCP
  Open: IPCP
  PPPoE vaccess, cloned from Dialer1
  Vaccess status 0x44, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Interface is bound to Di1 (Encapsulation PPP)
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters 00:50:38
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 4116000 bits/sec, 437 packets/sec
  5 minute output rate 251000 bits/sec, 321 packets/sec
     371428 packets input, 456762140 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     282780 packets output, 36587614 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
C2650-ADSL#sh ver
Cisco IOS Software, C2600 Software (C2600-ADVENTERPRISEK9-M), Version 12.4(19), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Fri 29-Feb-08 19:23 by prod_rel_team

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

C2650-ADSL uptime is 5 hours, 19 minutes
System returned to ROM by power-on
System restarted at 18:18:33 EST Tue Aug 25 2009
System image file is "flash:c2600-adventerprisek9-mz.124-19.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2650 (MPC860P) processor (revision 2.0) with 127627K/3445K bytes of memory.
Processor board ID JAB05290F6J
M860 processor: part number 5, mask 2
1 FastEthernet interface
1 ISDN Basic Rate interface
1 ATM interface
32K bytes of NVRAM.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

C2650-ADSL#sh run
Building configuration...

Current configuration : 3471 bytes
!
! Last configuration change at 23:00:32 EST Tue Aug 25 2009
! NVRAM config last updated at 23:12:49 EST Tue Aug 25 2009
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug uptime
service timestamps log datetime localtime
no service password-encryption
!
hostname C2650-ADSL
!
boot-start-marker
boot-end-marker
!
no logging monitor
!
no aaa new-model
clock timezone EST -5
clock summer-time EST recurring
no network-clock-participate slot 1
no network-clock-participate wic 0
no ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.1.0.1 10.1.3.0
!
ip dhcp pool ADSL_pool
   network 10.1.0.0 255.255.0.0
   default-router 10.1.1.1
   option 66 ip 10.1.2.3
   option 150 ip 10.1.2.3
   domain-name STORM
   dns-server 4.2.2.1 4.2.2.2
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
vpdn enable
!
!
!
!
class-map match-all voice-signaling
match access-group 101
class-map match-all voice-traffic
match access-group 102
!
!
policy-map qos-voice
class voice-traffic
  priority 240
class voice-signaling
  bandwidth 16
!
!
no crypto isakmp enable
!
bridge irb
!
!
!
interface ATM0/0
description ADSL
no ip address
ip route-cache flow
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
clock rate aal5 7000000
hold-queue 224 in
!
interface ATM0/0.35 point-to-point
description SBC VPI/VCI = 0/35
pvc 0/35
  pppoe-client dial-pool-number 1
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.0.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
service-policy output qos-voice
hold-queue 32 in
hold-queue 100 out
!
interface BRI0/0
ip address 10.2.1.1 255.255.0.0
encapsulation hdlc
!
interface Dialer1
description PPPOE
mtu 1492
ip address negotiated
no ip redirects
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username b****5 password 0 ******
ppp ipcp dns request
ppp ipcp route default
ppp ipcp address accept
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat translation timeout 120
ip nat translation tcp-timeout 120
ip nat translation udp-timeout 120
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static udp 10.1.2.3 80 interface Dialer1 80
ip nat inside source static tcp 10.1.2.3 500 interface Dialer1 500
ip nat inside source static udp 10.1.2.3 51 interface Dialer1 51
ip nat inside source static tcp 10.1.2.3 1723 interface Dialer1 1723
ip nat inside source static udp 10.1.2.3 50 interface Dialer1 50
!
logging 10.1.2.3
access-list 1 permit 10.1.0.0 0.0.255.255
access-list 101 permit udp any any eq 5060
access-list 101 permit udp any any eq 5061
!
!
!
control-plane
!
!
!
!
line con 0
exec-timeout 120 0
transport output all
stopbits 1
line aux 0
line vty 0 4
access-class 23 in
exec-timeout 120 0
privilege level 15
password ***
login
transport input telnet
transport output all
!
scheduler max-task-time 5000
ntp clock-period 17179968
ntp server 216.194.70.2
ntp server 192.135.48.21
ntp server 72.51.27.50
ntp server 72.55.146.217
ntp server 64.69.38.107
ntp server 132.214.200.120
ntp server 65.255.217.202
ntp server 128.10.252.6
ntp server 208.53.158.34 prefer
ntp server 208.83.212.8
ntp server 66.70.29.130
!
end

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от Вячеслав (??) on 26-Авг-09, 07:56 
Несколько вопросов:


1. Загрузка пиковая или постоянная
2. Что показывают трансляции

Дай с кошки:
sh processes cpu history
sh ip nat statistics(дай трансляции без торрента и с ним)

Вообще нормальная загрузка не более 60%


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от alex6999 email(ok) on 26-Авг-09, 08:40 
>1. Загрузка пиковая или постоянная

ну как запущу download на торренте - сразу загрузка, уменьшая скорость - загрузка падает. в покое она 10-20%

upload на торренте 50 кбайт/с - это у меня называется состояние покоя.

>2. Что показывают трансляции
>Дай с кошки:
>sh processes cpu history

вот, я как раз качал новую серию сериала, 300 мегов на скорости в 500 кбайт/сек

    111111 21211111111111 1111131111 11111112219999999999999983
    954221901521543363530912202400229123062396499999999999996329
100                                            *############*
90                                            *#############
80                                            *#############*
70                                            ##############*
60                                            ###############
50                                            ###############
40                                            ###############
30          *                 *            ** ###############*
20 **     * *  *   * *        *         *  ## ###############*
10 ############################################################
   0....5....1....1....2....2....3....3....4....4....5....5....6
             0    5    0    5    0    5    0    5    0    5    0
               CPU% per minute (last 60 minutes)
              * = maximum CPU%   # = average CPU%

>sh ip nat statistics(дай трансляции без торрента и с ним)
>Вообще нормальная загрузка не более 60%

ну я это понимаю, что 99% это ненормально.


вот покой, вялая раздача торрентом
C2650-ADSL#sh ip nat statistics
Total active translations: 252 (0 static, 252 dynamic; 252 extended)
Outside interfaces:
  Virtual-Access1, Dialer1
Inside interfaces:
  FastEthernet0/0
Hits: 995169  Misses: 6251
CEF Translated packets: 300627, CEF Punted packets: 1410921
Expired translations: 7636
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 1 interface Dialer1 refcount 221
Appl doors: 1
Normal doors: 0
Queued Packets: 0


а вот бешаная свистопляска, торрент пошёл качать, скорость он уже набрал уже 500 кбайт/сек, загрузка проца 68%, количество нат трансляций растёт - 300

Total active translations: 435 - загрузка проца 82%
вот только в этот раз условия были нетакие, была отключена upload, скорость download выросла почти до 600 кбайт/с, upload не могла поднятся на забитом канале.

останавливаю download, пускаю upload - количество НАТ соединений прыгает аж до 900,
C2650-ADSL#sh ip nat statistics
Total active translations: 915 (0 static, 915 dynamic; 915 extended)
Outside interfaces:
  Virtual-Access1, Dialer1
Inside interfaces:
  FastEthernet0/0
Hits: 1382498  Misses: 8483
CEF Translated packets: 580488, CEF Punted packets: 1630662
Expired translations: 9573
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 1 interface Dialer1 refcount 693
Appl doors: 1
Normal doors: 0
Queued Packets: 0

а загрузка проца не очень большая.
CPU utilization for five seconds: 55%/24%; one minute: 19%; five minutes: 34%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  73     1135716    179107       6340 23.16%  6.82%  9.47%   0 IP Input

а вот теперь, с активным upload я включаю download

ждём немного и вот
C2650-ADSL#sh ip nat statistics
Total active translations: 1039 (0 static, 1039 dynamic; 1039 extended)
Outside interfaces:
  Virtual-Access1, Dialer1
Inside interfaces:
  FastEthernet0/0
Hits: 1454870  Misses: 9126
CEF Translated packets: 602019, CEF Punted packets: 1735754
Expired translations: 10220
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 1 interface Dialer1 refcount 703
Appl doors: 1
Normal doors: 0
Queued Packets: 0
C2650-ADSL#sh proc cpu s
CPU utilization for five seconds: 98%/52%; one minute: 78%; five minutes: 49%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  73     1213668    185201       6553 43.89% 33.00% 17.85%   0 IP Input
220       19579     43225        452  1.46%  2.96%  1.34%   0 IP NAT Ager

да, связано похоже с нат, то что на 915 НАТ соединениях загрузка 54% в рассчёт можно не брать, это маленький DOS - куча компов из интернета продолжаю ещё пару менут долбить меня, после остановки скачки.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от GolDi (??) on 26-Авг-09, 11:00 
>[оверквотинг удален]
>1.46%  2.96%  1.34%   0 IP NAT Ager
>
>
>
>
>
>да, связано похоже с нат, то что на 915 НАТ соединениях загрузка
>54% в рассчёт можно не брать, это маленький DOS - куча
>компов из интернета продолжаю ещё пару менут долбить меня, после остановки
>скачки.

Может проблема в ADSL?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от alex6999 email(ok) on 26-Авг-09, 12:20 
>Может проблема в ADSL?

думаете сам интерфейс потребляет так много процессорного времени?

и на 837 встроенный ADSL модем и карточка WIC-1ADSL?

вообщето на просутую скачку с хорошего сервака... ну например с микрософта, чтобы скорость была большой, процессор практически не тратится.

да и копеечные домашние роутеры, которым по 10 лет с данной задачей справляются лучше.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от GolDi (??) on 26-Авг-09, 12:31 
>[оверквотинг удален]
>
>думаете сам интерфейс потребляет так много процессорного времени?
>
>и на 837 встроенный ADSL модем и карточка WIC-1ADSL?
>
>вообщето на просутую скачку с хорошего сервака... ну например с микрософта, чтобы
>скорость была большой, процессор практически не тратится.
>
>да и копеечные домашние роутеры, которым по 10 лет с данной задачей
>справляются лучше.

Я просто предположил, может не дружит cisco с adsl коммутатором

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от alex6999 email(ok) on 27-Авг-09, 00:36 
>Я просто предположил, может не дружит cisco с adsl коммутатором

мммм.... мне сложно представить себе что вы имеете ввиду под словом ADSL коммутатор?
WIC интерфейс? он ведь родной, цисковский, трудно представить что циска сделала хреновую карту за штуку баксов(когдато она столько и стоила)

я ещё попробую взять обычный ADSL модем и попробовать подключить его через vlan. может действительно интерфейс.....

хотя неверю, интерфейс тупой, ему что линейную качку через себя гнать, что торрента, на каналаньном уровне без разницы

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от fantom (??) on 27-Авг-09, 12:36 
>[оверквотинг удален]
>мммм.... мне сложно представить себе что вы имеете ввиду под словом ADSL
>коммутатор?
>WIC интерфейс? он ведь родной, цисковский, трудно представить что циска сделала хреновую
>карту за штуку баксов(когдато она столько и стоила)
>
>я ещё попробую взять обычный ADSL модем и попробовать подключить его через
>vlan. может действительно интерфейс.....
>
>хотя неверю, интерфейс тупой, ему что линейную качку через себя гнать, что
>торрента, на каналаньном уровне без разницы

Таки нет.
ADSL как ни крути - ATM, а Ethernet - НЕТ!
Если через модем - то Ethernet-ATM преобразование будет выполняться модемом.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от silvercaptain (ok) on 27-Авг-09, 10:40 
>>1. Загрузка пиковая или постоянная
>

Я думаю это из-за Nat'а

Если мозможно, можно проверить, как себя закгрузка ведет без ната?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от alex6999 email(ok) on 27-Авг-09, 16:58 
>Я думаю это из-за Nat'а
>Если мозможно, можно проверить, как себя закгрузка ведет без ната?

без торрента всё нормально, загрузка проца 35%

но если это НАТ, почему 837 грузился точно также?

если у меня будет 50/50mbps интернет, то какой роутер мне понадобится? вероятно 3725, а то 3745? .... это судя по таблице скорости


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от fantom (??) on 27-Авг-09, 17:22 
>>Я думаю это из-за Nat'а
>>Если мозможно, можно проверить, как себя закгрузка ведет без ната?
>
>без торрента всё нормально, загрузка проца 35%
>
>но если это НАТ, почему 837 грузился точно также?
>
>если у меня будет 50/50mbps интернет, то какой роутер мне понадобится? вероятно
>3725, а то 3745? .... это судя по таблице скорости

Это если без НАТ-а :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от silvercaptain (ok) on 27-Авг-09, 17:36 
>>Я думаю это из-за Nat'а
>>Если мозможно, можно проверить, как себя закгрузка ведет без ната?
>
>без торрента всё нормально, загрузка проца 35%
>

Понятно, что Nat очень сильно откушивает процессор, torrent  не самая приятная штука. он генерирует кучу соеденений, которых нужно держать постоянно в памяти, постоянно поддерживать и т.д и т.п

Попробуйте так: ip nat translation max-entries all-host 500   :-)
А вообще проще поставить ту же 837 перед 3725 исключительно для ната и забыть проблему :-)


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от silvercaptain (ok) on 27-Авг-09, 17:47 

>Попробуйте так: ip nat translation max-entries all-host 500   :-)

ну и

ip nat translation timeout 300
ip nat translation tcp-timeout 600

для полноты :-) если помогло - подбирайте оптимальыне параметры

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от Зло on 30-Авг-09, 23:19 
>
>>Попробуйте так: ip nat translation max-entries all-host 500   :-)
>
>ну и
>
>ip nat translation timeout 300
>ip nat translation tcp-timeout 600
>
>для полноты :-) если помогло - подбирайте оптимальыне параметры

поддерживаю, у меня 1711 и на 10мбит/с 2 компа с торрента активно(в сумме забивают 8мбит/с) занимают 75-80% CPU. после отключения ip inspect снизилось до 60-70%(
ip nat translation tcp-timeout 1200
ip nat translation udp-timeout 30
ip nat translation finrst-timeout 10
ip nat translation syn-timeout 30
ip nat translation dns-timeout 3
ip nat translation icmp-timeout 5). в торренте основная проблема не в количестве соединений а в размере пакета. обратите внимание у себя на  это.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от alex6999 email(ok) on 06-Сен-09, 11:52 
>>>Попробуйте так: ip nat translation max-entries all-host 500   :-)

спасибо помогает. только вот существует-ли способ назначить для
ip nat inside source static tcp 10.1.2.3 80 interface dialer 1 80
более высокий приоритет чем для
ip nat inside source static tcp 10.1.2.3 1723 interface Dialer1 1723

а то важные соединения могут отметатся.

куда копать? в QoS?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от KiM (??) on 07-Сен-09, 14:32 
>[оверквотинг удален]
>
>спасибо помогает. только вот существует-ли способ назначить для
>ip nat inside source static tcp 10.1.2.3 80 interface dialer 1 80
>
>более высокий приоритет чем для
>ip nat inside source static tcp 10.1.2.3 1723 interface Dialer1 1723
>
>а то важные соединения могут отметатся.
>
>куда копать? в QoS?

никуда не копать, ведь uplink вы не контролируете. если всёже контролируете то да qos

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от Mick (??) on 16-Сен-09, 20:08 
>[оверквотинг удален]
>
>спасибо помогает. только вот существует-ли способ назначить для
>ip nat inside source static tcp 10.1.2.3 80 interface dialer 1 80
>
>более высокий приоритет чем для
>ip nat inside source static tcp 10.1.2.3 1723 interface Dialer1 1723
>
>а то важные соединения могут отметатся.
>
>куда копать? в QoS?

Копать, очевидно, в торрент-клиента - в них обычно выставляется  максимальное количество пиров Ж)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от silvercaptain (ok) on 27-Авг-09, 17:56 

>если у меня будет 50/50mbps интернет, то какой роутер мне понадобится? вероятно
>3725, а то 3745? .... это судя по таблице скорости

Скорее что-то из этого..

http://www.cisco.com/en/US/prod/collateral/vpndevc/ps6032/ps...

с учетом, что bandwidth capacity != NAT perfomance

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "Была загрузка CPU 99%, поставил более мощный роутер - опять ..."  +/
Сообщение от CrAzOiD (ok) on 16-Сен-09, 21:16 
>

у меня 827 на 6 мбит ADSL под торрентом работала. Тяжко ей было, но справлялась.
Есть подозрение на фрагментацию. Попробуйте поработать над MTU и mss

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру