The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Правильно ли настроен QoS для VoIP"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Правильно ли настроен QoS для VoIP"  +/
Сообщение от Денис (??) on 02-Окт-09, 14:45 
Вот выписка из регламента предоставления услуг передачи данных провайдера:
Организация постоянного цифрового виртуального канала точка-точка IP/MPLS
1.    Абоненту предоставляется возможность использовать приоритетный тип трафика для обеспечения гарантированной скорости передачи в рамках цифрового виртуального канала точка-точка.
2.    Идентификация приоритетного трафика осуществляется в сети Абонента проставлением значения IP Precedence в поле ToS пакета IP (значения 2 и 5). Пакеты с другим значением IP Precedence классифицируются как низкоприоритетный трафик.
3.    Обслуживание приоритетного трафика осуществляется при условии утилизации полосы пропускания линии доступа на порту Абонента и/или порту узла доступа не более 70%. При превышении 70%-го порога полосы пропускания параметры качества на линии доступа не гарантируются.
4.    Ограничение обслуживания трафика может производиться как для входящего в сеть передачи данных Оператора (от Абонента) трафика, так и для исходящего в сторону Абонента. Ограничение приоритетного трафика производится в соответствии с заказанной гарантированной скоростью передачи. Суммарное ограничение трафика (приоритетный + низкоприоритетный) на порту доступа Абонента производится в размере 3-х кратной заказанной гарантированной скорости передачи. При превышении указанных значений происходит сброс пакетов.
========================================================================================
На центральной циске 2851 настроено следующее:
!
class-map match-any VOIP
match access-group name ACLVIP
!
!
policy-map PRI256
class VOIP
  priority 256
  set ip precedence 5
class class-default
  fair-queue
  random-detect
policy-map TUN_256
class class-default
  shape average 768000
  service-policy PRI256
!
policy-map PRI128
class VOIP
  priority 128
  set ip precedence 5
class class-default
  fair-queue
  random-detect
policy-map TUN_128
class class-default
  shape average 384000
  service-policy PRI128
!
policy-map PRI64
class VOIP
  priority 64
  set ip precedence 5
class class-default
  fair-queue
  random-detect
policy-map TUN_64
class class-default
  shape average 192000
  service-policy PRI64
!
policy-map PRI32
class VOIP
  priority 32
  set ip precedence 5
class class-default
  fair-queue
  random-detect
policy-map TUN_32
class class-default
  shape average 96000
  service-policy PRI32
!
!
interface Loopback0
ip address 192.168.100.101 255.255.255.255
ip pim sparse-dense-mode
!
!
interface Tunnel27
bandwidth 768
...
qos pre-classify
...
service-policy output TUN_256
!
interface Tunnel40
bandwidth 384
...
qos pre-classify
...
service-policy output TUN_128
!
interface Tunnel23
bandwidth 192
...
qos pre-classify
...
service-policy output TUN_64
!
interface Tunnel43
bandwidth 96
...
qos pre-classify
...
service-policy output TUN_32
!
!
ip access-list extended ACLVIP
permit ip 192.168.100.0 0.0.0.255 192.168.100.0 0.0.0.255
========================================================================================
На удаленном маршрутизаторе 2801:
!
class-map match-any VOIP
match access-group name ACLVIP
!
!
policy-map PRIORITY
  class VOIP
  priority 32
  set ip precedence 5
  class class-default
  fair-queue
  random-detect
policy-map SHAPE
  class class-default
  shape average 96000
  service-policy PRIORITY
!
!
interface Tunnel0
bandwidth 96
...
qos pre-classify
...
service-policy output SHAPE
!
!
interface Loopback0
ip address 192.168.100.43 255.255.255.255
h323-gateway voip interface
h323-gateway voip id gk ipaddr 192.168.100.101 1719 priority 10
h323-gateway voip h323-id XXXX
h323-gateway voip tech-prefix 1#
h323-gateway voip bind srcaddr 192.168.100.43
!
!
ip access-list extended ACLVIP
permit ip 192.168.100.0 0.0.0.255 192.168.100.0 0.0.0.255
!
!
dial-peer voice 1 voip
...
codec g729r8 bytes 40
=======================================================================================
Хочу узнать правильно ли у меня настроено?
И можно ли как то улучшить передачу голоса, потому что на узлах с гарантированной скоростю 32К, 64К при приеме/передаче почты и т.п. голос начинает временами пропадать. Иногда появляется бульканье при разговоре.
Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Правильно ли настроен QoS для VoIP"  +/
Сообщение от GolDi (??) on 02-Окт-09, 14:58 
>[оверквотинг удален]
>!
>!
>dial-peer voice 1 voip
> ...
> codec g729r8 bytes 40
>=======================================================================================
>Хочу узнать правильно ли у меня настроено?
>И можно ли как то улучшить передачу голоса, потому что на узлах
>с гарантированной скоростю 32К, 64К при приеме/передаче почты и т.п. голос
>начинает временами пропадать. Иногда появляется бульканье при разговоре.

Так вы у себя проверьте классифицируются ли у вас пакеты с голосом,
и нет ли дропов уже с вашей стороны?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Правильно ли настроен QoS для VoIP"  +/
Сообщение от Денис (??) on 04-Окт-09, 19:33 
>Так вы у себя проверьте классифицируются ли у вас пакеты с голосом,
>
>и нет ли дропов уже с вашей стороны?

а не подскажите как? никогда этого не делал :(

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Правильно ли настроен QoS для VoIP"  +/
Сообщение от mario email(ok) on 05-Окт-09, 08:38 
>>Так вы у себя проверьте классифицируются ли у вас пакеты с голосом,
>>
>>и нет ли дропов уже с вашей стороны?
>
>а не подскажите как? никогда этого не делал :(

к примеру sh policy-map int tu23

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Правильно ли настроен QoS для VoIP"  +/
Сообщение от Денис (??) on 05-Окт-09, 09:58 
>к примеру sh policy-map int tu23

вот что получилось, видно что трафик классифицируется, а вот что с дропами делать?
#sh policy-map int tu23
Tunnel23
  Service-policy output: TUN_64
    Class-map: class-default (match-any)
      26337269 packets, 4562138151 bytes
      5 minute offered rate 2000 bps, drop rate 0 bps
      Match: any
      Traffic Shaping
           Target/Average   Byte   Sustain   Excess    Interval  Increment
             Rate           Limit  bits/int  bits/int  (ms)      (bytes)
           192000/192000    1968   7872      7872      41        984

        Adapt  Queue     Packets   Bytes     Packets   Bytes     Shaping
        Active Depth                         Delayed   Delayed   Active
        -      0         26317660  4045188853 1365753   1295844165 no
      Service-policy : PRI64
        Class-map: VOIP (match-any)
          2476979 packets, 246746843 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group name ACLVIP
            2476979 packets, 246746843 bytes
            5 minute rate 0 bps
          Queueing
            Strict Priority
            Output Queue: Conversation 40
            Bandwidth 64 (kbps) Burst 1600 (Bytes)
            (pkts matched/bytes matched) 32712/2635284
            (total drops/bytes drops) 0/0
          QoS Set
            precedence 5
              Packets marked 2476979
        Class-map: class-default (match-any)
          23860288 packets, 4315391004 bytes
          5 minute offered rate 2000 bps, drop rate 0 bps
          Match: any
          Queueing
            Flow Based Fair Queueing
            Maximum Number of Hashed Queues 32
        (total queued/total drops/no-buffer drops) 0/428/0
             exponential weight: 9
  class    Transmitted      Random drop      Tail drop    Minimum Maximum  Mark
           pkts/bytes       pkts/bytes       pkts/bytes    thresh  thresh  prob
      0  357301/22794366      382/532909        42/58471       20      40  1/10
      1       0/0               0/0              0/0           22      40  1/10
      2       0/0               0/0              0/0           24      40  1/10
      3       0/0               0/0              0/0           26      40  1/10
      4       0/0               0/0              0/0           28      40  1/10
      5 4294967292/18446744073709551376      4/240            0/0           30      40  1/10
      6 1235047/122191436       0/0              0/0           32      40  1/10
      7       0/0               0/0              0/0           34      40  1/10
   rsvp       0/0               0/0              0/0           36      40  1/10

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру