The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"2isp ручное переключение"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"2isp ручное переключение"  +/
Сообщение от sash555 email(ok) on 05-Окт-09, 17:52 
Здравствуй всезнающий all.
Решил разобраться с тем, как настроить подключение к 2м провайдерам. Дано: 2 подключения со статическими адресами. Настроил так

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
boot-start-marker
boot system flash:c1841-advipservicesk9-mz.124-25b.bin
boot-end-marker
!
no aaa new-model
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
username admin privilege 15 secret 5 hjfgkjhgjkhgkjhg
archive
log config
  hidekeys
! Смотрит в локалку
interface FastEthernet0/0
ip address 10.10.10.14 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
! Дефолтный влан
interface FastEthernet0/1
no ip address
duplex auto
speed auto
! Основной провайдер
interface FastEthernet0/1.1
encapsulation dot1Q 50
ip address 212.152.xx.212 255.255.255.248
ip nat outside
ip virtual-reassembly
! Резервный(дорогой) провайдер
interface FastEthernet0/1.2
encapsulation dot1Q 60
ip address 83.102.xx.34 255.255.255.240
ip nat outside
ip virtual-reassembly
!
ip forward-protocol nd
! 2 маршрута с разной метрикой
ip route 0.0.0.0 0.0.0.0 212.152.xx.209
ip route 0.0.0.0 0.0.0.0 83.102.xx.33 10
!
ip nat inside source route-map corbina_nat interface FastEthernet0/1.2 overload
ip nat inside source route-map inetcomm_nat interface FastEthernet0/1.1 overload
!
ip access-list standard corbGW
permit 83.102.xx.33
ip access-list standard inetGW
permit 212.152.xx.209
!
access-list 1 permit 10.10.10.0 0.0.0.255
access-list 2 permit 10.10.10.0 0.0.0.255
!
route-map inetcomm_nat permit 10
match ip address 1
match ip next-hop inetGW
!
route-map corbina_nat permit 10
match ip address 2
match ip next-hop corbGW
!
control-plane
!
scheduler allocate 20000 1000
end

Настраивать пытаюсь по http://www.cisco.com/en/US/tech/tk648/tk361/technologies_con...

Создал 2 роатмапа, 2 маршрута добавил, с разной метрикой. Хочу чтоб при опускании интерфейса  FastEthernet0/1.1 данные лезли в FastEthernet0/1.2 Если сохраняю и перезагрузаю железку, то трафик начинает ходить через резервного прова. А без перезагрузки не хочет ни в какую. Помогите понять в чем дело?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "2isp ручное переключение"  +/
Сообщение от Николай (??) on 07-Окт-09, 11:04 
Посмотри в сторону IP SLA тема неоднократно поднималась на форуме, проблема в твоей реализации что при падении основного прова происходит переход на резерв но при его включении
дефаулт роут обратно не перестраивается.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "2isp ручное переключение"  +/
Сообщение от sash555 email(ok) on 08-Окт-09, 13:55 
Вот что странно, дело похоже не в маршруте. Даже если я оставляю один маршрут. Например на основного прова ip route 0.0.0.0 0.0.0.0 212.152.xx.209
Запускаю пинги - работает. Грохаю его. Добавляю другой ip route 0.0.0.0 0.0.0.0 83.102.xx.33
Не работает. Сохраняю конфиг, перегружаю роутер - работает! Мне не понятно почему НЕ работает БЕЗ перезагрузки, и почему работает после неё?
Такое чувство, будто зарулив в один route-map всё наглухо там и остается... С кошки всё работает без перезагрузок, а вот с компа за ней только С перезагрузкой.
--------------------------
Бэн это Данила!
I need help!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "2isp ручное переключение"  +/
Сообщение от pavel2084 (??) on 08-Окт-09, 15:00 
>[оверквотинг удален]
>Запускаю пинги - работает. Грохаю его. Добавляю другой ip route 0.0.0.0 0.0.0.0
>83.102.xx.33
>Не работает. Сохраняю конфиг, перегружаю роутер - работает! Мне не понятно почему
>НЕ работает БЕЗ перезагрузки, и почему работает после неё?
>Такое чувство, будто зарулив в один route-map всё наглухо там и остается...
>С кошки всё работает без перезагрузок, а вот с компа за
>ней только С перезагрузкой.
>--------------------------
>Бэн это Данила!
>I need help!

https://www.opennet.ru/base/cisco/ip_sla.txt.html

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "2isp ручное переключение"  +/
Сообщение от sash555 email(ok) on 08-Окт-09, 16:27 
Спасибо за ссылку, прочел, посмотрел, обязательно буду пробовать как написано. Но хотелось бы все таки услышать ответ, почему в моем конкретно случае наблюдается такое поведение железки. show ip nat translation даже после удаления старого маршрута, и добавления нового показывает что icmp продолжают долбиться через старый интерфейс. Мне важно именно понимание
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "2isp ручное переключение"  +/
Сообщение от pavel2084 (ok) on 08-Окт-09, 17:57 
>Спасибо за ссылку, прочел, посмотрел, обязательно буду пробовать как написано. Но хотелось
>бы все таки услышать ответ, почему в моем конкретно случае наблюдается
>такое поведение железки. show ip nat translation даже после удаления старого
>маршрута, и добавления нового показывает что icmp продолжают долбиться через старый
>интерфейс. Мне важно именно понимание

Ну в конфиге написано следующее:

route-map inetcomm_nat permit 10
match ip address 1
match ip next-hop inetGW
!
route-map corbina_nat permit 10
match ip address 2
match ip next-hop corbGW

а в мануале от cisco:

route-map fixed-nat permit 10
match ip address 110
match interface XXXXX
!
route-map dhcp-nat permit 10
match ip address 110
match interface YYYYY

разные команды дают разный результат :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "2isp ручное переключение"  +/
Сообщение от sash555 email(ok) on 11-Ноя-09, 17:30 
>разные команды дают разный результат :)

Юмор это хорошо. НО... Поскольку никто мне ответ на мой вопрос так и не дал, отвечу сам
в статье http://cisco.far.ru/2isp.html написана замечательная фраза:
"если мы хотим сделать per-packet load-balancing, то на всех интерфейсах, которые соединяют нас с провайдером, ставим no ip route-cache, если же нужно per-destination, то на всех - ip route-cache. Заметьте, что если хотя бы на одном выходном интерфейсе используется NAT, то нельзя использовать per-packet, так как это приведёт к пропаданию пакетов..."

В моем конкретно случае было следующее. Я запустив ping с машины, которая стоит за кошкой с ключом -t наблюдал явление полного пропадания пингов при гашении одного интерфейса. И даже не догадывался о том, что если бы я запустил ping на другой внешний ip то пакетики бы пошли!
То есть я во всей красе увидел и почувствовал работу ip route-cache алгоритма. И в моём конкретно случае нужно использовать per-packet. Но у меня как раз случай с NAT-ами на внешних интерфейсах.
В общем при выключеном ip cef добился балансировки нагрузки. Теперь нужно добиться резервирования...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру