The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Постоянная перезагрузка маршрутизаторов."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Cisco маршрутизаторы)
Изначальное сообщение [ Отслеживать ]

"Постоянная перезагрузка маршрутизаторов."  +/
Сообщение от cisco_ibm (ok) on 30-Ноя-09, 00:44 
Коллеги, приветствую!

Подскажите что может быть причинной следующего глюка:
Был рутер 2811 на котором висело 5 ISP. В один прекрасный момент это рутер начал постоянно перезагружаться. Первая мысль которая пришла в голову - глючный IOS, перепрошил на новый, результат тот же. Смотрел crashinfo, ничего нужного там не обнаружил. Решил что рутеру пришел каюк и начал переводит каналы на новое оборудование – (маршрутизатор 2811 и карта HWIC-4ESW, в которую подключаются провайдеры).
Перевел  три ISP и старому рутеру полегчало перезагрузки больше нет. Зато новый рутер начал постоянно перезагружаться.  Трафик который проходит через рутер в переделах нормы, аномалий никаких нет. Есть подозрения, что может быть проблема на L2, потому что два ISP идут через один смежный узел. Вроде как отключение одного ISP (ISP1, vlan 108)приводит к исчезновению этого глюка, но пока точной уверенности нет.
В консоли выводятся ошибки связанные с ошибкой с неправильным режимом dupex - нужно hulf стоит full, это получаю от коммутатора ISP через STP, делаю hulf, тогда от другого коммутатора этого же провайдера я получаю что  надо ставить full.

Конфиг прилагаю
no spanning-tree vlan 109 (пришлось отключить на vlan 109, потому что от ISP1 идут пакеты bpdu, которые просят перевести порт в trunk)

interface FastEthernet0/0/0
description ISP1
switchport access vlan 109
no keepalive
no cdp enable
!
interface FastEthernet0/0/1
description ISP2
switchport access vlan 121
no keepalive
no cdp enable
!
interface FastEthernet0/0/2
description ISP3
switchport access vlan 108
no keepalive
no cdp enable
!
interface FastEthernet0/0/3
shutdown
!
interface Vlan108
description ISP3
ip address ----------
ip access-group 333 in
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly
!
interface Vlan109
description ISP1
ip address ----------
ip access-group 111 in
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly
!
interface Vlan121
description ISP2
ip address --------
ip access-group 222 in
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly

GATE#sh spanning-tree

VLAN108 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0023.04b0.d5e9
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 001b.11b6.367a
  Root port is 3 (FastEthernet0/0/2), cost of root path is 32339
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:13:18 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 3 (FastEthernet0/0/2) of VLAN108 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.3.
   Designated root has priority 32768, address 001b.11b6.367a
   Designated bridge has priority 32768, address 001b.11b6.3cf7
   Designated port id is 128.1, designated path cost 32320
   Timers: message age 3, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 0, received 387

          
VLAN121 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0023.04b0.d5e8
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 1 last change occurred 00:12:48 ago
          from FastEthernet0/0/1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 1, topology change 0, notification 0, aging 300

Port 2 (FastEthernet0/0/1) of VLAN121 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.2.
   Designated root has priority 32768, address 0023.04b0.d5e8
   Designated bridge has priority 32768, address 0023.04b0.d5e8
   Designated port id is 128.2, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 402, received 0

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Постоянная перезагрузка маршрутизаторов."  +/
Сообщение от Hawk (??) on 30-Ноя-09, 09:08 
Предлагаю банально проверить питание - поменять все кабели, ИБП, удлинители.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Постоянная перезагрузка маршрутизаторов."  +/
Сообщение от cisco_ibm (ok) on 30-Ноя-09, 10:57 
>Предлагаю банально проверить питание - поменять все кабели, ИБП, удлинители.

Проверили все ОК.
Более того на ИБП висит другое оборудвоание которое тоже тогда бы перезагружалось.
Проблема перешла с переносом провайдеров.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Постоянная перезагрузка маршрутизаторов."  +/
Сообщение от zaikini (ok) on 30-Ноя-09, 14:04 
>>Предлагаю банально проверить питание - поменять все кабели, ИБП, удлинители.
>
>Проверили все ОК.
>Более того на ИБП висит другое оборудвоание которое тоже тогда бы перезагружалось.
>
>Проблема перешла с переносом провайдеров.

Какая причина перезагрузки в show version? что в логах в этот момент?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Постоянная перезагрузка маршрутизаторов."  +/
Сообщение от cisco_ibm (ok) on 30-Ноя-09, 23:23 
>>>Предлагаю банально проверить питание - поменять все кабели, ИБП, удлинители.
>>
>>Проверили все ОК.
>>Более того на ИБП висит другое оборудвоание которое тоже тогда бы перезагружалось.
>>
>>Проблема перешла с переносом провайдеров.
>
>Какая причина перезагрузки в show version? что в логах в этот момент?
>

System returned to ROM by error - a Software forced crash, PC 0x400609A8 at 22:44:50 Moscow Mon Nov 30 2009
System image file is "flash:c2800nm-advsecurityk9-mz.124-24.T2.bin"


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Постоянная перезагрузка маршрутизаторов."  +/
Сообщение от cisco_ibm (ok) on 05-Дек-09, 00:00 
>>>Предлагаю банально проверить питание - поменять все кабели, ИБП, удлинители.
>>
>>Проверили все ОК.
>>Более того на ИБП висит другое оборудвоание которое тоже тогда бы перезагружалось.
>>
>>Проблема перешла с переносом провайдеров.
>
>Какая причина перезагрузки в show version? что в логах в этот момент?
>

System returned to ROM by error - a Software forced crash, PC 0x400609A8 at 22:44:50 Moscow Mon Nov 30 2009
System image file is "flash:c2800nm-advsecurityk9-mz.124-24.T2.bin"

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Постоянная перезагрузка маршрутизаторов."  +/
Сообщение от j_vw on 05-Дек-09, 00:16 
http://www.cisco.com/en/US/products/hw/iad/ps397/products_te...
Вроде, show stacks отдает, после релода, последние сообщения в лог.
Может чего то интересное и найдется...
P.S. У меня эта прошивка на одном из рутеров, вроде, работает без сбоев....
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Постоянная перезагрузка маршрутизаторов."  +/
Сообщение от cisco_ibm (ok) on 05-Дек-09, 01:17 
>http://www.cisco.com/en/US/products/hw/iad/ps397/products_te...
>Вроде, show stacks отдает, после релода, последние сообщения в лог.
>Может чего то интересное и найдется...
>P.S. У меня эта прошивка на одном из рутеров, вроде, работает без
>сбоев....

спасибо. буду смотреть.
Есть подозрения что все это происходит из-за переполнения таблиц NAT трансляций.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Постоянная перезагрузка маршрутизаторов."  +/
Сообщение от cisco_ibm (ok) on 23-Мрт-10, 09:58 
>>http://www.cisco.com/en/US/products/hw/iad/ps397/products_te...
>>Вроде, show stacks отдает, после релода, последние сообщения в лог.
>>Может чего то интересное и найдется...
>>P.S. У меня эта прошивка на одном из рутеров, вроде, работает без
>>сбоев....
>
>спасибо. буду смотреть.
>Есть подозрения что все это происходит из-за переполнения таблиц NAT трансляций.

Методом проб обнаружил что зависания были связаны с коммандой  
ip nbar protocol-discovery

убрал ее с интерфейсов и все работает как лялечка. :)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру