The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Настройка CISCO NAT на почтовик на определенный ip"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Настройка CISCO NAT на почтовик на определенный ip"  +/
Сообщение от sundoom email(ok) on 19-Мрт-10, 06:17 
Здравствуйте.
Задача такая. Имеется сервак, на котором поднят локальный почтовик. Зарегистрировано доменное имя на него. У провайдера были выделены для нас доп. ip адреса для почтовика. На циске настроен НАТ.
Как сделать так, чтобы почта уходила и приходила по одному ip адресу (yyy.yyy.yyy.yyy), а весь остальной трафик ходил по ip ххх.ххх.ххх.ххх? Или посоветуйте, плиз, как грамотно сделать. Вот часть конфиги:

interface Loopback0
ip address yyy.yyy.yyy.yyy 255.255.255.255 secondary
ip address xxx.xxx.xxx.xxx 255.255.255.255
!
interface FastEthernet0/0
description LAN
ip address 192.168.11.1 255.255.255.0 secondary
ip address 192.168.10.1 255.255.255.0
ip nbar protocol-discovery
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/3/0:0
ip unnumbered Loopback0
no ip redirects
no ip proxy-arp
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly
encapsulation ppp
no peer default ip address
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 zzz.zzz.zzz.zzz
!

no ip http server
no ip http secure-server
ip nat inside source list 10 interface Loopback0 overload
ip nat inside source static tcp 192.168.10.2 25 yyy.yyy.yyy.yyy 25 extendable
!
access-list 10 permit 192.168.10.0 0.0.0.255

Добавлю. Когда почта уходит во вне, то она уходит по ip ххх.ххх.ххх.ххх, а должна по ip yyy.yyy.yyy.yyy, соответственно внешние почтовики меня банят по этому ip.


и еще. На сайте freedns.ws  у меня зарегистрирован домен, на котором и прописаны все необходимые DNS записи, за исключением PTR. Не могу прописать и все - ругается "Error: Invalid PTR records". Пишу вот это: 44.33.22.11.in-addr.arpa PTR domen.ru
Может кто прописывал зону именно на этом сайте? Может что-то там не работает?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Настройка CISCO NAT на почтовик на определенный ip"  +/
Сообщение от Gbyte email(ok) on 19-Мрт-10, 06:58 
>
>и еще. На сайте freedns.ws  у меня зарегистрирован домен, на котором
>и прописаны все необходимые DNS записи, за исключением PTR. Не могу
>прописать и все - ругается "Error: Invalid PTR records". Пишу вот
>это: 44.33.22.11.in-addr.arpa PTR domen.ru
>Может кто прописывал зону именно на этом сайте? Может что-то там не
>работает?

Обратная зона принадлежит провайдеру.
И либо делигируется от провайдера вашему днс, либо ведется самим провайдером.
Обычно ведется провайдером, звонишь прову и говоришь прошу в обратной зоне ип-адресу у.у.у.у дать имя такое-то и все. через несколько часов твой ип будет в правильное имя разрешаться.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Настройка CISCO NAT на почтовик на определенный ip"  +/
Сообщение от eek email on 19-Мрт-10, 09:25 
SPF record в DNS добавить не забудь.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Настройка CISCO NAT на почтовик на определенный ip"  +/
Сообщение от sundoom email(ok) on 19-Мрт-10, 11:27 
>SPF record в DNS добавить не забудь.

что за SPF record - для чего нужна?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Настройка CISCO NAT на почтовик на определенный ip"  +/
Сообщение от Gbyte email(ok) on 19-Мрт-10, 12:02 
>>SPF record в DNS добавить не забудь.
>
>что за SPF record - для чего нужна?

http://en.wikipedia.org/wiki/Sender_Policy_Framework
http://www.openspf.org/

гугл рулит.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Настройка CISCO NAT на почтовик на определенный ip"  +/
Сообщение от sundoom email(ok) on 19-Мрт-10, 11:26 

>Обратная зона принадлежит провайдеру.
>И либо делигируется от провайдера вашему днс, либо ведется самим провайдером.
>Обычно ведется провайдером, звонишь прову и говоришь прошу в обратной зоне ип-адресу
>у.у.у.у дать имя такое-то и все. через несколько часов твой ип
>будет в правильное имя разрешаться.

Они обратную зону мне делегировали. И даже ссылку CNAME на ptr сделали. А самой ptr нет - не могу ввести. Не знаю чего там делать :-(

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру