The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Два PPPoE от одного ISP"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Два PPPoE от одного ISP"  +/
Сообщение от knightbeholder (ok) on 11-Янв-12, 20:40 
На cisco  заведены два pppoe  соединения от одного провайдера. За маршрутизатором существует несколько подсетей. Задача перенаправлять одну подсеть под одному маршруту, а остальные по второму.
-----------------------------------------------------------------------------------
interface FastEthernet0/1.22
description inet-tunnel-1
encapsulation dot1Q 22
ip address 10.2.7.1 255.255.255.0
ip broadcast-address 10.2.7.255
ip nat inside
ip virtual-reassembly
rate-limit input 512000 128000 128000 conform-action transmit exceed-action drop
rate-limit output 512000 128000 128000 conform-action transmit exceed-action drop
no cdp enable
!
interface FastEthernet0/1.25
description VLAN-25-inet-tunnel-2
encapsulation dot1Q 25
ip address 192.168.25.1 255.255.255.248
ip broadcast-address 192.168.25.6
ip nat inside
ip virtual-reassembly
rate-limit input 512000 60000 64000 conform-action continue exceed-action drop
rate-limit output 512000 60000 64000 conform-action continue exceed-action drop
!
interface FastEthernet0/1.26
description VLAN-26-inet-tunnel-3
encapsulation dot1Q 26
ip address 192.168.26.1 255.255.255.248
ip broadcast-address 192.168.26.6
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.27
description VLAN-27-internet-4
encapsulation dot1Q 27
ip address 192.168.27.1 255.255.255.224
ip broadcast-address 192.168.27.31
ip nat inside
ip virtual-reassembly
rate-limit output 1240000 512000 512000 conform-action continue exceed-action drop
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
switchport access vlan 2
no mop enabled
!
interface FastEthernet0/1/2
switchport access vlan 3
!
interface FastEthernet0/1/3
switchport access vlan 2
!
interface Vlan1
no ip address
!
interface Vlan2
no ip address
pppoe enable
pppoe-client dial-pool-number 2
!
interface Vlan3
no ip address
pppoe enable
pppoe-client dial-pool-number 3
!
interface Dialer1
description InterNET- статический
mtu 1492
bandwidth 2048
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 3
dialer-group 3
no cdp enable
ppp authentication chap callin
ppp chap hostname
ppp chap password 0
ppp pap sent-username  password
!
interface Dialer2
description InterNET- PPPoE  динамический
mtu 1492
ip address negotiated
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly
encapsulation ppp
shutdown
dialer pool 2
dialer-group 2
no cdp enable
ppp authentication chap callin
ppp chap hostname
ppp chap password 0
ppp pap sent-username  password 0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
ip http server
ip http authentication local
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source list 10 interface Dialer1 overload
ip nat inside source list 25 interface Dialer1 overload
ip nat inside source list 26 interface Dialer1 overload
ip nat inside source list 27 interface Dialer1 overload

!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 10 permit 10.2.7.0 0.0.0.255
access-list 25 permit 192.168.25.0 0.0.0.7
access-list 26 permit 192.168.26.0 0.0.0.7
access-list 27 permit 192.168.27.0 0.0.0.31


dialer-list 2 protocol ip permit
dialer-list 3 protocol ip permit
!

----------------------
access-list 10 permit 10.2.7.0 0.0.0.255 – должен ходить через dialer 1. Все остальные по Dialer 2

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Два PPPoE от одного ISP"  +/
Сообщение от koblin (ok) on 17-Янв-12, 23:07 
наверное стоит посмотреть про route-map и set ip default next-hop
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру