The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco 1841 PPTP server - объединение подсетей"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VPN, VLAN, туннель)
Изначальное сообщение [ Отслеживать ]

"Cisco 1841 PPTP server - объединение подсетей"  +/
Сообщение от skazo4nik18 (ok) on 22-Мрт-12, 16:44 
Добрый день! настроил у себя pptp на удаленном хосте.
Проблема заключается в том что - клиент из вне получает ip в подсети 10, но не видит локальные машины в подсети 0. В кошках новичок, помогите плиз)
Кофинг:

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$6Cr3$RkhjdhjdfhjdgfsrVNGNlIEG3l1
!
no aaa new-model
!
resource policy
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1 192.168.0.50
ip dhcp excluded-address 192.168.0.1 192.168.0.49
!
ip dhcp pool LAN
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 192.168.0.1 8.8.8.8
!
!
vpdn enable
!
vpdn-group 2
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
!
!
!
!
username admin privilege 15 password 0
username vpnuser password 0 A
!
!
!
!
!
!
interface FastEthernet0/0
description $ES_LAN$
ip address 192.168.0.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/0.1
no cdp enable
!
interface FastEthernet0/1
ip address dhcp
speed 10
half-duplex
pppoe enable
pppoe-client dial-pool-number 1
!
interface ATM0/0/0
description Stream
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 1/50
  encapsulation aal5snap
  pppoe-client dial-pool-number 2
!
!
interface Virtual-Template1
ip unnumbered FastEthernet0/0
ip nat inside
ip virtual-reassembly
peer default ip address pool vpnpool
no keepalive
ppp encrypt mppe auto
ppp authentication pap chap ms-chap
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname
ppp chap password 0
!
interface Dialer2
description Stream PPPoE
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 2
dialer-group 2
no cdp enable
ppp authentication chap callin
ppp chap hostname ppp@mtu
ppp chap password 0
ppp pap sent-username ppp@mtu password 0
!
ip local pool vpnpool 192.168.10.1 192.168.10.250
ip route 0.0.0.0 0.0.0.0 Dialer2
!
!
ip http server
ip http authentication local
no ip http secure-server
ip nat translation timeout 120
ip nat translation tcp-timeout 120
ip nat translation udp-timeout 120
ip nat inside source list 1 interface Dialer2 overload
ip nat inside source static tcp 192.168.0.1 1723 interface Dialer2 1723
ip nat inside source static tcp 192.168.0.3 3389 interface Dialer2 3389
ip nat inside source static tcp 192.168.0.1 23 interface Dialer2 22
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 permit 192.168.10.0 0.0.0.255
no cdp run
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet
!
no scheduler allocate
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end


Роутер по впн пингуется, остальное - нет. Косяк кажется либо с маршрутом, либо с натом...
Заранее спасибо.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco 1841 PPTP server - объединение подсетей"  +1 +/
Сообщение от Николай_kv on 22-Мрт-12, 18:05 
>[оверквотинг удален]
> !
> webvpn context Default_context
>  ssl authenticate verify all
>  !
>  no inservice
> !
> end
> Роутер по впн пингуется, остальное - нет. Косяк кажется либо с маршрутом,
> либо с натом...
> Заранее спасибо.

Косяк в реализации PPTP от версии к версии у мелкомягких. Когда выстраиваеться ВПН, то в тунель будет уходит только 192.168.10.0/24 подсеть о сети 192.168.0.0/24 ничего не известно, поэтому, ее надо вручную на клиенте отроутить в тунель (но прикол в том что он у вас постоянно новый ИП получает) второй вариант - тыцнуть галоку использовать удаленный шлюз по умолчанию - но есть вероятность что вы включите дома торенты и удаленному каналу прийдут вафли. Третий за который прийму благоданость в WMZ )) использовать локальный ДХЦП пул для удаленных клиентов  peer default ip address dhcp-pool <NAME> на interface Virtual-Template

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Cisco 1841 PPTP server - объединение подсетей"  +/
Сообщение от skazo4nik18 (ok) on 22-Мрт-12, 18:34 
>[оверквотинг удален]
>> Заранее спасибо.
> Косяк в реализации PPTP от версии к версии у мелкомягких. Когда выстраиваеться
> ВПН, то в тунель будет уходит только 192.168.10.0/24 подсеть о сети
> 192.168.0.0/24 ничего не известно, поэтому, ее надо вручную на клиенте отроутить
> в тунель (но прикол в том что он у вас постоянно
> новый ИП получает) второй вариант - тыцнуть галоку использовать удаленный шлюз
> по умолчанию - но есть вероятность что вы включите дома торенты
> и удаленному каналу прийдут вафли. Третий за который прийму благоданость в
> WMZ )) использовать локальный ДХЦП пул для удаленных клиентов  peer
> default ip address dhcp-pool <NAME> на interface Virtual-Template

Прислушался к последнему совету. Теперь клиенты получают адресс в той же подсети, но все равно не пингуются товарищи внутри сети...

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Cisco 1841 PPTP server - объединение подсетей"  +/
Сообщение от skazo4nik18 (ok) on 22-Мрт-12, 19:57 
>[оверквотинг удален]
>> ВПН, то в тунель будет уходит только 192.168.10.0/24 подсеть о сети
>> 192.168.0.0/24 ничего не известно, поэтому, ее надо вручную на клиенте отроутить
>> в тунель (но прикол в том что он у вас постоянно
>> новый ИП получает) второй вариант - тыцнуть галоку использовать удаленный шлюз
>> по умолчанию - но есть вероятность что вы включите дома торенты
>> и удаленному каналу прийдут вафли. Третий за который прийму благоданость в
>> WMZ )) использовать локальный ДХЦП пул для удаленных клиентов  peer
>> default ip address dhcp-pool <NAME> на interface Virtual-Template
> Прислушался к последнему совету. Теперь клиенты получают адресс в той же подсети,
> но все равно не пингуются товарищи внутри сети...

Паралельно вопрос: почему он мне не двает сделать icmp-echo и вообще никаких команд не показывает? Прошивка advipservicesk9 12.4 (6) T.
Только вот памяти 128, а требуется 192.


Router(config)#ip sla monitor 100
Router(config-rtr)#?
SAA entry configuration commands:

Router(config-rtr)#icmp ?
% Unrecognized command
Router(config-rtr)#icmp-?
% Unrecognized command
Router(config-rtr)#icmp-echo
                   ^
% Invalid input detected at '^' marker.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Cisco 1841 PPTP server - объединение подсетей"  +/
Сообщение от Николай_kv on 23-Мрт-12, 11:15 
>[оверквотинг удален]
>> ВПН, то в тунель будет уходит только 192.168.10.0/24 подсеть о сети
>> 192.168.0.0/24 ничего не известно, поэтому, ее надо вручную на клиенте отроутить
>> в тунель (но прикол в том что он у вас постоянно
>> новый ИП получает) второй вариант - тыцнуть галоку использовать удаленный шлюз
>> по умолчанию - но есть вероятность что вы включите дома торенты
>> и удаленному каналу прийдут вафли. Третий за который прийму благоданость в
>> WMZ )) использовать локальный ДХЦП пул для удаленных клиентов  peer
>> default ip address dhcp-pool <NAME> на interface Virtual-Template
> Прислушался к последнему совету. Теперь клиенты получают адресс в той же подсети,
> но все равно не пингуются товарищи внутри сети...

пинг по IP адресу делаешь или по имени? Странно по идее этого должно хватать - схема откатаная. Незнаю может действительно прошивка неуютно чувствет себя на 128 вместо требуемых 192 - вкрути память она копейки сейчас стоит.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Cisco 1841 PPTP server - объединение подсетей"  +/
Сообщение от Николай_kv on 23-Мрт-12, 11:20 

> пинг по IP адресу делаешь или по имени? Странно по идее этого
> должно хватать - схема откатаная. Незнаю может действительно прошивка неуютно чувствет
> себя на 128 вместо требуемых 192 - вкрути память она копейки
> сейчас стоит.

может бональный виндовый фаервод включен у удаленной стороны которую пытаетесь пропинговать?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Cisco 1841 PPTP server - объединение подсетей"  +/
Сообщение от hop (??) on 23-Мрт-12, 11:43 
>[оверквотинг удален]
>> ВПН, то в тунель будет уходит только 192.168.10.0/24 подсеть о сети
>> 192.168.0.0/24 ничего не известно, поэтому, ее надо вручную на клиенте отроутить
>> в тунель (но прикол в том что он у вас постоянно
>> новый ИП получает) второй вариант - тыцнуть галоку использовать удаленный шлюз
>> по умолчанию - но есть вероятность что вы включите дома торенты
>> и удаленному каналу прийдут вафли. Третий за который прийму благоданость в
>> WMZ )) использовать локальный ДХЦП пул для удаленных клиентов  peer
>> default ip address dhcp-pool <NAME> на interface Virtual-Template
> Прислушался к последнему совету. Теперь клиенты получают адресс в той же подсети,
> но все равно не пингуются товарищи внутри сети...

вероятно, у Вас не хватает в конфиге на интерфейсе строчки
ip proxy-arp

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

7. "Cisco 1841 PPTP server - объединение подсетей"  +/
Сообщение от skazo4nik18 (ok) on 23-Мрт-12, 17:36 
>[оверквотинг удален]
>>> в тунель (но прикол в том что он у вас постоянно
>>> новый ИП получает) второй вариант - тыцнуть галоку использовать удаленный шлюз
>>> по умолчанию - но есть вероятность что вы включите дома торенты
>>> и удаленному каналу прийдут вафли. Третий за который прийму благоданость в
>>> WMZ )) использовать локальный ДХЦП пул для удаленных клиентов  peer
>>> default ip address dhcp-pool <NAME> на interface Virtual-Template
>> Прислушался к последнему совету. Теперь клиенты получают адресс в той же подсети,
>> но все равно не пингуются товарищи внутри сети...
> вероятно, у Вас не хватает в конфиге на интерфейсе строчки
> ip proxy-arp

не помогло... так же остро стоит проблема с ip sla, почему не стартует? :(

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Cisco 1841 PPTP server - объединение подсетей"  +/
Сообщение от Николай_kv on 23-Мрт-12, 17:43 
>[оверквотинг удален]
>>>> по умолчанию - но есть вероятность что вы включите дома торенты
>>>> и удаленному каналу прийдут вафли. Третий за который прийму благоданость в
>>>> WMZ )) использовать локальный ДХЦП пул для удаленных клиентов  peer
>>>> default ip address dhcp-pool <NAME> на interface Virtual-Template
>>> Прислушался к последнему совету. Теперь клиенты получают адресс в той же подсети,
>>> но все равно не пингуются товарищи внутри сети...
>> вероятно, у Вас не хватает в конфиге на интерфейсе строчки
>> ip proxy-arp
> не помогло... так же остро стоит проблема с ip sla, почему не
> стартует? :(

мой скайп bad_char

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Cisco 1841 PPTP server - объединение подсетей"  +/
Сообщение от fomim email(ok) on 03-Авг-12, 17:14 
Тема старовата, но может кто нибудь ответит...
А почему на интерфейсе Virtual-Template 1 нет адреса. У меня на пример без адреса на этом интерфейсе впн клиент выдает ошибку 733. А в общем такая же проблема. Если решил то подскажи как.
Добавил
transmit-interface FastEthernet 0/0(Локальный интерфейс)
Ошибка 733 пропала но клиент не проходит проверку пароля, сервер не ответил вовремя

Мой конфиг здесь https://www.opennet.ru/openforum/vsluhforumID6/28.html#0
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру