The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Cisco 2511 и Dial-in"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Cisco 2511 и Dial-in" 
Сообщение от Darsh emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 26-Мрт-05, 23:49  (MSK)
Оборудование Cisco2511, сервер-Radius, моемы Zyxel 336. Проблема когда пользвоатели логинятся и входят в сеть, данные пользователем отправляются, а ответа от сервера не приходит. со стороны клиента пингуется циска, но интерент не виден. Причем раз на раз не приходится, т.е. с 3-10 раза пользователям удается выйти в интерент, но никакой закономерности не увидел. Думаю проблема с конфигурацией Cisco т.к. иногда она определят скорость модемов как 300 и тогда вообще законектится невозможно. пытался жестко задать скорость, но она все время меняется (sh run).    

version 11.2
no service finger
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
aaa new-model
aaa authentication login no_radius enable
aaa authentication login none none
aaa authentication ppp default if-needed radius local
aaa authorization network if-authenticated radius
aaa accounting network wait-start radius
!
ip subnet-zero
no ip rcmd domain-lookup
ip rcmd rsh-enable
ip rcmd remote-host user XX.XX.XX.XX root enable
ip rcmd source-interface Ethernet0
ip name-server YY.YY.YYY.YY
!
interface Ethernet0
ip address YY.YYY.YY.YY
no ip redirects
no ip directed-broadcast
no ip proxy-arp
no ip mroute-cache
ip route-cache same-interface
no keepalive
no cdp enable
!
!
interface Group-Async1
ip unnumbered Ethernet0
no ip mroute-cache
encapsulation ppp
async default routing
async dynamic address
async mode interactive
peer default ip address pool MyPool
no fair-queue
no cdp enable
ppp authentication pap
ppp multilink
group-range 1 16
!
ip local pool MyPool YY.YY.YY.131 YY.YY.YY.135
ip default-gateway YY.YY.YY.129
ip classless
ip route 0.0.0.0 0.0.0.0 YY.YY.YY.129
no cdp run
radius-server host YY.YY.YY.91 auth-port 1812 acct-port 1813
radius-server key 44443
!
line con 0
exec-timeout 30 0
login authentication no_tacacs
line 1 16
autoselect during-login
autoselect ppp
modem Dialin
modem autoconfigure discovery
transport input all
stopbits 1
speed 2400 <- этот параметр менятся как захочет, даже если его установить жестко
flowcontrol hardware
line aux 0
...
end

Помогите пожалуйста, в чем причина частовстречающегося отсутствия инета?

  Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "Cisco 2511 и Dial-in" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 27-Мрт-05, 19:04  (MSK)
modem autoconfigure type - правильный выставите
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "Cisco 2511 и Dial-in" 
Сообщение от Darsh emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 27-Мрт-05, 20:03  (MSK)
>modem autoconfigure type - правильный выставите
выставлял modem autoconfigure type default
- помогло,  speed пишется правильный, но всерано в инет не пускает. От клиента tracert дает сначала шлюз Cisco, затем указаный узел не доступен... может дело с маршрутизацией? но ведь есть соединения клиента при которых все работает...причем не зависят от линии, ни от порта, ни от выделяемого IP адреса. Подскажите в чем может быть еще проблема?
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "Cisco 2511 и Dial-in" 
Сообщение от GroundBeat Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 28-Мрт-05, 09:13  (MSK)
Адрес на Ether0, адреса в пуле MyPool и default-gateway сидят в разных сетях?

Кроме всего прочего попробуй сказать
no ip subnet-zero

И выбери что нибудь одно. Работе не мешает, но смотрится не фонтан:
no ip routing
ip default-gateway YY.YY.YY.129

или
ip routing
ip route 0.0.0.0 0.0.0.0 YY.YY.YY.129

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "Cisco 2511 и Dial-in" 
Сообщение от Darsh emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 28-Мрт-05, 14:56  (MSK)
>Адрес на Ether0, адреса в пуле MyPool и default-gateway сидят в разных
>сетях?
Адреса из одной сети. Если прописать адрес из MyPool и используя default-gateway на локальной машине, то интернет виден. Остальные рекомендации выполнил - не помогло, также пользователи только с 2-4 раза попадают в интернет.
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "Cisco 2511 и Dial-in" 
Сообщение от GroundBeat Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 01-Апр-05, 09:28  (MSK)
>Адреса из одной сети.
Плохо.
>Если прописать адрес из MyPool и используя default-gateway
>на локальной машине, то интернет виден.
Это тоже понятно.
>Остальные рекомендации выполнил - не
>помогло, также пользователи только с 2-4 раза попадают в интернет.
Странно что вообще выходят. Смотри. При установлении соединения имеем картину маслом:

ext.net---(eth0---GA0[eth0])---MyPool[0..n]
И eth0 и GA0 имеют адреса из одной сети. Куда циска должна отправлять трафик для этой сети? Попробуй уведи MyPool в другую сеть.


  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "Cisco 2511 и Dial-in" 
Сообщение от Darsh emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 01-Апр-05, 11:03  (MSK)
>ext.net---(eth0---GA0[eth0])---MyPool[0..n]
>И eth0 и GA0 имеют адреса из одной сети. Куда циска должна
>отправлять трафик для этой сети? Попробуй уведи MyPool в другую сеть.

попробовал. разбил на 2 подсети 1.2.3.0/25 и 1.2.3.128/27 теперь имеем
Eth0
YY.YY.YY.120 255.255.255.128 secondary
YY.YY.YY.130 255.255.255.224
...

ip local pool MyPool YY.YY.YY.131 YY.YY.YY.135
ip route 0.0.0.0 0.0.0.0 1.1.3.129

всеравно результат такой же или я чего не понял в предыдущем посте? если так пожалуйста поправьте.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "Cisco 2511 и Dial-in" 
Сообщение от YuryD Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 01-Апр-05, 16:58  (MSK)
>YY.YY.YY.120 255.255.255.128 secondary
>YY.YY.YY.130 255.255.255.224


Зачем ?

Допустим eth0 yy.yy.yy.120  ,без всяких secondary

Mypool YY.YY.YY.131 YY.YY.YY.135 (кривоват пул, по маске кривой, лучше
при такой маске yy.yy.yy.129 yy.yy.yy.158 )

interface Group-Async1
ip unnumbered Ethernet0

ip classless
ip route 0.0.0.0 0.0.0.0 куда_по_умолчанию
ip route yy.yy.yy.128 255.255.255.224 Ethernet0 - это чтоб tracert не дергался

ну и выдавай DNS им тоже
async-bootp dns-server xx.xx.xx.xx yy.yy.yy.yy


  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "Cisco 2511 и Dial-in" 
Сообщение от aljil Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 04-Апр-05, 15:18  (MSK)
Пять копеек про "плавание" скорости на порту киски. ИМХО у тебя не на всех 16 линиях модемы есть физицки. Кошка в таком случае ведет себя именно так (ну по крайней мере у меня). Рекомендую отдельно описать группой линии с мопедами, а отдельно без оных, иначе ИМХО колбасня со скоростью останется, в результате и будешь получать кривые коннекты.
Что касается выделения адресов для диал-ин в отдельную подсеть - ИМХО фигня все это, кошка прекрасно роутит коннекты по ппп+ип, имеющие адреса из подсети своего эзернетового линка. Руты на такие коннекты создаются и удаляются из таблицы роутинга кошки динамически на время диалапного коннекта. И на АРП-запросы со стороны эзернета кошка тоже чудненько отвечает для своих диал-инов (у меня давно и успешно пашет 2511 в качестве диал-ин сервера, адреса выдаются из пула в пределах подсети со стороны эзера, адресом всех линков со стороны киски есть адрес кискиного же эзернета. И ходит народ куда надо и когда надо без проблем - так что ИМХО проблема НЕ в роутинге).
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх


Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру