The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Потери пакетов в туннеле nhrp"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Потери пакетов в туннеле nhrp"  +/
Сообщение от cr1m2email (ok), 23-Июл-18, 13:27 
Здравсвтвуйте, настроено несколько офисов в nhrp, недавно заметили, что один удаленный офис, который выходит в интернет через vdsl начинает терять пакеты в туннеле. Причем белый адрес роутера этого офиса пингуется без потерь, а вот серый, который в туннеле, может испытывать до 40% потерь, возникает это в середине рабочего дня, потом внезапно прекращается, в логах ошибок нет. Настройка интерфейса этого роутера:

interface GigabitEthernet0/0
description WAN via ext VDSL modem
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable

interface Dialer0
mtu 1492
ip address negotiated
ip access-group incoming in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly in max-fragments 64 max-reassemblies 1024
ip virtual-reassembly out max-fragments 64 max-reassemblies 1024
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp pap sent-username XXXXXX password 7 YYYYYYY
ppp ipcp dns request
ppp ipcp route default
no cdp enable

НАстройка туннеля на этом интерфейсе:
interface Tunnel1
ip address 192.168.35.5 255.255.255.240
no ip redirects
ip mtu 1400
ip nhrp authentication 123
ip nhrp map multicast X.X.88.114
ip nhrp map 192.168.35.1 X.X.88.114
ip nhrp network-id 123
ip nhrp holdtime 60
ip nhrp nhs 192.168.35.1
ip nhrp registration timeout 60
ip tcp adjust-mss 1360
ip ospf network broadcast
ip ospf hello-interval 30
ip ospf priority 0
ip ospf mtu-ignore
cdp enable
tunnel source Dialer0
tunnel mode gre multipoint
tunnel key 123
tunnel bandwidth transmit 16000
tunnel bandwidth receive 16000

Последнее, что добавлял в интерфейсе туннеля, это
ip mtu 1400
ip tcp adjust-mss 1360

В момент потерь процессор роутера загружен всего на 3-6%.  И канал интернет не нагружен и в половину в этот момент. МОжно ли еще как-то попытаться продиагностировать порблему, может что посоветуете?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по ответам | RSS]

1. "Потери пакетов в туннеле nhrp"  +/
Сообщение от cr1m2email (ok), 23-Июл-18, 13:53 
Статистика в туннельном интерфейсе

Tunnel1 is up, line protocol is up
  Hardware is Tunnel
  Internet address is 192.168.35.5/28
  MTU 17912 bytes, BW 100 Kbit/sec, DLY 50000 usec,
     reliability 255/255, txload 51/255, rxload 94/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel linestate evaluation up
  Tunnel source X.X.171.30 (Dialer0)
   Tunnel Subblocks:
      src-track:
         Tunnel1 source tracking subblock associated with Dialer0
          Set of tunnels with source Dialer0, 2 members (includes iterators), on interface <OK>
  Tunnel protocol/transport multi-GRE/IP
    Key 0x3122CAB, sequencing disabled
    Checksumming of packets disabled
  Tunnel TTL 255, Fast tunneling enabled
  Tunnel transport MTU 1472 bytes
  Tunnel transmit bandwidth 16000 (kbps)
  Tunnel receive bandwidth 16000 (kbps)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 1y2w
  Input queue: 0/75/271095/0 (size/max/drops/flushes); Total output drops: 225004
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 36000 bits/sec, 13 packets/sec
  5 minute output rate 21000 bits/sec, 13 packets/sec
     1432678070 packets input, 3587649481 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1327156386 packets output, 3526856391 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out


Ошибок т.е. нет

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Потери пакетов в туннеле nhrp"  +/
Сообщение от cr1m2email (ok), 23-Июл-18, 14:04 
Может попробовать virtual-reassembly на Dialer0 отключить?
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору


Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру