The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"
Вариант для распечатки  
Пред. тема | След. тема 
Форум WEB технологии (Apache, http-серверы)
Изначальное сообщение [ Отслеживать ]

"Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +1 +/
Сообщение от a_chuprin email(ok) on 11-Дек-06, 13:18 
Hello All!
Есть такая трабла: apache собран с опцией --enable-so, а пхп --with-apsx2=путь к apsx. Компиляция и установка php  приходит нормльно, но libphp5.so в каталоге modules не создается, как в прочем ни где не создается ни какого намека на libphp. Подскажите плз, где могут быть грабли.
Спасибо.
Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от xeon email(??) on 11-Дек-06, 21:48 
>Hello All!
>Есть такая трабла: apache собран с опцией --enable-so, а пхп --with-apsx2=путь к
>apsx. Компиляция и установка php  приходит нормльно, но libphp5.so в
>каталоге modules не создается, как в прочем ни где не создается
>ни какого намека на libphp. Подскажите плз, где могут быть грабли.
>
>Спасибо.
Покажи опции configure для php

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от a_chuprin email(ok) on 12-Дек-06, 09:53 
./configure --with-pgsql=/usr/local/pgsql --with-apsx2=/usr/local/apache/bin/apsx


Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от xeon email(??) on 12-Дек-06, 11:01 
>./configure --with-pgsql=/usr/local/pgsql --with-apsx2=/usr/local/apache/bin/apsx

./configure ...
make
find / * > all_files_before
make install
find / * > all_files_after
diff all_files_before all_files_after

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от a_chuprin email(ok) on 12-Дек-06, 14:28 
>>./configure --with-pgsql=/usr/local/pgsql --with-apsx2=/usr/local/apache/bin/apsx
>
>./configure ...
>make
>find / * > all_files_before
>make install
>find / * > all_files_after
>diff all_files_before all_files_after


разницы никакой. Файлы одинаковые

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

4. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от Krist email on 12-Дек-06, 13:32 
>Hello All!
>Есть такая трабла: apache собран с опцией --enable-so, а пхп --with-apsx2=путь к
>apsx. Компиляция и установка php  приходит нормльно, но libphp5.so в
>каталоге modules не создается, как в прочем ни где не создается
>ни какого намека на libphp. Подскажите плз, где могут быть грабли.
>
>Спасибо.

А под чем собираешь ?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от a_chuprin email(ok) on 12-Дек-06, 14:13 
>>Hello All!
>>Есть такая трабла: apache собран с опцией --enable-so, а пхп --with-apsx2=путь к
>>apsx. Компиляция и установка php  приходит нормльно, но libphp5.so в
>>каталоге modules не создается, как в прочем ни где не создается
>>ни какого намека на libphp. Подскажите плз, где могут быть грабли.
>>
>>Спасибо.
>
>А под чем собираешь ?


Год назад это было Debian 3.11 sarge, но за неимением нормального инета приходится обновлятся с сорцов. gcc 3.3.5

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от Krist email on 12-Дек-06, 14:52 
>>>Hello All!
>>>Есть такая трабла: apache собран с опцией --enable-so, а пхп --with-apsx2=путь к
>>>apsx. Компиляция и установка php  приходит нормльно, но libphp5.so в
>>>каталоге modules не создается, как в прочем ни где не создается
>>>ни какого намека на libphp. Подскажите плз, где могут быть грабли.
>>>
>>>Спасибо.
>>
>>А под чем собираешь ?
>
>
>Год назад это было Debian 3.11 sarge, но за неимением нормального инета
>приходится обновлятся с сорцов. gcc 3.3.5

На днях пробовал компилять под fc6 - то же самое, правда не разбирался еще.
Попробуй apache 1.3x, возможно в нем дело.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от a_chuprin email(ok) on 12-Дек-06, 18:31 
>>>>Hello All!
>>>>Есть такая трабла: apache собран с опцией --enable-so, а пхп --with-apsx2=путь к
>>>>apsx. Компиляция и установка php  приходит нормльно, но libphp5.so в
>>>>каталоге modules не создается, как в прочем ни где не создается
>>>>ни какого намека на libphp. Подскажите плз, где могут быть грабли.
>>>>
>>>>Спасибо.
>>>
>>>А под чем собираешь ?
>>
>>
>>Год назад это было Debian 3.11 sarge, но за неимением нормального инета
>>приходится обновлятся с сорцов. gcc 3.3.5
>
>На днях пробовал компилять под fc6 - то же самое, правда не
>разбирался еще.
>Попробуй apache 1.3x, возможно в нем дело.
На 1.3.37 поднялось все с полпинка и без граблей. Всем спасибо.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от xeon email(??) on 18-Дек-06, 19:47 
Таже хрень
Apache 2.2.3  и php-4.4.4
so-модуля не видно
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

10. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от Саша Купер email on 05-Мрт-07, 16:23 
>Hello All!
>Есть такая трабла: apache собран с опцией --enable-so, а пхп --with-apsx2=путь к
>apsx. Компиляция и установка php  приходит нормльно, но libphp5.so в
>каталоге modules не создается, как в прочем ни где не создается
>ни какого намека на libphp. Подскажите плз, где могут быть грабли.
>
>Спасибо.

У меня была такая же проблема, и я с ней бился пару дней.
Не появляется, хоть ты тресни, libphp5.so на amd64 c apache2 и php5.
Все появилось (хвала яйцам) только после того, как я опустил апаче (не уверен, что это надо было, но говорю как было),снес php source предыдущей версии - просто перенес весь каталог куда то в ..., скачал wget последний релиз php и ./configure make make install как обычно...
с ТЕМИ ЖЕ опциями, с которыми 2 дня нифига не получалось все скомпилировалось и libphp5.so появилась в .libs после чего я ее скопировал туда где апачи modули лежат, добавил loadmodule в httpd.conf и стартанул апачи..

Надеюсь, кому то это поможет и он не проведет все выходные компилируя .... :)
http://www.half-lime.com

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

11. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от Zaqwr on 12-Мрт-07, 09:53 
>Все появилось (хвала яйцам) только после того, как я опустил апаче (не
>уверен, что это надо было, но говорю как было),снес php source
>предыдущей версии - просто перенес весь каталог куда то в ...,
>скачал wget последний релиз php и ./configure make make install как
>обычно...
>с ТЕМИ ЖЕ опциями, с которыми 2 дня нифига не получалось все
>скомпилировалось и libphp5.so появилась в .libs после чего я ее скопировал
>туда где апачи modули лежат, добавил loadmodule в httpd.conf и стартанул
>апачи..


частенько когда что-то идёт нетак, снос сорцов и замена на такиеже из решает проблемму.
тоже было при сборке apache с mod_ssl mod_perl mod_php ,

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от TaunT email on 28-Ноя-07, 13:37 
#$$## !!!
столкнулся с такой же проблемой, убил полдня!!!
спасло то, что поставил пхп 5.2.2, он то и указал мне на ошибку, которую НЕ УВИДЕЛ НИКТО из отвечавших в этом посте

--with-apxs2=/path/to/apxs это вам не --with-apsx2=/path/to/apsx :)))

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от TaunT email on 28-Ноя-07, 13:55 
видимо мы с автором поста с одного faq ставили пхп :)
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

14. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от Макс (??) on 10-Июл-08, 11:58 
>видимо мы с автором поста с одного faq ставили пхп :)

у меня было круче - apcx :-)


Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от Alder on 21-Май-09, 10:44 
>Hello All!
>Есть такая трабла: apache собран с опцией --enable-so, а пхп --with-apsx2=путь к
>apsx. Компиляция и установка php  приходит нормльно, но libphp5.so в
>каталоге modules не создается, как в прочем ни где не создается
>ни какого намека на libphp. Подскажите плз, где могут быть грабли.
>
>Спасибо.

Всё это решается корректным указанием пути к сырцам Апача.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

16. "Apache 2.2.3 & PHP 5.2.0 Не создается libphp5.so"  +/
Сообщение от Василий email(??) on 20-Авг-13, 14:50 
Спасительная фраза "apache собран с опцией --enable-so" наконец-то помогла мне собрать апач так чтобы был apxs. До этого перерыл вес инет. Спасибо.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру