The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"php5 + fastcgi? Centos5"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы WEB технологии (Public)
Изначальное сообщение [ Отслеживать ]

"php5 + fastcgi? Centos5"  
Сообщение от snooper email on 03-Июн-08, 11:48 
Есть Centos5.1, на нем apache2.0 + php 5.1.6. Пхп подключается к апачу как модуль,
#php -v PHP 5.1.6 (cli), phpinfo выводит: "Server API Apache 2.0 Handler", в phpinfo упоминаний о fastcgi нигде нет, по всей видимости он не включен.

Решил включить fastcgi, полазил по гуглу - нашел статью как собрать php src rpm,
там написано, что нужно в php.spec добавить "--enable-fastcgi \", все сделал как написано - пересобрал, переустановил. Запускаю #php -v PHP 5.1.6 (cli), а ведь должно быть PHP 5.1.6 (cgi-fcgi) sad

Помогите плиз, как на Centos5 настроить эту связку? Может есть какие-то статейки? Возможно кто-то из вас уже настраивал это?

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "php5 + fastcgi? Centos5"  
Сообщение от kpn on 05-Июн-08, 00:43 
>#php -v PHP 5.1.6 (cli), phpinfo выводит: "Server API Apache 2.0 Handler",
>в phpinfo упоминаний о fastcgi нигде нет, по всей видимости он
>не включен.

#yum install lighttpd-fastcgi

#/usr/bin/php-cgi -v
;-)

и не забудь указать в lighttpd.conf
fastcgi.server             = ( ".php" =>
.....
  "bin-path" => "/usr/bin/php-cgi"
.....
)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру