The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз проприетарного видеодрайвера AMD Catalyst 10.10

22.10.2010 21:10

Компания AMD выпустила новую версию проприетарного видеодрайвера для видеокарт ATI - AMD Catalyst 10.10 (загрузить, 100 Мб). Основные изменения:

  • Добавлена поддержка Linux-ядра 2.6.35;
  • Добавлена поддержка X-сервера 1.9;
  • Обеспечена поддержка дистрибутивов openSUSE 11.3 и Ubuntu 10.10;
  • Исправлена ошибка сборки драйвера после установки патча, исправляющего уязвимость (CVE-2010-3081) в 64-разрядных Linux-ядрах, которая позволяла непривилегированному локальному пользователю получить root-доступ к системе.
  • При вращении экрана через XRandR более не возникают паразитные задержки;
  • Из известных, но неисправленных проблем можно отметить:
    • Завершение работы X-сервера после возвращения из спящего режима может привести к зависанию системы;
    • Система может не отобразить сообщение об ошибке при указании некорректной позиции, используемой в "aticonfig --tv-geometry", в результате чего в xorg.conf будут записаны нерабочие значения настроек "TVHPosAdj" и "TVVPosAdj";
    • Курсор мыши может испытывать проблемы попадания в область панели задач после осуществления специфичных вращений экрана;
    • В Ubuntu 10.10 начальная попытка вращения экрана может привести к некорректной инициализации X-сервера;
    • Запуск игр "Quake 4" и "Enemy Territory: Quake Wars" в режиме начиная с 1280x1024 может привести к краху.


  1. Главная ссылка к новости (http://www2.ati.com/drivers/li...)
  2. OpenNews: Релиз проприетарного видеодрайвера ATI Catalyst 10.9
  3. OpenNews: Пререлиз проприетарного видеодрайвера ATI Catalyst 10.10
  4. OpenNews: Вышел видеодрайвер ATI Catalyst 10.8 с поддержкой OpenGL ES 2.0
  5. OpenNews: Релиз проприетарного видеодрайвера AMD Catalyst 10.7
Лицензия: CC-BY
Тип: Интересно / Программы
Короткая ссылка: https://opennet.ru/28386-Catalyst
Ключевые слова: Catalyst, amd, ati, driver
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (23) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, emg81 (?), 22:39, 22/10/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > Добавлена поддержка Linux-ядра 2.6.35

    ммм, владельцы карт АМД не подскажут мне - нормально ли это? в смысле, оперативно по меркам АМД?

     
     
  • 2.3, Аноним (-), 22:49, 22/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Да вроде у меня на 2.6.35 ещё 10.9 работала, а так никогда из за ядра проблем с fglrx не замечал.
     
     
  • 3.7, Drist (ok), 00:27, 23/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Ядро 2.6.36 вполне себе замечательно работает с catalyst 10.9. xorg-server 1.8.х.
     
     
  • 4.15, Аноним (-), 12:07, 23/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Ядро работает замечательно, а вот каталист безумно лагает и отказывается пересобираться.
     
  • 2.4, ононим (?), 22:50, 22/10/2010 [^] [^^] [^^^] [ответить]  
  • –2 +/
    вполне нормально, особенно с учетом того, что АМД подстраивается под выпуски убунту и дает им свежие пререлизные дрова для включения в дистрибутив.
     

  • 1.2, KroArtem (ok), 22:40, 22/10/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >>Запуск игр "Quake 4" и "Enemy Territory: Quake Wars" в режиме начиная с 1280x1024 может привести к краху.

    Похоже, этот баг и не собираются фиксить.
    Первый релиз за несколько месяцев, когда кол-во исправлений наконец-то сравнялось с количеством неисправленных проблем. Прогресс налицо.

     
     
  • 2.16, GameFoeLinux (?), 12:47, 23/10/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Это ж mega Lol. Как они такой кривой драйвер выпускают и ошибку еще не исправили!
     
     
  • 3.21, User294 (ok), 20:38, 23/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Думаете, в остальных драйверах ошибок меньше? Да вы никак оптимист?! :)
    Hint: "если вам кажется что дела идут хорошо, значит вы просто чего-то не заметили".
     

  • 1.5, ононим (?), 22:51, 22/10/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    кто потестил, скажите, не отвалился ли XvBA в этом выпуске. ранее такое бывало.
     
  • 1.6, Толстый_ (?), 23:37, 22/10/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А как у них с поддержкой OpenGL? На игры в принципе пофигу, для них можно(и нужно) держать винду в дуал-буте. А для кодинга под линуксом OpenGL нужен.
     
     
  • 2.8, Аноним123321 (ok), 01:25, 23/10/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    ды даже если бы все игры шли бы безприкословно на GNU/linux -- то сёравно нужно было бы держать в дуалбуте два GNU/Linux :-)

    ...так как действительно ведь -- это как-то нехорошо когда одна и таже операционная система используется и для игр и для других манипуляций

    (если заигнорить факт безопасности (в случае когда в одной операционной системе и игрушки и всё остальное) -- то даже банально остаётся непонятно -- как тюнинговать операционную систему -- под скокрость или под финтифлюшковость :))

     
     
  • 3.22, Аноним (-), 10:14, 30/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Какая то виндовость в логике прослеживается. Не вижу никакого преступления, если на единственной системе будут игры среди установленных приложений.
     
  • 2.9, User294 (ok), 01:49, 23/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > (и нужно)

    Кому нужно, а кому и не очень. Под линух в принципе есть уже достаточно игрушек чтобы приятно провести время. А сильно много времени на гамезы тратить как-то досадно. А еще и платить за винду которую почти не будешь юзать т.к. в линуксе продвинутости удобнее - досадно вдвойне.

     
     
  • 3.10, Толстый_ (?), 02:51, 23/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Мне винда еще нужна, чтобы тестировать код на ней. Ну и 1-2 программулины есть, которые под wine плохо работают.
    Насчет лицензии, мне она вместе с ноутбуком досталась. Но учитывая, что я не особый фанат MS, я и пиратки не погнушаюсь. Уж точно платить мелкомягким за ОС лично я никогда не буду, не заслужили.
     
     
  • 4.13, filosofem (ok), 11:42, 23/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Откройте для себя виртуализацию, пожалуйста.
     

  • 1.11, Аноним (-), 04:28, 23/10/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    о_О, у меня и прошлый релиз на .35 работал
     
  • 1.12, Zenitur (?), 06:24, 23/10/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    М-да. 100 мегабайтов вместо 80-ти. Crossfire появился ли? А что тогда появилось, попимо багфиксов?
    Многие используют версию драйвера 9.3 для своей Radeon < 3xxx. Специально для этого в систему устанавливаются не последние иксы. Теперь этих людей можно спокойно взломать, получается?! Самое время выпустить 9.3.1, так как для виндовса они выпускали, когда вышел Windows 7.
     
     
  • 2.14, filosofem (ok), 11:59, 23/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Программа установки поменялась по всей видимости. Потому что после --buildpkg размеры пакетов все те же.
     
     
  • 3.18, Zenitur (?), 13:21, 23/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Мне кажется, что в run-файле несколько модулей ядра. Каждый из них собран с разными ядрами, один с 2.4, другой с 2.6, другой чуть новее. Плюс по 64-битному дубликату всего этого! Потом этому всему даётся обёртка "ты собран в ядре 2.6.36 и только никому не говори что ты собран в 2.6.14.10 а то замочат". При сборке пакета для определённого дистрибутива выбирается болько один модуль ядра (драйвер). Поэтому размер всё тот же.
    Если мои размышления правильные, то новые 20 мегабайтов это новый модуль ядра. Собранный в 2.6.32, чтобы заработал kms.
     
  • 2.23, Аноним (-), 11:06, 30/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > М-да. 100 мегабайтов вместо 80-ти.

    Рассказали бы мне такое в году в 96-м, я бы умер от смеха.

     

  • 1.17, Аноним (-), 13:20, 23/10/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Странно у меня и предыдущая версия под suse 11.3 работала... Вот только на некоторых машинах была проблема со сборкой похоже из-за исправленной ошибки установшика...
     
     
  • 2.19, Zenitur (?), 13:26, 23/10/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Странно у меня и предыдущая версия под suse 11.3 работала... Вот только
    > на некоторых машинах была проблема со сборкой похоже из-за исправленной ошибки
    > установшика...

    Насколько я помню поддержку 11.3 уже добавляли, от 11.2 она отличалась одной дополнительной строчкой для программы упаковки пакета. Вот именно эта строчка и содержала ошибку! А если просто запускать run-файл без сборки rpm-пакета, то всё заработает и так!
    P.S. Есть у меня 10.2. Его поддержка закончилась и я собирая пакет выбрал версию 10.3. Собралось. Только шрифт в консоли Konsole поменялся! Название то же, выглядит по-другому. После удаления пакета всё осталось изменённым. Кто-нибудь знает, в чём может быть проблема?

     

  • 1.20, Аноним (-), 14:59, 23/10/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    На ноуте с гибридной графикой m51ta впервые завёлся(чипсетный), не прошло и 3х лет
     
     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру