The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз проприетарных видеодрайверов AMD Catalyst 11.1

28.01.2011 14:11

Компания AMD выпустила новую версию проприетарного видеодрайвера для видеокарт ATI - AMD Catalyst 11.1 (120 Мб). Несмотря на официальную поддержку OpenGL 4.1 в аналогичной версии драйвера для Windows (в Linux поддержка OpenGL 4.1 пока носит неофициальный характер), в Linux-версии из улучшений отмечено только добавление официальной поддержки дистрибутивов RHEL 6/5.6 и поддержка 68хх, 69хх серий видеокарт ATI Radeon HD. Кроме того, в Catalyst Control Center добавлена настройка для снижения помех изображений (борьба с tearing) в видео, трехмерной графики и оконных приложениях.

  1. Главная ссылка к новости (http://blogs.amd.com/play/2011...)
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/29413-ati
Ключевые слова: ati, amd, catalyst, video, driver
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (14) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.3, non anon (?), 15:20, 28/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Несмотря на поддержку OpenGL 4.1 в аналогичной версии драйвера для Windows, в Linux-версии из улучшений отмечено только

    Атишники в очередной раз продемонстрировали своё отношение к пользователям linux.

     
     
  • 2.5, Аноним (-), 15:59, 28/01/2011 [^] [^^] [^^^] [ответить]  
  • –2 +/
    >> OpenGL 4.1

    в линуксе и второй нигде почти не используется - зачем тратить силы на то, что не нужно, лучше пусть стабильность пилят. игры всё равно все под ДХ10/11 счас делают и портировать никто не будет. под тот же мак 10ть штук игр.

     
     
  • 3.6, ещ один анонимус (?), 16:19, 28/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >в линуксе и второй нигде почти не используется - зачем тратить силы на то, что не нужно, лучше пусть стабильность пилят.

    В новом файрфоксе не заблеклистили поддержку 3D-ускорения только для драйверов nvidia.

     
     
  • 4.7, Толстый (ok), 16:26, 28/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Кто-то здесь откомментировал в том треде, что на проприетарном драйвере АМД проходит около 5000 тестов тоже. Не все так однозначно. Надо будет проверить.
     
  • 4.9, Аноним (-), 21:00, 28/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Не 3д-ускорения, а вебгл. В вебгл используется openGL ES, а это урезанное opengl 2.0...
     
  • 3.12, Zenitur (?), 06:11, 29/01/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > игры всё равно все под ДХ10/11 счас делают

    Угадай через что их запускает Wine.

    Честно говоря удивительно это. ATi-шные видеокарты сали поддерживать DX11-OGL4 на полгода раньше nVidia. В Linux-драйвере OGL4 появился сразу. Ну так почему же так долго ждём 4.1, который ещё летом появился?

     
  • 2.8, gkv311 (ok), 19:28, 28/01/2011 [^] [^^] [^^^] [ответить]  
  • +3 +/
    (Catalyst 10.12)
    $ fglrxinfo
    display: :0.0  screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: AMD Radeon HD 6800 Series
    OpenGL version string: 4.1.10362 Compatibility Profile Context

    Может чем писать нелепые посты сначала полностью проанализировать информацию?
    Поддержка OpenGL 4.1 была заявлена ещё несколько каталистов назад, однако один из специалистов написал серию тестов на работоспосбность OpenGL (в том числе и по версии 4.1). И тесты эти показали, что драйвера NVIDIA и AMD/ATi проходят не все сценарии, а значит спецификации версии 4.1 были реализованы разработчиками не полностью (и о их поддержке быол заявлено преждевременно скорее в маркетинговых целях).

    Собственно говоря в особенностях релиза 11.1 заявлена _полная_ поддержка OpenGL 4.1 (то есть можно предположить, что были исправлены указанные ранее ошибки). Если вспомнить, что разработчики Catalyst заявляли о переходе по большей части к использованию общего кода для OpenGL реализации в драйверах для Windows и Linux, то можно смело предположить, что изменения каснулись и Linux драйвера.

    О противоположном можно утверждать только проверив эту самую поддержку OpenGL 4.1 самому, что как справедливо заметили некоторые другие коментаторы, проблематично в виду отсутствия приложений (как Linux так и Windows) активно использующих все возможности свежей версии OpenGL 4.1 :|

     
     
  • 3.13, Zenitur (?), 06:22, 29/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Спасибо что всё объяснил, новость придётся исправить. А ещё новый драйвер стал быстрее! Один мой знакомый потестировал его - Unigine Heaven выдал немного больше FPS. Тестировал также и в Windows - 10.12 в Windows обгоняет тот что в Linux, но отстаёт от 11.1 в Linux.

    Главное нововведение - опция, включающая борьбу с тирингом.

     
     
  • 4.15, gkv311 (ok), 09:32, 29/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Главное нововведение - опция, включающая борьбу с тирингом.

    Да, я тоже заметил появление новой вкладки:
    http://imglink.ru/pictures/29-01-11/497c325572febb648bc1ab195b3d8774.jpg

    Только я не понял какие другие действия выполняет драйвер, помимо включения вертикальной синхронизации...

     

  • 1.4, Толстый (ok), 15:21, 28/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Ну чтож наконец-то поддержка HD 69xx, скачаю и сравню производительность в 3D с виндой.
     
  • 1.10, gkv311 (ok), 22:30, 28/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >>Linux-версии из улучшений отмечено ... поддержка 68хх, 69хх серий видеокарт ATI Radeon HD.

    Что-то я не заметил разницы, по-прежнему overlay 'Unsupported Hardware' после установки (RadeOn HD 6850). Ну разве что появилась экспериментальная поддержка серии 6900?

    Кто-нибудь вообще видел где можно скачать релиз ноты для Linux??? Где-то с версии 10.10 они пропали со страницы загрузки. С выходом 11.1 ссылка снова появилась, но вместо release-notes внезапно оказалась инструкция по установке/удалению каталиста :|.

     
     
  • 2.11, Stax (ok), 03:21, 29/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Какой оверлей нужен, opengl overlay? Включается опцей в xorg.conf. Аппаратной поддержки видео-оверлея YUV на этих картах нет, но реализация xv может выполняться через 3D-акселератор (как наложение текстуры). Оно уже несколько поколений карт так.
     
     
  • 3.14, gkv311 (ok), 09:24, 29/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Какой оверлей нужен, opengl overlay? Включается опцей в xorg.conf. Аппаратной поддержки
    > видео-оверлея YUV на этих картах нет, но реализация xv может выполняться
    > через 3D-акселератор (как наложение текстуры). Оно уже несколько поколений карт так.

    Я неправильно выразился, эта штука обычно называет watermark - полупрозрачная плямба на каждом мониторе, которая говорит о том, что драйвер отказывается принимать родное для него железо, хотя и работает с ним.

    Overlay для видео мне нафиг не нужен, предпочитаю полноценный OpenGL рендеринг.

     

  • 1.16, konkor (?), 10:00, 01/02/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Подскажите где удалить конфиги от предыдущей версии каталиста... удаление /etc/ati не помогает. В amdcccle пишет что версия каталиста осталась прошлая, изменяется только версия OpenGL Driver-a...
    PS: Неужели нужно переустановить всю систему для этого O_o
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру