The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Настройка NetFlow на cisco совместно с NAT

01.08.2004 22:09

Рассмотрена актуальная проблема настройки маршрутизатора Cisco 3620 для экспорта NetFlow-статистики по трафику в случае использования NAT.

Данная тема не раз обсуждалась в форуме, но подробного описания по настройке не было. Надеемся, что данная статья поможет многим администраторам. В случае если будут найдены ошибки, неточности просьба присылать комментарии.

  1. Главная ссылка к новости (http://www.netup.ru/?pid=35...)
Автор новости: NetUP
Тип: яз. русский / Практикум
Короткая ссылка: https://opennet.ru/4191-cisco
Ключевые слова: cisco, traffic, netflow, nat
Поддержать дальнейшую публикацию новостей на OpenNET.


Обсуждение (18) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (1), 12:32, 02/08/2004 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Только проблема в том, что трафик на loopback всегда попадает в process routed, что очень сильно грузит процессор роутера.
     
  • 1.2, Аноним (2), 01:19, 05/08/2004 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Это "описание" стырено отсюда: http://www.netams.com/doc/documentation-ru.html#6.5 (где лежит уже который год). И хочу заметить что для того чтобы nat+netflow заработал на циске где один физический интерфейс+вланы, придется извращаться через _два_ лупбэка и _два_ роутмапа :(
     
     
  • 2.3, _roman_ (?), 07:06, 05/08/2004 [^] [^^] [^^^] [ответить]  
  • +/
    можете показать рабочий конфиг с такими настройками?
     
  • 2.4, Аноним (-), 21:51, 05/08/2004 [^] [^^] [^^^] [ответить]  
  • +/
    > Это "описание" стырено отсюда:  ...
    Гы
    Как раз по описанию "отсюда"  ничего не работало, а вот по описанию из этой статьи все завелось
     

  • 1.5, Аноним (2), 19:51, 09/08/2004 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    укажите отличия?
     
  • 1.6, romale (?), 16:26, 27/10/2004 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    через два лупбека извращаться не надо, по крайней мере в ios 12.3(11).
    interface FastEthernet0/1
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    duplex auto
    speed auto
    !в инет
    interface FastEthernet0/1.1
    encapsulation dot1Q 2 native
    ip address 2.2.2.2 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat outside
    ip virtual-reassembly
    ip policy route-map MAP
    no cdp enable
    no cdp enable
    !в локалку
    interface FastEthernet0/1.2
    encapsulation dot1Q 1
    ip address 10.1.1.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    no cdp enable
    route-map MAP permit 10
    match ip address 108
    set interface Loopback0
    остальное из статьи. важно, чтобы на fa0/1 не было ip route-cache policy; ip route-cache flow
     
     
  • 2.7, Alexey (??), 11:14, 03/12/2004 [^] [^^] [^^^] [ответить]  
  • +/
    Хотелось бы обсудить эту тему на предмет Process switching, как было сказанно в этом трейде при policy routing каждый пакетик обрабатывается через Process switching что очень грузит циску, а мне хотелось бы выяснить такли это? На мой взгляд, тут должна работать технология Netflow switching, по правилам которой только первый пакет должен попасть в Process switching, а остальные пакеты будут коммутироваться через Netflow switching.

    Будет ли это верно в данной ситуации?

    Благодарен за ответ!

     

  • 1.8, Аноним (8), 07:45, 10/03/2005 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Можно както описать как работает программа что из себя предстовляет, вообшем побольше инфы о ней или если есть ссылки то где взять очень надо
    зарание спасибо Ghost.....
     
  • 1.9, nightowl (ok), 18:13, 21/02/2006 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Собственно не по одной из ссылок статья не доступна, а очень бы хотелось её посмотреть, может кто натанкивался на зеркала ?

    Спасибо.

     
     
  • 2.10, olegm (??), 15:51, 22/02/2006 [^] [^^] [^^^] [ответить]  
  • +/
    статья лежит здесь: http://www.netup.ru/articles_pdf/10.pdf
     
     
  • 3.11, nightowl (ok), 15:55, 22/02/2006 [^] [^^] [^^^] [ответить]  
  • +/
    >статья лежит здесь: http://www.netup.ru/articles_pdf/10.pdf


    спасибо

     

  • 1.12, SergR (?), 19:43, 03/03/2006 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Все это уже устарело! Начиная с 12.3Т можно дать команду ip flow egress на выходном интерфейсе и все в шоколаде
     
     
  • 2.13, nightowl (ok), 10:05, 06/03/2006 [^] [^^] [^^^] [ответить]  
  • +/
    >Все это уже устарело! Начиная с 12.3Т можно дать команду ip flow
    >egress на выходном интерфейсе и все в шоколаде


    12.3(8r)T8 - Должно работать ? Вы имеете ввиду, что тогда можно не через looback ?

     

  • 1.14, SergR (?), 14:57, 07/03/2006 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Да, лупбак не нужен.
    Однако небольшая поправка - начиная с 12.3(11)T

    Feature History for the NetFlow Egress Support Feature

    Release  Modification  
    12.3(11)T
    This feature was introduced.

     
  • 1.15, NightOwl (??), 17:18, 06/04/2006 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А будет ли оно работать на Vlane ? т.е. на Fas 0/0.XXXX
     
  • 1.16, NightOwl (??), 17:20, 06/04/2006 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Т.Е. Чтоб натилось на Vlanовском интерфейсе ?
     
  • 1.17, olegm (??), 14:08, 21/04/2006 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Да, работает и на интерфейсах Vlan
     
     
  • 2.18, NightOwl (??), 14:18, 21/04/2006 [^] [^^] [^^^] [ответить]  
  • +/
    >Да, работает и на интерфейсах Vlan


    Что-то особое надо писать ? Потому как у меня не работает :-(
    IOS 124-5

     
     Добавить комментарий
    Имя:
    E-Mail:
    Текст:
    При перепечатке указание ссылки на opennet.ru обязательно



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2021 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру