The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Выпуск пакетного менеджера Apt 1.1

27.11.2015 10:20

Сформирован релиз инструментария для управления пакетами Apt 1.1 (Advanced Package Tool), развиваемого проектом Debian. Кроме Debian и производных от него дистрибутивов Apt также применяется в некоторых дистрибутивах на основе пакетного менеджера rpm, таких как OpenMandriva и ALT Linux. Новый выпуск уже интегрирован в ветку Debian Unstable и из-за изменения ABI привёл к необходимости пересборки пакетов, связанных с libapt.

Из изменений можно отметить:

  • Возможность установки индивидуальных пакетов ("apt-get install foo_1.0_all.deb") и указания полного пути к пакету ("apt-get install /foo/bar.deb");
  • Поддержка команды "apt-get build-dep foo.dsc";
  • Увеличена точность вывода информации о прогрессе выполнения операции "apt-get update" за счёт предварительной загрузки данных о размере;
  • Реализован упрощённый метод загрузки по хэшам (by-hash) при выполнении "apt update", позволивший увеличить надёжность применения обновлений (в репозиториях, поддерживающих by-hash, файл Packages вначале проверяется в /by-hash/$hash_type/$hash_value);
  • Поддержка удаления по хэшу ('apt-key del fingerprint');
  • Возможность использования gnupg2 вместо gnupg;
  • Добавлена опция "--sha512";
  • Реализована верификация .diff/Index на начальной стадии загрузки;
  • В sources.list реализована директива Signed-By;
  • Реализован транзакционный метод обновления (acq-trans) при выполнении "apt-get update", при котором строка из sources.list вначале помещается в partial/ и только после проверки всех данных разом перемещается в lists/;
  • Введена система проверки размера загружаемых служебных данных. Если размер известен, apt теперь не будет загружать больше данных, чем ожидается. Максимальный размер регулируется параметром Acquire::MaxReleaseFileSize;
  • Добавлена поддержка метода PDiff для наложения патчей к сжатым данным;
  • Для исключения неоднозначной трактовки команда 'apt-get files' переименована в 'apt-get indextargets';
  • Реализована команда "apt-cache showsrc --only-source srcpkgname".

  1. Главная ссылка к новости (https://lists.debian.org/debia...)
  2. OpenNews: В пакетном менеджере APT выявлена новая уязвимость
  3. OpenNews: Представлена бета-версия Cupt - проекта, продолжающего развитие APT
  4. OpenNews: Релиз пакетного менеджера Apt 1.0
  5. OpenNews: Для PkgSrc представлен APT-подобный пакетный менеджер nih
  6. OpenNews: Представлен проект по созданию пакетного менеджера APT2
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/43403-apt
Ключевые слова: apt, debian
Поддержать дальнейшую публикацию новостей на OpenNET.


Обсуждение (156) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 10:27, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    Время переустанавливать дебиан - дебиан сам себя не переустановит :^D
     
     
  • 2.4, Michael Shigorin (ok), 11:04, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Время переустанавливать дебиан - дебиан сам себя не переустановит :^D

    Зачем бы? :)

     
     
  • 3.9, РОСА (ok), 11:35, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +4 +/
    В OpenMandriva используется apt?… Новость для меня. Я использовал «родной» для OpenMandriva urpmi.
     
  • 3.11, Аноним (-), 11:49, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –8 +/
    до сих пор встречаются ситуации, когда обновление пакетного менеджера тянет за собой проблемы с обновлением всего остального
     
     
  • 4.59, myhand (ok), 14:40, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Когда школьник сидит на сиде?
     
     
  • 5.61, Аноним (-), 14:56, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    когда на сиде вертится сервак, потому что в штабле уже все окаменело
     
     
  • 6.79, myhand (ok), 16:53, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +8 +/
    > когда на сиде вертится сервак

    А, localhost школьника...

     
     
  • 7.84, Аноним (-), 17:06, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Что ж у Вас что ни анонимус, то школьник? Аль били в школе часто?
     
     
  • 8.90, Аноним (-), 17:53, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Да это распространённая аберрация сознания у школьников, когда им кажется, что в... текст свёрнут, показать
     
  • 8.94, ram_scan (?), 19:14, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Экспериментировать с нестабильными релизами может по определению человек, которы... текст свёрнут, показать
     
     
  • 9.96, Аноним (-), 19:55, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ответственность - это не отказ от экспериментов Вы видимо никогда не знали, что... большой текст свёрнут, показать
     
     
  • 10.100, anonymous (??), 20:16, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Это не экспериментаторы, а тестеры В продакшен такое будет ставить только полны... текст свёрнут, показать
     
     
  • 11.138, Аноним (-), 16:00, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Не спорю Только где в предыдущих постах речь шла именно о продакшене Суть заяв... большой текст свёрнут, показать
     
     
  • 12.163, myhand (ok), 19:46, 01/12/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Там где школие гордо заявило сервак Суть лично моего выступления была не тип... большой текст свёрнут, показать
     
  • 11.142, anonymous (??), 16:39, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    У вас очень ограниченный мирок Есть продакшн сервера которые и пару дней могут ... текст свёрнут, показать
     
  • 6.130, 1111 (??), 02:25, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Когда на сиде вертится сервак, это уже дигноз покруче чем "школьник"
     
     
  • 7.141, anonymous (??), 16:33, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Когда на сиде вертится сервак, это уже дигноз покруче чем "школьник"

    А когда самописные приложения на серваке вертятся?
    Ну те, которые банки, нефтяные компании для себя пишут.

     
  • 5.76, Аноним (-), 16:35, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Времена когда в sid что то по серьёзному ломали уже давным-давно прошли.
     
  • 4.89, Nicknnn (ok), 17:33, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Не встречается.
     
  • 3.77, Sluggard (ok), 16:42, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    В Альте придётся много перепиливать под новую версию?
    Или вы решите с предыдущей остаться, а там потихоньку?
     
     
  • 4.81, myhand (ok), 16:56, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    А там разве не древний как г*вно мамонта форк?
     
     
  • 5.82, Sluggard (ok), 17:03, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > А там разве не древний как г*вно мамонта форк?

    Вот это нам Миша и расскажет, я надеюсь.

     
  • 4.120, Michael Shigorin (ok), 00:40, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > В Альте придётся много перепиливать под новую версию?

    Много, у нас форк ещё 0.5.x (правда, как и с rpm-4.0.4, он сильно ушёл вперёд).

    > Или вы решите с предыдущей остаться, а там потихоньку?

    Угу.  Часть работ уже проведена, выяснены узкие места, но с разбегу не берутся.

     
  • 2.6, Аноним (-), 11:13, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > дебиан сам себя не переустановит

    Почему это?

     
     
  • 3.10, Аноним (-), 11:45, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Кто за тебя apt ... вводить будет?
     
     
  • 4.85, Pilat (ok), 17:13, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Кто за тебя apt ... вводить будет?

    cron-apt ?

     

     ....большая нить свёрнута, показать (25)

  • 1.2, Какаянахренразница (ok), 10:38, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Ждём ебилдо^W deb-пакетов. Хм, "apt-get install apt" звучит немножко странно.
     
     
  • 2.3, Эргил (ok), 11:03, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +6 +/
    > "apt-get install apt" звучит немножко странно.

    Что странного? apt постепенно приходит на смену apt-get и apt-cache, пока еще неполноценно, но приходит. До недавнего времени команды apt не существовало, были apt-get, apt-cache, apt-config, apt-cdrom, apt-key. Сейчас apt может заменить собой apt-get и apt-cache. При этом в нем есть функционал которого не было в предшественниках(либо я его не знал все 15 лет пользования Debian), apt list --upgradable это прекрасно.

     
     
  • 3.45, Аноним (-), 13:22, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >До недавнего времени команды apt не существовало, были apt-get, apt-cache, apt-config, apt-cdrom, apt-key.

    Вот наличие команд apt-* с кучей суффиксов вместо одной единой команды apt которая принимает различные опции (apt search, apt install, apt remove, apt update, apt upgrade) - это самая большая вещь которая меня раздражает в Debian (это чисто эстетически крайне некрасиво, и необходимо помнить ненужные суффиксы), почему за столько лет ещё не перешли на просто apt непонятно совершенно.

     
     
  • 4.46, Эргил (ok), 13:26, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > почему за столько лет ещё не перешли на просто apt
    > непонятно совершенно.

    Ну вот просто apt зарелизился не так давно(в апреле прошлого года), в stretch он у меня есть, в Ubuntu 14.04 тоже есть, есть ли jessie не знаю, под рукой отсутствует, проверить не могу.

     
     
  • 5.49, Аноним (-), 13:46, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >в Ubuntu 14.04 тоже есть

    В 14.04 у apt отсутствует автодополнение по клавише Tab для некоторых его опций, например, набираю apt s, жму Tab, автодополняется до apt show, а мне нужен был search. Если вручную написать apt search firefox то поиск работает. При этом такие опции apt как remove, purge, install, update, upgrade, dist-upgrade успешно автодополняются по Tab.

     
     
  • 6.52, Эргил (ok), 13:48, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > В 14.04 у apt отсутствует автодополнение по клавише Tab для некоторых его
    > опций, например, набираю apt s, жму Tab, автодополняется до apt show,
    > а мне нужен был search. Если вручную написать apt search firefox
    > то поиск работает. При этом такие опции apt как remove, purge,
    > install, update, upgrade, dist-upgrade успешно автодополняются по Tab.

    За дополнение отвечает не apt, а автодополнение вашего шелла. Смотрите в сторону bash-completion, можете сами его научить нужному. И, да, у apt нет dist-upgrade, есть full-upgrade.

     
     
  • 7.53, Аноним (-), 13:58, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –2 +/
    >За дополнение отвечает не apt, а автодополнение вашего шелла. Смотрите в сторону bash-completion, можете сами его научить нужному.

    Ещё чего, всё должно работать из коробки.

    >И, да, у apt нет dist-upgrade, есть full-upgrade.

    Тем не менее если набрать apt d и нажать Tab то автодополняется до apt dist-upgrade.

     
     
  • 8.56, Эргил (ok), 13:59, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Что должно работать За дополнение отвечает шелл apt пока вы его не запустили н... текст свёрнут, показать
     
     
  • 9.74, Аноним (-), 16:24, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Не прикидывайся веником, ты всё понял, о том и речь что я не должен ничего отпра... текст свёрнут, показать
     
     
  • 10.75, Эргил (ok), 16:26, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Кому и что должно в открытом и бесплатном проекте Оно ничего никому не должно ... текст свёрнут, показать
     
     
  • 11.155, АнонимХ (??), 11:21, 29/11/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Не функционала, а функциональности Не в в открытом и бесплатном , а в свободно... текст свёрнут, показать
     
  • 10.105, Sinot (ok), 22:30, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Так и пишите свои притенении в новости про используемый вами шелл ... текст свёрнут, показать
     
  • 6.139, Аноним (-), 16:28, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > В 14.04 у apt отсутствует автодополнение по клавише Tab для некоторых его опций,

    Ты шутишь или действительно думаешь что команда может что-то тебе подсказывать (автодополнение) _до_того_ как ты её запустил на выполнение (нажал Enter)?

     
     
  • 7.140, Michael Shigorin (ok), 16:30, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >> В 14.04 у apt отсутствует автодополнение по клавише Tab для некоторых его опций,
    > Ты шутишь или действительно думаешь что команда может что-то тебе подсказывать
    > (автодополнение) _до_того_ как ты её запустил на выполнение (нажал Enter)?

    man zsh || find /usr/share/doc -name bash_completion.txt

    (а вообще человек оговорился, наверное -- не "у apt", если речь не про apt-shell)

     
     
  • 8.143, anonymous (??), 17:04, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    A почему не man apt 124 124 find usr share doc -name apt_completion txt ... текст свёрнут, показать
     
  • 6.148, Аноним (-), 22:50, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Ты выбрал древний дистрибутив в котором нет автодополнения apt. Начиная с 15.04 автодополнение появилось.
     
     
  • 7.149, Аноним (-), 03:07, 29/11/2015 [^] [^^] [^^^] [ответить]  
  • –2 +/
    А в Debian даже в unstable у apt вообще отсутствует полностью автодополнение, вот такой вот "замечательный" в Debian мейнтейнер у пакета bash-autocompletion.
     
     
  • 8.157, Michael Shigorin (ok), 13:17, 29/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Так повесьте же наконец багу да выпейте чаю ... текст свёрнут, показать
     
     
  • 9.159, Аноним (-), 14:43, 29/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Багрепортов там до дури, больше сотни, висят годами https bugs debian org cgi... текст свёрнут, показать
     
  • 5.65, Аноним (-), 15:04, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >>есть ли jessie не знаю

    Проверил - есть :)

     
     
  • 6.67, Эргил (ok), 15:05, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >>>есть ли jessie не знаю
    > Проверил - есть :)

    Спасибо, буду знать :)

     
  • 4.73, Аноним (-), 16:24, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –3 +/
    >Вот наличие команд apt-* с кучей суффиксов вместо одной единой команды apt ...

    Легким движением руки брюки превращаются... apt-* -> apt -> dnf  :D

     
     
  • 5.98, Аноним (-), 20:06, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    ты не фрацтаил случайно? а то легким движением руки пакетный менеджер может превратиться в systemd-dnfd
     
     
  • 6.131, Аноним (-), 03:48, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Хорошо было бы
     
  • 4.151, Аноним (-), 07:13, 29/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    man alias
     
  • 3.66, Аноним (-), 15:05, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +5 +/
    >>  Сейчас apt может заменить собой apt-get и apt-cache. При этом в нем есть функционал которого не было в предшественниках

    apt autoclean
    >> E: Invalid operation autoclean

    apt autoremove
    >> E: Invalid operation autoremove

    Мда. Жаль.

     
     
  • 4.110, Dmitry (??), 00:07, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    В ubuntu 15.10 работает и apt autoclean и apt autoremove
     
  • 2.8, Stanislavvv (?), 11:24, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Нормально оно звучит :-)
    В какой-то версии дебиана так и рекомендовали апгрейдиться - вначале апт, потом всё остальное.
     
  • 2.21, anonymous (??), 12:26, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    zypper up zypper

     

     ....большая нить свёрнута, показать (28)

  • 1.5, Аноним (-), 11:11, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +8 +/
    > apt-get install foo_1.0_all.deb

    УРА!!!

     
     
  • 2.22, sabakka (?), 12:33, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    сколько же ждать пришлось
     
     
  • 3.30, imho (?), 12:42, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Теперь столько же ждать будете apt-get update <repo>
     
  • 2.23, ryoken (?), 12:35, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >> apt-get install foo_1.0_all.deb
    > УРА!!!

    Чо ура, dpkg -i foo_1.0_all.deb писать короче :D

     
     
  • 3.42, Andrey Mitrofanov (?), 13:12, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >>> apt-get install foo_1.0_all.deb
    >> УРА!!!
    > Чо ура, dpkg -i foo_1.0_all.deb писать короче :D

    Та же д.б.бы б.[CODE]apt install fo[...][/CODE]Те двое выше новости не читали. (я тоже нен читал, незачем)

     
     
  • 4.43, Andrey Mitrofanov (?), 13:13, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >>-i
    >install

    билн, не короче. посыпаю.


     
  • 3.47, Эргил (ok), 13:31, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >>> apt-get install foo_1.0_all.deb
    >> УРА!!!
    > Чо ура, dpkg -i foo_1.0_all.deb писать короче :D

    Ага. И получаем «Ой! Не шмагла! Зависимости! Делай теперь, хозяин apt-get install -f».
    На самом деле

    sudo gdebi foo_1.0_all.deb

     
     
  • 4.60, Аноним (-), 14:54, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >sudo gdebi foo_1.0_all.deb

    Упоролся? Специально для этого сделали dpkg. Я посмотрю, как ты это будешь выполнять на сервере. Лол.

     
     
  • 5.62, Эргил (ok), 14:57, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >>sudo gdebi foo_1.0_all.deb
    > Упоролся? Специально для этого сделали dpkg. Я посмотрю, как ты это будешь
    > выполнять на сервере. Лол.

    Так же, как всегда делаю.

    Usage: gdebi [options] filename

    Не путай gdebi и gdebi-gtk. dpkg не способен поставить зависимости к пакету, а лишь может сказать «паламалася я». gdebi же принесет все зависимости сам. То что вы не знаете о том, что gdebi — cliшная утилита лишь говорит о том, что видели Debian только у себя в виртуалочке на своей винде.

     
  • 2.111, Michael Shigorin (ok), 00:21, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >> apt-get install foo_1.0_all.deb
    > УРА!!!

    Из альтового сбэкпортили, что ли? :)

     

  • 1.7, Yar4e (?), 11:13, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    >> Возможность установки индивидуальных пакетов ("apt-get install foo_1.0_all.deb") и указания полного пути к пакету ("apt-get install /foo/bar.deb"); <<

    Ну наконец-то! Можно будет в Ubunte делать как и в Alt'е!) А то вызывало диссонанс - в "родном" для apt дистре не работает то, что работает в "не родном"..

     
  • 1.13, Анони (?), 11:53, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    apt и пакеты на винты мои сели
    apt и ставиться индивидуально хотят

    =D

     
  • 1.14, Меломан1 (?), 11:58, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –13 +/
    Перешли бы на Yum (Dnf) и Rpm узнали что такое счастье. Тебе и моментальное определение зависимостей, и Delta Rpm, и автоматический поиск быстрого зеркала, управление обновлениями, кэшем и всем всем всем. А то юзают какую то хрень Apt еще и радуются, извращенцы.
     
     
  • 2.15, Аноним (-), 12:05, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +6 +/
    > автоматический поиск быстрого зеркала

    Который работает медленнее, чем собственно скачивание чего-либо с зеркала.

     
     
  • 3.41, Меломан1 (?), 13:10, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Если не нравится миррорлист можешь свое любимое зеркало указать, тебе это никто не запрещает.
     
     
  • 4.99, Аноним (-), 20:08, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Если не нравится миррорлист можешь свое любимое зеркало указать, тебе это никто
    > не запрещает.

    проще плугин престо придушить, чем перечислять все зеркала во всех репах

     
  • 2.19, Аноним (-), 12:23, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Как в Yum (Dnf) сделать операцию аналогичную apt-get autoremove?
     
     
  • 3.27, Аноним (-), 12:38, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Вам это не нужно, партия не велит.
     
  • 3.33, Owlet (?), 12:47, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    ты в жизни не поверишь, но 'dnf autoremove'. впрочем, dnf взял манеру это делать автоматически
     
  • 3.39, Меломан1 (?), 13:00, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Как в Yum (Dnf) сделать операцию аналогичную apt-get autoremove?

    Я наоборот в dnf.conf прописываю keepcache=true, что бы после установки или обновления он не удалял пакеты.

     
     
  • 4.71, fa9238721 (?), 15:42, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    причем тут кэш и ненужные зависимости?
     
  • 3.78, Иван (??), 16:51, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    А как в apt сделать dnf history undo ?
     
     
  • 4.97, Аноним (-), 19:58, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    не как
     
  • 2.24, Аноним (-), 12:35, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –4 +/
    И поиск быстрого зеркала есть и все остальное. Ну а самое главное в DEB изначально были скрипты ДО инсталяции, ПОСЛЕ инсталяции, ДО деинсталяции и ПОСЛЕ деинсталяции.
    А в RPM такого не было. И сомнительно что есть сейчас.
     
     
  • 3.31, Анонимный (?), 12:44, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    С разморозкой: а альте, к примеру, это с каменного века.
     
     
  • 4.34, Аноним (-), 12:47, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Именно ПРЕД И ПОСТ скрипт на инсталляцию и деинсталляцию?
    Может просто скрипт на инсталляцию и скрипт на деинсталляцию?
    Не путаете?
     
     
  • 5.51, fi (ok), 13:47, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +3 +/
    "Именно ПРЕД И ПОСТ скрипт на инсталляцию и деинсталляцию?"

    вы меня пугаете! я помню их еще  rpm3 & rh4.x - то есть около 20 лет!

    Что сниться в криокамере?

     
  • 5.113, Michael Shigorin (ok), 00:24, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Именно ПРЕД И ПОСТ скрипт на инсталляцию и деинсталляцию?
    > Может просто скрипт на инсталляцию и скрипт на деинсталляцию?
    > Не путаете?

    Пожалуйста, изучайте матчасть перед столь уверенными утверждениями.  Особенно когда они глупейшие.

    Как вариант, скормите яндексу rpm spec %pre %post %preun %postun (и ещё про триггеры).

     
  • 3.35, Owlet (?), 12:48, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > И поиск быстрого зеркала есть и все остальное. Ну а самое главное
    > в DEB изначально были скрипты ДО инсталяции, ПОСЛЕ инсталяции, ДО деинсталяции
    > и ПОСЛЕ деинсталяции.
    > А в RPM такого не было. И сомнительно что есть сейчас.

    Всю жизнь было, с разморозкой

     
     
  • 4.37, Аноним (-), 12:51, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –4 +/
    >Всю жизнь было, с разморозкой

    Ошибаетесь в RPM был только инсталляционный и деинсталляционный скрипт (два скрипта на пакет) а в DEB изначально четыре скрипта на пакет

     
     
  • 5.40, Меломан1 (?), 13:07, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –2 +/
    >>Всю жизнь было, с разморозкой
    > Ошибаетесь в RPM был только инсталляционный и деинсталляционный скрипт (два скрипта на
    > пакет) а в DEB изначально четыре скрипта на пакет

    Да хоть 10 скриптов на пакет, если этот deb такой бестолковый и не понимает, с первого слова, что надо делать, то зачем он нужен такой разговорчивый? Вот RPM установил, удалил, переустановил, проверил пакет. Все больше ничего не надо, если не тривиальная установка, то это пусть баш делает.

     
  • 5.44, andy (??), 13:18, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Неправда http www rpm org max-rpm s1-rpm-inside-scripts html The pre Script ... большой текст свёрнут, показать
     
     
     
    Часть нити удалена модератором

  • 7.69, andy (??), 15:18, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Что-ж я рад что теперь RPM умеет то что DEB умел изначально и RPM не умел долгое время

    Теперь - это уже лет 15. Документ, выше по ссылке, датирован 2000 годом.

     
  • 7.72, Меломан1 (?), 16:06, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >>Неправда
    > Что-ж я рад что теперь RPM умеет то что DEB умел изначально
    > и RPM не умел долгое время

    Вы еще вспомните кто первый убил мамонта.

     
  • 7.114, Michael Shigorin (ok), 00:26, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Что-ж я рад что теперь RPM умеет то что DEB умел изначально
    > и RPM не умел долгое время

    Ещё один всплеск этого упорного бреда -- и я его зачищу весь, оставив только ответ Андрея как наиболее обстоятельный.

     
  • 2.117, Michael Shigorin (ok), 00:33, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Перешли бы на Yum (Dnf) и Rpm узнали что такое счастье.

    Да ладно сказки-то рассказывать.

    > Тебе и моментальное определение зависимостей

    Это пока не понадобятся альтернативы в репозитории.  Сузешники от них были вынуждены избавиться при переходе по сути на libsolv для разрешения зависимостей, а у шляпников и так завсегда дубовейший был репозиторий в этом плане...

    // покосившись на apt-rpm

     
     
  • 3.144, Led (ok), 17:21, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >> Тебе и моментальное определение зависимостей
    > Это пока не понадобятся альтернативы в репозитории.  Сузешники от них были
    > вынуждены избавиться при переходе по сути на libsolv для разрешения зависимостей

    Что за бред?

     
     
  • 4.158, Michael Shigorin (ok), 13:20, 29/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >>> Тебе и моментальное определение зависимостей
    >> Это пока не понадобятся альтернативы в репозитории.  Сузешники от них были
    >> вынуждены избавиться при переходе по сути на libsolv для разрешения зависимостей
    > Что за бред?

    Покажи, пожалуйста, пару спеков из factory, реализующих альтернативные пакеты.  Может, я что-то пропустил, но в SAT не получается разрешить такую задачу воспроизводимым образом (apt реализует существенно иной метод разрешения зависимостей, включающий логику такого выбора).  По математике можешь спросить ldv@, если интересно.

     
     
  • 5.161, Led (ok), 19:08, 29/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Покажи, пожалуйста, пару спеков из factory, реализующих альтернативные пакеты.

    Наскидку, неглядя, по памяти: tftp/atftp

     

  • 1.16, kravich (ok), 12:12, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Возможность установки индивидуальных пакетов ("apt-get install foo_1.0_all.deb") и указания полного пути к пакету ("apt-get install /foo/bar.deb");

    Ну наконец-то!

     
     
  • 2.57, xaxaxa (?), 14:02, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    А чо, dpkg -i пальцы ломало?
     
     
  • 3.58, Crazy Alex (ok), 14:28, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +4 +/
    нет, ломало зависимости
     
     
  • 4.86, Аноним (-), 17:22, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    но лучшеб всё-таки пальцы.
     
  • 4.91, xaxaxa (?), 18:01, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Имя пакета, где dpkg ломает зависимости
     
     
  • 5.107, Эргил (ok), 23:40, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Имя пакета, где dpkg ломает зависимости

    Любой пакет с зависимостями которые еще не установлены.
    apt-btrfs-snapper, vivaldi и далее везде.
    Если у тебя чего-то из требуемого ему не стоит, то при попытке поставить его через dpkg -i ты получишь писк про зависимости и предложение сделать apt-get install -f.

     
     
  • 6.112, xaxaxa (?), 00:24, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • –5 +/
    Обычно dpkg предлагает доустановить неустановленные пакеты для корректной установки. Так про какие ломки зависимостей шла речь, если при неудовлетворенных зависимостях инсталл идёт в девнулл, а при ключе force вы сами ломаете систему?
     
     
  • 7.119, Эргил (ok), 00:37, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Обычно dpkg предлагает доустановить неустановленные пакеты для корректной установки.
    > Так про какие ломки зависимостей шла речь, если при неудовлетворенных зависимостях
    > инсталл идёт в девнулл, а при ключе force вы сами ломаете
    > систему?

    Не предлагает он доустановить. Он говорит, что нешмагла и грохается. И предлагает починить это через apt-get install -f, где -f это не force, а fix-broken.

     

  • 1.17, Саша (??), 12:14, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    sudo apt autoremove -не работает, еще рано?
     
  • 1.18, Аноним (-), 12:21, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Попробовал, пока как-то слабоюзабельно, опций почти нету. Не хватает:

    --no-install-reconnends
    --download-only
    --fix-broken
    --dry-run, -s
    --assume-yes, -y
    --purge
    --reinstall
    --target-release, -t

     
     
  • 2.87, Аноним (-), 17:23, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > --dry-run, -s

    вот, кстати, бесит. в куче софта -> -n

     

  • 1.20, Пётр (ok), 12:25, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Опять свистоперделки, лучше autoremove нормально бы реализовали, как в Arch. Проведите такой опыт в Дебиане: 1) apt install kde 2) apt remove kde 3)apt autoremove Грубо говоря, из 300 пакетов в системе останутся висеть мёртвым грузом штук 100. Pacman -Rs же в Arch удалит все до единого, не говоря уже про скорость работы. Кривое и устаревшее нагромождение костылей этот apt.
     
     
  • 2.25, ryoken (?), 12:37, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Опять свистоперделки, лучше autoremove нормально бы реализовали, как в Arch. Проведите
    > такой опыт в Дебиане: 1) apt install kde 2) apt remove
    > kde 3)apt autoremove Грубо говоря, из 300 пакетов в системе останутся
    > висеть мёртвым грузом штук 100. Pacman -Rs же в Arch удалит
    > все до единого, не говоря уже про скорость работы. Кривое и
    > устаревшее нагромождение костылей этот apt.

    Вспоминается поговорка про кулика и болото.

     
     
  • 3.32, Dzmitry (??), 12:47, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +7 +/
    Товарищ конкретный пример привёл, по делу. Можешь опровергнуть -- валяй.
     
     
  • 4.70, ryoken (?), 15:30, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Товарищ конкретный пример привёл, по делу. Можешь опровергнуть -- валяй.

    Не могу, в арчах не копенгаген. Надо упомянуть, что работа с пакетами в Демьяне иногда меня тоже добивает.

     
  • 2.55, xaxaxa (?), 13:59, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Бгг, ты забыл побаянить за свежесть пакетов ещё
     
  • 2.64, Аноним (-), 14:59, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >в Arch удалит все до единого

    вся суть, лол

     
  • 2.92, systemd_anonymousd (?), 19:03, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Опять свистоперделки, лучше autoremove нормально бы реализовали, как в Arch. Проведите
    > такой опыт в Дебиане: 1) apt install kde 2) apt remove
    > kde 3)apt autoremove Грубо говоря, из 300 пакетов в системе останутся
    > висеть мёртвым грузом штук 100. Pacman -Rs же в Arch удалит
    > все до единого, не говоря уже про скорость работы. Кривое и
    > устаревшее нагромождение костылей этот apt.

    Используйте debfoster, пока не завезут изкоробочное.

     
  • 2.145, freehck (ok), 20:52, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Пётр, вообще говоря пример совсем не корректен Во-первых, и это только верхушка... большой текст свёрнут, показать
     
     
  • 3.160, Пётр (ok), 17:53, 29/11/2015 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Да мне всё равно, чья это проблема, хоть Папы Римского Криворукие разработчики ... большой текст свёрнут, показать
     
     
  • 4.164, freehck (ok), 09:18, 02/12/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Всяк кулик своё болото хвалит.
     
  • 4.165, Michael Shigorin (ok), 15:57, 02/12/2015 [^] [^^] [^^^] [ответить]  
  • +/
    ...куча сборочного хлама на диске, полная непригодность для промышленного применения во многих областях уже поэтому...

    Ох уж мне эти арчекулики.

     

  • 1.28, Аноним (-), 12:39, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    APT штука хорошая но уже нужно что-то по типу GIT - с возможностью ставить что угодно и откатываться на что угодно - с возможностью запоминать любое множество текущих пакетов, изменять его, возвращаться к нему, давать имена этим множествам, как-то так. Может даже на основе git как хранилища.
     
     
  • 2.36, Dzmitry (??), 12:50, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > APT штука хорошая но уже нужно что-то по типу GIT

    Плюсую. И с push нотификациями об обновления, через любой pubsub сервис.


     
     
  • 3.50, Эргил (ok), 13:46, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Плюсую. И с push нотификациями об обновления, через любой pubsub сервис.

    Берете apt, берете https://github.com/r-darwish/pushbullet-cli и пашите себе выхлоп apt list --upgradable после apt update.

     
  • 2.38, Аноним (-), 12:58, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    aptly?
     
     
  • 3.146, freehck (ok), 20:54, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Именно. Самая адекватная нынче утилита для создания репозиториев apt.
     
  • 2.48, Меломан1 (?), 13:38, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > APT штука хорошая но уже нужно что-то по типу GIT - с
    > возможностью ставить что угодно и откатываться на что угодно - с
    > возможностью запоминать любое множество текущих пакетов, изменять его, возвращаться к
    > нему, давать имена этим множествам, как-то так. Может даже на основе
    > git как хранилища.

    Еще один изобретатель, dnf history уже все это делает.

     
  • 2.95, alex (??), 19:25, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Это кошмар мейнтейнера.
     
  • 2.132, Аноним (132), 10:20, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    https://nixos.org/nix/ не устроит?:)
     

  • 1.54, xaxaxa (?), 13:58, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Теперь apt взялся жиреть, ну ити вашу мать!
     
     
  • 2.68, RootKiiit (?), 15:16, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Лишь бы не потел ...
     

  • 1.83, Аноним (-), 17:03, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Блин, не трогали бы то, что работает...
     
     
  • 2.93, testt (ok), 19:13, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Ага, старые гайды уже некому переписывать?
     
     
  • 3.104, Аноним (-), 21:38, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Гайды лучше актуального Man? думаю да, ибо для дополнительных чит-кодов нужно лезть в исходники.
     

  • 1.102, Аноним (-), 21:11, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –4 +/
    rpm вполне хорошо работает, зачем нужен apt?
     
     
  • 2.108, Эргил (ok), 23:44, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > rpm вполне хорошо работает, зачем нужен apt?

    Холодильник хорошо работает, зачем нужна плита?
    rpm и apt несколько про разное.
    Аналогом dpkg в rpm-hell-системах является rpm, а аналогом apt yum/zypper и никак иначе.

     
     
  • 3.116, Michael Shigorin (ok), 00:29, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > rpm и apt несколько про разное.

    Да.

    > Аналогом dpkg в rpm-hell-системах является rpm, [B]а аналогом apt yum/zypper и никак иначе.[/B]

    Я бы на Вашем месте не был столь самоуверенным, поскольку упустили минимум ещё два варианта.

     
     
  • 4.118, Эргил (ok), 00:36, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >> Аналогом dpkg в rpm-hell-системах является rpm, [B]а аналогом apt yum/zypper и никак иначе.[/B]
    > Я бы на Вашем месте не был столь самоуверенным, поскольку упустили минимум
    > ещё два варианта.

    Да, в Alt не смотря на принадлежность его к rpm-hell используется apt, я это помню. Но за Alt тут выступаете Вы, Михаил.
    Что я там еще упустил? dnf? Я его не видел и не горю желанием.

     
     
  • 5.121, Michael Shigorin (ok), 00:47, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >>> а аналогом apt yum/zypper [B]и никак иначе.[/B]
    >> упустили минимум ещё два варианта.
    > Да, в Alt не смотря на принадлежность его к rpm-hell используется apt,
    > я это помню. Но за Alt тут выступаете Вы, Михаил.

    Вне зависимости от наличия или отсутствия меня и кого бы то ни было призываю высказываться точно :)

    > Что я там еще упустил? dnf? Я его не видел и не горю желанием.

    Тем не менее существует и на известных rpm-системах вполне себе является аналогом apt.

     
     
  • 6.123, Эргил (ok), 00:53, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Вне зависимости от наличия или отсутствия меня и кого бы то ни
    > было призываю высказываться точно :)

    Я, иногда, забываю про Alt, если честно. Со времен как перестал ездить на LinuxFest и общаться там с частью вашей команды не видел вашего дистрибутива, грешен.

    > Тем не менее существует и на известных rpm-системах вполне себе является аналогом
    > apt.

    А dnf уже в каких-то продакшен-системах есть или он только на минном поле Fedora все еще?

     
     
  • 7.124, Michael Shigorin (ok), 01:01, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Я, иногда, забываю про Alt, если честно. Со времен как перестал ездить
    > на LinuxFest и общаться там с частью вашей команды не видел
    > вашего дистрибутива, грешен.

    Да лишь бы находилось то, что для Ваших задач и пользователей годится :)

    На LF, кстати, небольшая группа без анонсов собирается и ныне (этим летом приезжали ещё четыре студента, встали поодаль; а с анонсами дошло было до совсем левой публики, портившей всем жизнь).  Но это уж офтопик, виноват.

    > А dnf уже в каких-то продакшен-системах есть или он только на минном
    > поле Fedora все еще?

    Насколько понимаю, штатно только в федоре (поискал -- пишут, что на RHEL7 устанавливают из EPEL).  Тем не менее вариантов у редхата особых нет, т.к. автор yum погиб и bus factor оказался невелик...

     
     
  • 8.125, Эргил (ok), 01:04, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Ну я покидал Москву на несколько лет и мне было не с руки ездить, надо будет узн... текст свёрнут, показать
     
     
  • 9.134, rob pike (?), 11:17, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    У apt-rpm были хорошие шансы, но RH продавил yum Тренировались перед systemd ... текст свёрнут, показать
     
  • 8.135, Эргил (ok), 11:20, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Михаил, кстати, а что у вас в Альте с установкой Google Chrome Именно Chrome, а... текст свёрнут, показать
     
     
  • 9.137, Michael Shigorin (ok), 13:01, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    http altlinux org chrome -- только это уж совсем офтопик, идёмте куда-нить в h... текст свёрнут, показать
     
  • 7.126, fi (ok), 01:14, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > А dnf уже в каких-то продакшен-системах есть или он только на минном поле Fedora все еще?

    это как с systemd - будет везде :)

    собственно это yum-ng  - мало заметные отличия снаружи. Только имя неудачное.

    Btw, a чем Fedora провинилась? тут занялся армами - вполне себе система, уж лучше чем другие.

    зы. скорей всего будет в RHEL8

     
     
  • 8.127, Эргил (ok), 01:17, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Да ничем Просто Федора 8212 тестовый полигон, а не дистрибутив для использов... текст свёрнут, показать
     
     
  • 9.133, rob pike (?), 11:15, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Это так с совершенно любым дистрибутивом Поэтому используют уровни testing и s... текст свёрнут, показать
     
  • 2.115, Michael Shigorin (ok), 00:28, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > rpm вполне хорошо работает, зачем нужен apt?

    Это инструменты разного уровня -- rpm занимается пакетами (как тот же dpkg), apt занимается зависимостями в репозитории (как тот же yum).

     
     
  • 3.122, Аналитики АНБ (?), 00:51, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Спасибо КЭП, мы собираем метрики реакции на вбросы.
     
     
  • 4.129, systemd_anonymousd (?), 01:25, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Спасибо КЭП, мы собираем метрики реакции на вбросы.

    А за что это вас так, заместо машин статистику собирать? Пили на рабочем месте?

     
  • 3.128, fi (ok), 01:25, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >> rpm вполне хорошо работает, зачем нужен apt?
    > Это инструменты разного уровня -- rpm занимается пакетами (как тот же dpkg),
    > apt занимается зависимостями в репозитории (как тот же yum).

    Очень нужная подсказка :) Несмотря на альт, когда говорят apt подразумевают deb и прочие надстройки над ним.

     
     
  • 4.136, Michael Shigorin (ok), 12:55, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >>> rpm вполне хорошо работает, зачем нужен apt?
    >> Это инструменты разного уровня
    > Очень нужная подсказка :) Несмотря на альт, когда говорят apt подразумевают deb

    Вот такие и сегфолтятся при виде apt-rpm. :)

     

     ....большая нить свёрнута, показать (18)

  • 1.106, Аноним (106), 22:31, 27/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    Интересно как apt обновит apt :)
     
     
  • 2.109, Эргил (ok), 23:44, 27/11/2015 [^] [^^] [^^^] [ответить]  
  • +4 +/
    > Интересно как apt обновит apt :)

    Спокойно и не чихая, как делает это много лет.

     
  • 2.147, freehck (ok), 20:59, 28/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Интересно как apt обновит apt :)

    Интересно, как gcc соберёт gcc?
    Интересно, как pypy соберёт pypy?
    Интересно, как на лиспе написать интерпретатор лиспа?

     

  • 1.150, Аноним (-), 06:40, 29/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    судя по нынешним тенденциям, ждем aptd
     
     
  • 2.152, Andrey Mitrofanov (?), 08:06, 29/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > судя по нынешним тенденциям, ждем aptd

    Лёня не умеет "в графы" и пакажь-манажь-мент. Единственным верным пакажем считает КопиПаст.

     

  • 1.153, XAnimus (ok), 08:34, 29/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Они коровью суперсилу еще не выпилили? Я когда после бсд запустил apt-get что бы справку почитать. Последняя строчка меня заставила кататься по полу. Я искренне думал что это кривой перевод.
     
     
  • 2.154, Andrey Mitrofanov (?), 10:23, 29/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Я искренне думал что это кривой перевод.

    Никто не згает.   http://unix.stackexchange.com/questions/92185/whats-the-story-behind-super-co

     
     
  • 3.156, Michael Shigorin (ok), 13:02, 29/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > http://unix.stackexchange.com/questions/92185/whats-the-story-behind-super-co

    Ба, про aptitude -vv moo не знал 8)

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:
    При перепечатке указание ссылки на opennet.ru обязательно



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2021 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру