The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Доступен форк zsnes, эмулятора Super Nintendo

14.07.2021 22:22

Доступен форк zsnes, эмулятора игровой приставки Super Nintendo. Автор форка взялся за расчистку проблем со сборкой и приступил к обновлению кодовой базы. Исходный проект zsnes не обновлялся уже 14 лет и при попытке его использования возникают проблемы с компиляцией в современных дистрибутивах Linux, а также имеются несовместимости с новыми компиляторами. Обновлённый пакет размещён в репозитории Arch Linux. Из планов на будущее упоминается портирование на библиотеку SDL2. Код распространяется под лицензией GPLv2.

  1. Главная ссылка к новости (https://github.com/xyproto/zsn...)
  2. OpenNews: Выпуск Lakka 3.1, дистрибутива для создания игровых консолей
  3. OpenNews: Представлен порт Linux для игровых приставок Nintendo 64
  4. OpenNews: Выпуск эмулятора игровых консолей RetroArch 1.9.0
  5. OpenNews: Релиз дистрибутива для создания домашних кинотеатров LibreELEC 9.0
  6. OpenNews: Выпуск Dolphin 5.0, эмулятора игровых консолей GameCube и Wii
Автор новости: Аноним
Тип: Программы
Короткая ссылка: https://opennet.ru/55483-zsnes
Ключевые слова: zsnes, nintendo, super_nintendo, emulator
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (69) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Гурыч (?), 22:47, 14/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • +13 +/
    респект автору. а то уж думали, что всё, помер эмулятор.
     
  • 1.2, Dzen Python (ok), 22:55, 14/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • +6 +/
    Спасибо. Все-таки есть хорошие новости
     
  • 1.3, Аноним (3), 23:11, 14/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Кто бы нормальный эмулятор Genesis для SEGA Dreamcast намутил, чтобы без проблем со звуком и скоростью игры.
     
     
  • 2.11, oops (ok), 04:58, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Да, их есть какое-то количество, но все с какими-то проблемами и заброшены
     
  • 2.14, Аноним (14), 06:54, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Не получится с современными графическими API. Долго объяснять, но сейчас мы не знаем когда кадр отрисовываться будет и поэтому что-то синхронизировать очень сложно.
     

  • 1.4, Аноним (4), 23:13, 14/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    Пам-пам-пам-парамрам-парарарарара!
    Радостная весть. Ретрогейминг жив.
     
     
  • 2.5, Аноним (5), 23:24, 14/07/2021 [^] [^^] [^^^] [ответить]  
  • –7 +/
    Только не понятно, зачем
     
     
  • 3.7, Аноним (4), 00:07, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +12 +/
    Чтобы играть, ёкаламэнэ
     
  • 3.25, Козлетто (?), 09:24, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Потому что раньше было лучше. Ну и для старых игр не нужны топовые видеокарты. Даже разберри потянет.
     
     
  • 4.72, Kuromi (ok), 04:02, 30/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    > Потому что раньше было лучше. Ну и для старых игр не нужны
    > топовые видеокарты. Даже разберри потянет.

    Для эмулятора SNES видеокарта вообще безразлична (почти), там все на CPU. Во всяком случае для SNES это так, вот N64 уже 3D и там GPU уже нужен, хотя хватит и простенького.

     

  • 1.6, Аноним (6), 23:32, 14/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А кооп онлайн между платформами там так и не починили?
     
     
  • 2.20, GG (ok), 08:50, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А он когда-то работал в нём?
     
     
  • 3.53, Аноним (53), 19:06, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > А он когда-то работал в нём?

    не знаю, у меня не завёлся, хотя сказки из интернетов говорят, что должен работать.
    у меня не получилось поиграть с виндоюзверем.

     

  • 1.8, Ilya Indigo (ok), 02:23, 15/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    А чем mednafen не устроил?
    Там есть великолепные snes и snes_faust (использую его) модули!
     
     
  • 2.33, feoktist.rassolny (?), 10:49, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вы, наверное, не в курсе, что mednafen — просто сборник эмуляторов наподобие RetroArch (только поменьше и постабильнее, конечно).
     
     
  • 3.38, Ilya Indigo (ok), 11:28, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Вы, наверное, не в курсе, что mednafen — просто сборник эмуляторов наподобие
    > RetroArch (только поменьше и постабильнее, конечно).

    Не совсем так, у ретроарча нет своего ничего, кроме убогого и неудобного меню.
    У mednafen вообще нет меню, но его руками можно настроить при желании под каждую игру. чем я очень часто пользуюсь, а также у него единые опции настройки скалеров, шейдеров и интерполяторов, а также, не по умолчанию. а при correct_aspect = 0), правильные пропорции, что мне во многих эмуляторах очень не хватает.
    Но ещё у него свои модули, причём лучшие, их даже ретроарч использует, для PlayStation и Sega Suturn.
    Я думал mednafen snes от snes9x но нет, это как раз форк bsnes 0.059 с патчами https://mednafen.github.io/documentation/snes.html
    А вот snes_faust не понятно откуда, возможно собственная разработка на основе модуля snes.
    https://mednafen.github.io/documentation/snes_faust.html

     
  • 2.34, feoktist.rassolny (?), 10:51, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    В частности, поддержка SNES в нём от bsnes, если правильно помню.
     

  • 1.9, Аноним (9), 04:16, 15/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    Higan лучше всего, остальных в утиль.
     
     
  • 2.10, Аноним (9), 04:46, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Там, кстати, драма с автором, чёт не знаю. Как можно кого-то затравить? И зачем травить инвалида или склонять к суициду его и знакомых ему людей?

    Это лучший эмулятор на свете, этого не отнять. Но, вообще, было подозрение что чёт не то ещё в прошлом году когда он выкинул его целиком в опенсорс устранившись от разработки.

     
     
  • 3.70, Аноним (70), 01:24, 30/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Автора bsnes и higan больше с нами нет. F and RIP. Постарались пользователи kiwifarms (долго думал какой эпитет подобрать, решил, что лучше никакой, пусть будет "пользователи").
     
  • 2.27, InuYasha (??), 10:18, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Который гоняет игры 1980ых годов только на топовом железе 2010ых? Ну нафиг. Одержимость точной эмуляции должна знать пределы или быть опциональной. Под виндой под fceux спокойно можно играть во всё подряд. А под линуксом, в итоге, сплошной ужас и тормоза.
     
     
  • 3.40, Аноним (9), 11:50, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Не во всё подряд. Куча багов и несовместимостей и совершенно не похоже на оригинал. Эмуляторы должны максимально передавать всё оригинальные ощущения, а не терять половину возможностей. Иначе, зачем они нужны? Какие проблемы с топовым железом десятилетней давности? Сегодня этот уровень уже энтри левел и точное воспроизведение на устройстве иной архитектуры не бесплатно, так что тут вполне логично. Для примера, третьеплойка на обычном железе 2021 года вообще не эмулируется нормально, надо иметь хотя бы 6 очень быстрых ядер. Тут разница не 30 лет, только 15. Ещё лет через 15 железо уже будет позволять эмулировать не кое-как, но и подумать о точности.
     
     
  • 4.48, Kuromi (ok), 15:45, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Никогда не понимал этой вашей одержимостью "точной эмуляции" игр времен SNES. Да, баги и несовместимости бывают, это правда и вот тут точная эмуляция спасает, все верно, НО тезис о "не похоже на оригинал" меня просто смешит. Если вам так нужно "как оригинал", может проще купить настоящий SNES и пачку картриджей к нему. Даже более того, можно даже картриджи не покупать, а купить мультиромовый и гонять на нем.
     
     
  • 5.49, Аноним (9), 16:06, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Эмуляторы лучше и удобнее реального железа. Да и дешевле. Никаких проводов, опять же. Игры в те времена были намного круче нынешнего индишлака, и, если эмуляция позволяет получить большее удовольствие, почему нет?
     
     
  • 6.50, Kuromi (ok), 16:34, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Эмуляторы лучше и удобнее реального железа. Да и дешевле. Никаких проводов, опять
    > же. Игры в те времена были намного круче нынешнего индишлака, и,
    > если эмуляция позволяет получить большее удовольствие, почему нет?

    Так вы определитесь, вам эмуляция и удобства или "ощущение как будто по настоящему"?
    Именно об этом ведь речь, кто бы чтобы не говорил, а эмуляция изначално была способом "срезать углы", но некоторые хотят сделать такой эмулятор чтобы он еле ползал, грел процессор как печку, "зато там оттенки цветов похожи на настоящие" и пофиг что человек играет на жидкокристаллическом мониторе, а приставка цеплялась к кинескопному телевизору...

     
     
  • 7.52, Аноним (9), 16:48, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    На хорошем жк картинка будет почти как на элт монике. Лично меня беспокоит качество эмуляции. И звук, и цветопередача тоже. Картинку можно даже улучшить, но лишь бы точность эмуляции не страдала. Это единственное, что меня заботит.
     
     
  • 8.59, InuYasha (??), 16:32, 16/07/2021 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Мне послышалось Ты эмулируешь мои 256 цветов, но делаешь это без уважения Ну... текст свёрнут, показать
     

  • 1.12, nebularia (ok), 06:16, 15/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    > и при попытке его использованию возникают проблемы с компиляцией в современных дистрибутивах Linux, а также имеются несовместимости с новыми компиляторами

    Типичная ситуация в линуксе, однако. А если и бинарь есть, то он не запускается из-за какой-нибудь библиотеки. При этом под виндой софт 10-15-летней давности чувствует себя спокойно, в большинстве случаев.

     
     
  • 2.13, Аноним (13), 06:51, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Взять тот же ZSNESW 2007 года, кстати.
     
  • 2.15, Аноним (9), 07:14, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ха, нет. Я вот пытался собрать проект написанный для позапрошлой студии текущей и весьма обломался из-за миллионов несовместимостей. У гцц всё куда лучше в этом отношении. Линуксовый бинарный софт прекрасно работает спустя 20 лет, достаточно чтобы эта библиотека была (и её можно найти), если нет вендовой библиотеки то софт принципиально не запустишь потому что библиотека вообще неизвестно, что за файл.
     
     
  • 3.16, Аноним (9), 07:25, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Между 7 и 8 всего несколько лет разницы было кстати, но собрать не получилось по многим причинам. Люди просто не понимают, что разработка под закрытые ос хуже примерно во всём.
     
  • 3.26, пох. (?), 10:04, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +3 +/
    "несовместимости" в студию. Я очень хотеть видеть как это вообще возможно.

    А то ж сейчас окажется, что эта поделка гуанокодера и позапрошлой собиралась только с двумя притопами и тремя прихлопами и только на машине автора.

     
     
  • 4.39, Аноним (9), 11:38, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Конкретно в этом случае там были какие-то изменения в визуал цпп В итоге, автор... большой текст свёрнут, показать
     
     
  • 5.45, 123 (??), 12:51, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    >Ровно по этой же причине ремастеры 5-10 летних игр собирают в старом окружении

    Игроделы, особенно в древние времена, очень любили использовать недокументированные возможности и разные экзотические костыли, которые сами MS считают лютым харамом, в новых версиях шиндоушс исправляют и закрывают, из-за чего получаем то что есть.
    >ремастеры 5 летних игр

    Нет таких.
    >ремастеры 10 летних игр

    За это время сменилось несколько версий DX, почти полностью изменилась звуковая подсистема и планировщик.
    Вы много актуального софта на Debian 6 можете запустить?

     
     
  • 6.47, Аноним (9), 14:53, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Я запускал пару лет назад rr2 там из debian 3 либы. Ничего не изменилось. Esd и arts сейчас уже нет, но oss работал через эмуляцию в alsa. Наверное, самое неприятное -- это sdl1 сегодня.
     
  • 4.61, 404 (?), 15:17, 17/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    1й квейк, помнится, пытался запустить в середине нулевых на венде. Тоже читал статейке Джоела Спольски что мол в венде все работает десятилетиями. Каково же было мое удивление
     
     
  • 5.64, пох. (?), 16:35, 17/07/2021 [^] [^^] [^^^] [ответить]  
  • –2 +/
    что дос-программа, напрямую оперирующая регистрами видеокарт, не совсем работает?
    нда, действительно, с чего бы это она...

     
     
  • 6.67, 408983 (?), 20:42, 18/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    > что дос-программа, напрямую оперирующая регистрами видеокарт, не совсем работает?
    > нда, действительно, с чего бы это она...

    думал, вы постарше. Не застали ещё? нет, не о досовом варианте речь.

     
     
  • 7.68, пох. (?), 22:39, 18/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Застал, наверняка где-то валяется на уже нечитаемом носителе. Досовскую.

    Она, конечно, запускалась под 95, но значительно лучше работала без нее. Обычный dos4gw там был.

    Или ты linoops версию под виндой пытаешься запускать? ;-) Да, была и такая. Толком не работала. Использовалась как сервер для мультиплейеров, я такое довольно долго поддерживал.


     
  • 4.62, 111 (??), 15:17, 17/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    1й квейк, помнится, пытался запустить в середине нулевых на венде. Тоже читал статейке Джоела Спольски что мол в венде все работает десятилетиями. Каково же было мое удивление
     
     
  • 5.63, 408983 (?), 15:18, 17/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    лол все никнеймы заняты
     
  • 3.56, Аноним (13), 11:00, 16/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    > Линуксовый бинарный софт прекрасно работает спустя 20 лет,

    Тонко, тонко.
    Я помню, софт, скомпиленный под 2.2, на 3.0 уже не запускался, и нет — он не требовал библиотек, а просто не запускался.

     
     
  • 4.57, Аноним (9), 11:07, 16/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Какое ведро было в debian-3?
     
  • 2.19, ryoken (ok), 08:07, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >>  При этом под виндой софт 10-15-летней давности чувствует себя спокойно, в большинстве случаев.

    Чушь. Попытайтесь погонять Дьяблу1 хотя бы под Вин7.

     
     
  • 3.21, Аноним (13), 08:54, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Не скажу за семёрку, а под десяткой просто запускается и работает.
     
  • 3.22, Аноним (22), 09:01, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Чушь. Попытайтесь погонять Дьяблу1 хотя бы под Вин7.

    И в чём проблема? Я играл в первую Дьяблу (большой любитель именно её за более мрачную готическую атмосферу) на вин7: полностью проходил одиночку и даже бегал в сетевую (там надо некоторые телодвижения, т.к. сетевая в ней через IPX, но это решалось, причём даже средствами самой венды).
    Все решалось средствами самой венды. Там по большому счёту проблем совместимости всего 2, и одна решается в 5 кликов, а вторая не всегда (и не у всех) и проявляется-то.

    И я именно о исходной дисковой версии, а то так-то на GOG вполне официально можно сейчас купить подпиленную в плане совместимости аж с 10-ой вендой версию.

     
  • 3.23, Аноним (23), 09:15, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +1 +/
    https://github.com/diasurgical/devilutionX
     
     
  • 4.37, ryoken (ok), 11:24, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > https://github.com/diasurgical/devilutionX

    Штука вроде неплохая по описанию, но вопрос был именно в запуске натуральной Дьяблы :D.

     
  • 3.24, Аноним (22), 09:17, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +3 +/
    >>  При этом под виндой софт 10-15-летней давности чувствует себя спокойно, в большинстве случаев.
    >Чушь. Попытайтесь погонять Дьяблу1 хотя бы под Вин7.

    P.S.
    Ну и да, к сказанному выше хочу напомнить, что Дьябла1 - это 96-ой год. Это "слегка" не заявленные выше 10-15, а все 25 (в 2 раза больше). И отлично работает. И вообще игрушки того времени работают отлично, если руки ровно росли у тех, кто игрушку писал. Мелкософт об обратной совместимости заботится (ну, точнее, заботилась) весьма тщательно. Это вот с портами от всяких там аспиров и фералов спустя 5 лет уже бывают проблемы такие, что проще вендовую версию в протоне запустить (и заодно получить еще и производительность выше, чем у порта).

     
     
  • 4.65, пох. (?), 16:39, 17/07/2021 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > (в 2 раза больше). И отлично работает. И вообще игрушки того
    > времени работают отлично, если руки ровно росли у тех, кто игрушку
    > писал.

    ну не факт - скорее, если у тех кто в microsoft пытался потом угадать, каких оптимизационных хаков (при raw-доступе к железке в real mode!) туда напихали и как их теперь эмулировать так чтоб хотя бы вся винда не навернулась, если еще и пара ошибок в этом коде окажется, все получилось удачненько.
    Охотно верю, что с кваком не получилось.


     
  • 3.30, kusb (?), 10:25, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Преимущество винды - упоротая обратная совместимость. Они вообще молоды в этом плане! Нет, серьёзно. Да? Ведь так?
    (Хотя в винде нельзя chroot, наверное)
     
  • 3.31, InuYasha (??), 10:33, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • –1 +/
    У меня д2 под семёркой работала много лет. До прошлого года. А теперь - не стартует. Вот, просто так. Режимы совместимости не помогают. Видать, какая-то софтина при установке покорёжила Шиндовс. Теперь только soundtrack в винампе слушать...
     
     
  • 4.36, вфц_вцф (?), 11:04, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Все запуститься с правильным wrapper'ом, для d2 есть glide wrapper, если проблема именно в библиотеках.
     
  • 3.46, 123 (??), 12:55, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    >Попытайтесь погонять Дьяблу1 хотя бы под Вин7.

    Отлично работает что на 7, что на 8.1, что на 10ке. NOX с лицушного диска бородатого года под десяткой запускается, только меню стартовое глючило до настройки совместимости. Red Alert 2 дисковая версия без патчей и плясок работает на 10ке. Warcraft 2 battlenet edition времён 98 шинды запускал на 7ке.

     
  • 2.28, kusb (?), 10:22, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Вот удваиваю, два минуса показывают отрицание ситуации, эх. Признание и решение проблемы помогли бы линуксу лучше чувствовать себя в качестве десктопной ос. И это же решают всякие модные пакеты, но этот подход какой-то не такой.

    Вот такой вопрос: пакетный менеджер управляющий не только пакетами, но и их версиями, причём с возможностью установки версии пакета относительно другого пакета помог бы? Будут странные проблемы? Какие?
    Например Steam Runtime несёт с собой отдельные версии библиотек и там были проблемы для решения которых рекомендовали удалять библиотеки из Runtime (после этого наверное используется системная). Почему это происходит?

     
     
  • 3.29, kusb (?), 10:23, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • –1 +/
    (Модные пакеты - snap, flatpak)
     
  • 3.35, A.Stahl (ok), 10:58, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >Будут странные проблемы? Какие?

    Кроме нытья пары старпёров, никаких. Вообще, думаю, можно даже создать проект, который будет подтягивать из какого-то архива старые либы, требуемые бинариком и всё это забрасывать в одну кучу. Так, чтобы эти либы вообще никак, даже теоретически, не могли что-то испортить другой программе.

    Но это нужно упороться и сделать. А это много работы.

     
     
  • 4.55, Аноним (22), 10:28, 16/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Не нужно упарываться: всё уже сделано до тебя. NixOS (и тамошний пакетный манагер) обеспечивают вот то самое разделение пакетов и требуемых им либ и чтобы они друг другу не мешали.
     
     
  • 5.58, n00by (ok), 13:39, 16/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Выше речь шла про бинарник, то есть готовый исполняемый файл. То есть вот эту вот работу, когда "мантайнер" с умным видом запускает ldd, чешет репу и  ̶ж̶д̶ё̶т̶ ̶е̶б̶и̶л̶д̶о̶в̶  принимается творчески перерабатывать пакетик из соседней ОС под имеющийся пакетный менеджер -- её может выполнить программа в ряде случаев.
     

  • 1.17, Аноним (17), 07:50, 15/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Так есть же эмулятор bsnes со 100% совместимостью.
     
  • 1.32, InuYasha (??), 10:45, 15/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    /me уже лет 20 как пользователь zsnes.
    Сколько воспоминаний! Chrono Trigger, Bomberman, Battle Toads... :_)
    Больших успехов проекту!
     
  • 1.41, Аноним Вопрошающий (?), 11:59, 15/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А что со snes9x-то стало?
     
     
  • 2.43, Аноним (43), 12:09, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Пользоваться можно. Интерфейс на WinApi простой и удобный. Интерфейс на GTK2 кривой и глючный. Под Линуксом ZSNES удобнее.
     

  • 1.42, Аноним (43), 12:07, 15/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Форку всё ещё требуются 32-разрядные библиотеки?
     
     
  • 2.44, Аноним (43), 12:12, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Судя по README, по-прежнему, будет собираться только 32-битный бинарник под x86. SDL2 — в отдалённых планах.
     
  • 2.51, Kuromi (ok), 16:36, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    > Форку всё ещё требуются 32-разрядные библиотеки?

    Насколько я помню там тонна ассемблера, так что по простому адаптировать под 64 бит не выйдет.

     
     
  • 3.54, Анонимный доброжелатель (?), 22:34, 15/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    Это форк https://github.com/ericpearson/zsnes/commits/cport , там в коммитах сплошь "Translate ... to C"
     

  • 1.60, Аноним (60), 16:59, 16/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > Автор форка взялся за расчистку проблем со сборкой и приступил к обновлению кодовой базы

    Это супер, я бы сам занялся если бы не было более полезных проектов. Есть другие эмуляторы, но zsnes очень ламповый.

    > Исходный проект zsnes не обновлялся уже 14 лет и при попытке его использования возникают проблемы с компиляцией в современных дистрибутивах Linux, а также имеются несовместимости с новыми компиляторами

    Не забудьте ещё про переносимость (оригинальный код i386-only с кучей ассемблера) и проблемы с безопасностью.

     
  • 1.66, Xasd7 (?), 15:43, 18/07/2021 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    где вы берёте сами образы игрулей?
     
     
  • 2.69, Аноним (69), 23:56, 18/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    В интернете.
     
  • 2.71, Kuromi (ok), 03:44, 30/07/2021 [^] [^^] [^^^] [ответить]  
  • +/
    > где вы берёте сами образы игрулей?

    Раньше было дохрена сайтов в образами (и даже хаками\модами). Все лежало свободно т.к. вцелом правообладателям было не очень интересно все это. С появление всяких "виртуальных консолей", встроенных эмуляций и магазинчиков старые игры снова стали ликвидным товаром и на сервисы пошло юридическое давление. Скачать можно и сейчас, но уже и сложнее и выбор похуже стал.

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2021 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру