The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Защита пакетов, установленных из определенного Yum репозитория
Для того, чтобы гарантировать, что пакеты, установленные в CentOS / RHEL из
определенного внешнего Yum-репозитория не будут переустановлены/обновлены при
появлении более новых версий подобных пакетов в других репозиториях можно
использовать плагин yum-protectbase.

Устанавливаем плагин:

   yum install yum-protectbase 

Активируем плагин, добавив в /etc/yum/pluginconf.d/protectbase.conf

   [main]
   enabled = 1

Находим репозиторий, который нужно защитить в директории /etc/yum.repos.d и
добавляем в конфигурацию опцию

   protect = 1

Например, для репозитория epel в файле /etc/yum.repos.d/epel.repo меняем:

   [epel]
   name=Extra Packages for Enterprise Linux 5 - $basearch
   #baseurl=http://download.fedoraproject.org/pub/epel/5/$basearch
   mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=epel- 5&arch=$basearch
   failovermethod=priority
   enabled=1
   gpgcheck=1
   gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL
   protect = 1
 
29.10.2009 , Источник: http://www.cyberciti.biz/faq/rhel-c...
Ключи: redhat, centos, yum / Лицензия: CC-BY
Раздел:    Корень / Администратору / Система / Linux специфика / Установка и работа с пакетами программ в Linux

Обсуждение [ RSS ]
  • 1, аноним (?), 11:21, 03/11/2009 [ответить]  
  • +/
    бред какой-то, а что по умолчанию оно автоматом обновляется?
     
     
  • 2, Аноним (-), 11:58, 03/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >бред какой-то, а что по умолчанию оно автоматом обновляется?

    Там про ситуацию, когда один пакет  одновременно доступен в нескольких репозиториях, но использовать нужно только из одного, даже если во втором вышла более новая версия.

     
  • 3, Serg (??), 15:11, 03/11/2009 [^] [^^] [^^^] [ответить]  
  • –1 +/
    именно так. У меня в CentOS было такое с postfix - обновление полезно из другого репозитория
     

  • 4, fi (ok), 15:13, 08/11/2009 [ответить]  
  • +/
    вещь нужная, но не решает всех проблем - вот на днях одна из либ в dag-e обновилась, а те которые ее требует - по прежнему со старой слинкованны.

    а есть проги которые требуют разные либы!!!  одну с epel, другую с  dag :)

    нужно делать таг в rpm - "либа" - чтоб несколько ставилось без конфликтно.


     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:




    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2021 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру